MozillaZine

Search: Google.com auto redirect to google.co.uk

Discussion of general topics about Mozilla Firefox
gnikiV
 
Posts: 16
Joined: September 15th, 2004, 12:07 pm

Post Posted December 13th, 2004, 5:52 am

I want default google search to be Google.com. It's not. It's Google.co.uk (I want to use Mycroft google.co.uk later).

As it stands at the moment, I not only get redirected from Google.com to Google.co.uk at the beginning of a search. But if I type www.google.com/ in the URL address bar I still end up with www.google.co.uk.

As a hexperiment, I installed both en-GB and en-US - both do the same.

<B>Make it stop.</B> I have flu and a very short temper - something's having it shortly.

Fanks awfully chaps ;)

David H
 
Posts: 2254
Joined: June 13th, 2003, 5:17 am
Location: Japan

Post Posted December 13th, 2004, 6:06 am

It's the Google site detecting your locale. I get the same thing with Google Japan. I don't know how they do it exactly, my guess is by IP address range. What you need to do is set your preferences in Google. There should be a "preferences" link next to the Google search bar on their main page. You'll need to accept a cookie from them to make the settings stick.

radgie
 
Posts: 348
Joined: October 25th, 2003, 4:08 pm
Location: Newcastle upon Tyne, UK

Post Posted December 13th, 2004, 6:10 am

You can deal with this by going to the site for adding new search engines and using it to add Google, whatever country you like.
HERE

If you want to delete search engines look in the search plug ins folder in your main Firefox program folder
May We Live In Interesting Times
To Wives And Sweethearts. And Shall Never The Two Meet

Greg K Nicholson

User avatar
 
Posts: 1328
Joined: September 28th, 2003, 8:58 am

Post Posted December 13th, 2004, 7:09 am

Click Go to Google.com.

gnikiV
 
Posts: 16
Joined: September 15th, 2004, 12:07 pm

Post Posted December 13th, 2004, 7:48 am

David H - I think I agree with you - but no applicable preferences that I see.

radgie - You can delete all of the search plugins and start from scratch - but it still makes no difference, the google.com (netscape) search plugin still redirects me to google.co.uk.

Greg K - If I click on <B><I>Go to Google.com</I></B> from the google.co.uk page. I still arrive at google.co.uk.


One thing that does work for me, to get Google.com, without redirection, is using http://www.google.com/webhp URL. But that's manually typed or bookmarked - not from Firefox google search.

David H
 
Posts: 2254
Joined: June 13th, 2003, 5:17 am
Location: Japan

Post Posted December 13th, 2004, 8:10 am

Hmm, you're right about the setting. I was working by memory so my recollection was a bit off. For me, setting the display to English changed it back to Google.com. Not sure what you can do when both sites are already English though.

Clicking to Google.com always worked for me also. Of course, I hated that because it always required that extra click to get there. You should be able to go there directly.

One thing you can do about the search engine plugins is edit the google.src file (found in your installation directory/searchplugins subdirectory) and change the Google.com url to the http://www.google.com/webhp one. Just open it up in a text editor and change the url. Hopefully that will work for you.

Truthfully, as much as I like Google as a search engine and as a company, I really hate that redirect thing. When I click on Google.com, I want to go to Google.com, not to some other page they think I would rather go to. If I want to go to Google.co.jp, I'll go there myself, thank you very much.

Greg K Nicholson

User avatar
 
Posts: 1328
Joined: September 28th, 2003, 8:58 am

Post Posted December 13th, 2004, 8:11 am

gnikiV wrote:If I click on <B><I>Go to Google.com</I></B> from the google.co.uk page. I still arrive at google.co.uk.
Do you have cookies enabled for google.com?

gnikiV
 
Posts: 16
Joined: September 15th, 2004, 12:07 pm

Post Posted December 13th, 2004, 9:01 am

<B>David H</B> - We're singing from the same hymn sheet. Ditto everything about Google (cept I don't accept their cookies usually) and the wierd thing is, I already tried the http://www.google.com/webhp .src edit and the damn thing still redirects me back to google.co.uk ...another hack somewhere maybe ?

<B>Greg K</B> - Yes, you're right, if you accept cookies for google (I don't deliberately, usually - but have now tried with and without), you can do what you suggested, but alas, that still doesn't alter the default Firefox search problem.

gnikiV
 
Posts: 16
Joined: September 15th, 2004, 12:07 pm

Post Posted December 14th, 2004, 2:43 am

bump for a fresh pair of eyes.

Magus
 
Posts: 2022
Joined: November 28th, 2002, 11:39 am
Location: that-a-way ->

Post Posted December 14th, 2004, 3:36 am

Correct answer: http://www.google.com/ncr

ncr = No Country Redirect

You must allow Google to set cookies, or the pref won't stick.

Edit: Ok, just noticed that this is what the "Go to google.com" links to, but it is the only option.
For every action there is an equal and opposite criticism.

gnikiV
 
Posts: 16
Joined: September 15th, 2004, 12:07 pm

Post Posted December 14th, 2004, 7:08 am

Magus - Thanks, it's a definite Google thing. I fresh installed a en-GB and directly edited .src with google.com/nrc, accepted the cookie and It worked ! - I smiled and all was well.

Well the Firefox search worked <B>once</B> using that, then no more. I then got consistant...

Not Found
The requested URL /nrc?q=horseshit&start=0&start=0&ie=utf-8&oe=utf-8&client=firefox-a&rls=org.mozilla:en-US:official was not found on this server.


So I edited back to google.com/search, which is the redirect for google.co.uk, and sure enough the search box works properly, but I have google.co.uk redirection.

So I'll try and get an explanation/answer from google (unless more ideas are forthcoming) as I don't want a redirection to .co.uk when I specifically want google.com from my default Firefox search box.

chipili
 
Posts: 1
Joined: February 2nd, 2005, 3:39 am

Post Posted February 2nd, 2005, 3:47 am

I have UK search in Google but I'm in Australia and I can't figure out how to change the country setting.

My PC, XP and IE-Google all think Australia but Mozilla-Google thinks UK

Greg K Nicholson

User avatar
 
Posts: 1328
Joined: September 28th, 2003, 8:58 am

Post Posted February 2nd, 2005, 4:56 pm

chipili wrote:I have UK search in Google but I'm in Australia and I can't figure out how to change the country setting.

My PC, XP and IE-Google all think Australia but Mozilla-Google thinks UK
This might work: enter about:config into the location bar; type general.useragent.locale into the Filter text field and change the value to en-AU (double-click). If it's already en-AU, I'm out of ideas.

Return to Firefox General


Who is online

Users browsing this forum: No registered users and 4 guests