MozillaZine

Most recent STABLE version?

Discussion of general topics about Mozilla Firefox
merry widow

User avatar
 
Posts: 86
Joined: October 13th, 2010, 9:32 am

Post Posted September 12th, 2017, 10:32 pm

If you look at my signature you'll see version 52~~ . Not anymore. I risked using an experimental addon on the Firefox version you see in my signature and my computer went into meltdown, I kid you not. I had to do a hard shutoff of my computer and reboot before XP would allow me to remove the program! I know you're going to ask me which addon but I'll have to hunt through my FF history (that is, if I still have history buried somewhere :-k any help appreciated).

What is the most version-compatible, addon-friendly older version of FF? And I'll need the full version [-X not a live-install. I have never in my life seen a browser do what this one addon did. Yikes.

Recommend? Thanks guys.
____________________________
As of 2017-09 using Firefox 52.3.0

JayhawksRock

User avatar
 
Posts: 10412
Joined: October 24th, 2010, 8:51 am

Post Posted September 12th, 2017, 11:11 pm

Latest version of ESR 52.3.0 is working just ducky for me on WinXP....
I'm posting with ESR 49 on WinXP
All 17 of my extensions are working well... on both
and also on SeaMonkey 2.47
"The trouble with quotes on the internet is you never know if they are genuine" ...Abraham Lincoln

merry widow

User avatar
 
Posts: 86
Joined: October 13th, 2010, 9:32 am

Post Posted September 13th, 2017, 12:39 am

Howdy JR. XP here, as well. Installed v. 50 and (as is so often the case with FF) grinding. Endless, Endless grinding away. So I deleted a bunch of Addons and I'll cross my fingers that opening FF on a new computer boot won't sound like gravel. Quiet as a mouse right now (said the shore to the ocean just before the tsunami).
____________________________
As of 2017-09 using Firefox 52.3.0

Omega X

User avatar
 
Posts: 7843
Joined: October 18th, 2007, 2:38 pm
Location: A Parallel Dimension...

Post Posted September 13th, 2017, 4:10 am

Latest: Firefox/55.0.3 *ESR/52.3.0 - Mobile/55.0.2 - Thunderbird/52.3.0 - SeaMonkey/2.46
Nightly: Nightly/57.0a1 - Mobile/57.0a1 - Daily/52.0a1 - SeaMonkey/2.49a1

James
Moderator

User avatar
 
Posts: 26950
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted September 13th, 2017, 2:43 pm

Firefox 52 ESR and Thunderbird 52.X.x Releases (updates like a ESR) are the last versions to work on the EOL WinXP and Vista. 53.0 and later versions require Windows 7 or later to run.

Firefox 52.8.0esr will be out when Firefox 60.0 is Released in May 2018 and will be last unless support is extended.

merry widow

User avatar
 
Posts: 86
Joined: October 13th, 2010, 9:32 am

Post Posted September 13th, 2017, 11:41 pm

Omega X & James:
I'm not a large organization.
I'm not a group.
There is no deployment because there is no mass.

I'm on Version 50, newly shorn of about 2/3 of my addons so it didn't sound like gravel being (I have to, sorry) ... deployed. :mrgreen:
____________________________
As of 2017-09 using Firefox 52.3.0

malliz
Folder@Home

User avatar
 
Posts: 43140
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted September 14th, 2017, 12:32 am

Yes we know the definitions. We also know that ESR is the best answer for people who at this stage are not willing or able to upgrade to the latest release. Try not to be clever it makes thinks more difficult
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

James
Moderator

User avatar
 
Posts: 26950
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted September 14th, 2017, 1:10 am

merry widow wrote:Omega X & James:
I'm not a large organization.
I'm not a group.
There is no deployment because there is no mass.

I'm on Version 50, newly shorn of about 2/3 of my addons so it didn't sound like gravel being (I have to, sorry) ... deployed. :mrgreen:

The ESR channel was originally intended for enterprise users in mind yes.

In fact back in March 2017 Mozilla upgraded Firefox users on WinXP/Vista to the Firefox 52.0 ESR in upgrades so these users can still get Firefox security and allowed stability fixes for a while yet.

Firefox 52.0.1 and older Releases does not and will not get Any new security and or stability fixes. Firefox 53.0 and later versions does not run on WinXP/Vista as Win7 is the minimum.

So you can either use Firefox 52 ESR or use a older Release (like the Fx 50.0 that you think is good to use) that will get more and more vulnerable over time. https://www.mozilla.org/security/known-vulnerabilities/

merry widow

User avatar
 
Posts: 86
Joined: October 13th, 2010, 9:32 am

Post Posted September 15th, 2017, 9:58 am

Well this is interesting. I installed Firefox Setup 52.3.0esr.exe and my tabs stand upright. There hasn't been any grinding noise because none of my addons installed. I'm going to pay strict attention to the appearance of my tabs as I add each new addon and report it here. Thanks so much James.
____________________________
As of 2017-09 using Firefox 52.3.0

Return to Firefox General


Who is online

Users browsing this forum: No registered users and 5 guests