MozillaZine

Change default homepage for all users?

Discussion of general topics about Mozilla Firefox
bashar19
 
Posts: 4
Joined: May 25th, 2006, 7:27 am

Post Posted May 25th, 2006, 7:36 am

Hello,
How are you guys doing? I installed FireFox 1.5 here and I'd like to change the home page so that it starts on something like www.google.ca

I looked in the about:config section of FireFox, changed it there but didnt seem to do that for all users.

I made sure all their local profiles under "C:\documents and settings\". Even if i login under a new user and it creates everything, it still doesnt do that.

I looked under the folders and .js files and couldnt see anything.

any tips are appriciated it.

Sorry if this has been posted here before and/or if i have posted this in the wrong section.


Thank you,
Bashar

dickvl

User avatar
 
Posts: 51507
Joined: July 18th, 2005, 3:25 am

Post Posted May 25th, 2006, 12:28 pm

You can put this in user.js
Code: Select all
user_pref("browser.startup.homepage", "http://www.google.ca/");


If you put that file also in C:\Program Files\Mozilla Firefox\defaults\profile\
Then it will be copied to new profiles.

bashar19
 
Posts: 4
Joined: May 25th, 2006, 7:27 am

Post Posted May 25th, 2006, 12:44 pm

dickvl wrote:You can put this in user.js
Code: Select all
user_pref("browser.startup.homepage", "http://www.google.ca/");


If you put that file also in C:\Program Files\Mozilla Firefox\defaults\profile\
Then it will be copied to new profiles.

Hello,
I am Suppose to create the user.js file? or it should already be there under the directory you gave me?

Cause I checked in there and I didnt see a user.js file in there.


Thanks

dickvl

User avatar
 
Posts: 51507
Joined: July 18th, 2005, 3:25 am

Post Posted May 25th, 2006, 12:51 pm

As you can read in this section: "Creating the user.js file" (user.js)
You need to create that file.
It's not there by default.
Use a plain text editor like Notepad and make sure you save it as user.js (choose all files or add "user.js") and that Notepad doesn't append .txt to the name.

bashar19
 
Posts: 4
Joined: May 25th, 2006, 7:27 am

Post Posted May 25th, 2006, 1:12 pm

dickvl wrote:As you can read in this section: "Creating the user.js file" (user.js)
You need to create that file.
It's not there by default.
Use a plain text editor like Notepad and make sure you save it as user.js (choose all files or add "user.js") and that Notepad doesn't append .txt to the name.

Thanks! I created the file and delete the profiles for the users and it still didnt work.

Thanks

sheehan
 
Posts: 1398
Joined: March 30th, 2004, 4:07 pm
Location: Canada

Post Posted May 25th, 2006, 1:23 pm

Do you want this to be reflected on existing users or for new users? If it for new users, you need to place the user.js in the default profile area e.g. C:\Program Files\Mozilla Firefox\defaults\profile

dickvl

User avatar
 
Posts: 51507
Joined: July 18th, 2005, 3:25 am

Post Posted May 25th, 2006, 1:40 pm

The first time you start Fx you will get the update page.
On subsequent starts you should be getting the home page.
If not then use this in user.js (copy/paste)
Code: Select all
user_pref("browser.startup.homepage", "http://www.google.ca/");
user_pref("browser.startup.page", 1);

Add this line if you don't want the update site:
Code: Select all
user_pref("startup.homepage_override_url", "http://www.google.ca/");
Make sure you add a line break (press <enter>) to end the last line.

Racer
 
Posts: 6108
Joined: November 18th, 2002, 11:07 am

Post Posted May 25th, 2006, 1:42 pm

If you want it done to all users, you should add the pref line to all.js file in the Firefox application folder (\Firefox\greprefs\all.js)

bashar19
 
Posts: 4
Joined: May 25th, 2006, 7:27 am

Post Posted May 25th, 2006, 1:43 pm

dickvl wrote:The first time you start Fx you will get the update page.
On subsequent starts you should be getting the home page.
If not then use this in user.js (copy/paste)
Code: Select all
user_pref("browser.startup.homepage", "http://www.google.ca/");
user_pref("browser.startup.page", 1);

Add this line if you don't want the update site:
Code: Select all
user_pref("startup.homepage_override_url", "http://www.google.ca/");
Make sure you add a line break (press <enter>) to end the last line.

Thanks! I will be trying that.

Now another question is.. how do I disable to "Popup Blocker" or "Block Popup Windows" for all user? cause thats another option that gets set through admin but doesnt apply to users.

Do I do the same thing using the user.js file? if so, can you give me the coding for that?

Appriciate your help.


Thanks,
Bashar

dickvl

User avatar
 
Posts: 51507
Joined: July 18th, 2005, 3:25 am

Post Posted May 25th, 2006, 2:16 pm

You can look here for info about prefs: about:config
(some have an article: http://kb.mozillazine.org/Category:Preferences)

See: dom.disable_open_during_load

Return to Firefox General


Who is online

Users browsing this forum: No registered users and 6 guests