MozillaZine

Is there a way to stop floating videos?

Discussion of features in Mozilla Firefox
mightyglydd

User avatar
 
Posts: 9036
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted July 5th, 2017, 6:17 pm

Excellent feature, love it.
Watch the vid and read/scroll the article.
#KeepFightingMichael

Jimac
 
Posts: 5
Joined: May 11th, 2017, 9:23 am

Post Posted July 9th, 2017, 6:10 am

therube wrote:URL to these floating videos?


The floating, or sticky, video player happens on the high traffic websites bloomberg.com and dailymail.co.uk. Any news article with a video player, which is nearly all of them,

On Bloomberg after the site loads the video, it auto plays with sound without asking permission and when scrolling down, the player shrinks and continues playing on the right with no way to close it, no "x" or "close" that I can find. On Daily Mail it auto plays after scrolling and thankfully it can be closed. If you scroll back up and down again, however, it all begins again. It's a javascript function because blocking js on the page, such as with the YesScript add-on, stops it from happening, but you lose other js functions that you may want, so it's not a perfect solution. Somebody needs to invent a Stop Sticky Video Player add-on for Firefox, if technically possible.

My system: I am using FF 54.0.1 (32 bit), private browsing mode, 14" Windows 10 laptop, not yet offered the Creators 10 Update. These described effects may be different or the same on tablets, phones, and other responsive design screens; haven't tried them.

Follow-up edit: losangeles.cbslocal.com also does it.
Last edited by Jimac on July 9th, 2017, 7:34 am, edited 1 time in total.

loby
 
Posts: 19
Joined: September 16th, 2010, 12:00 am

Post Posted July 9th, 2017, 7:17 am

solution with Ublock, it works for me
add this in "my filters"
Code: Select all
dailymail.co.uk##.vjs-flyout-placeholder
source

Jimac
 
Posts: 5
Joined: May 11th, 2017, 9:23 am

Post Posted July 9th, 2017, 7:47 am

In the source you give, a commenter on the discussion thread on Reddit about Ublock (available as a Firefox add-on) and the block code you give above says that it also stops the main video from downloading so you can't watch it at all. Is that true? I notice on Daily Mail if I block the sticky player using YesScript, the main player just shows a blank gray screen with a center click button, which gives the impression it's blocked, but if you click on the gray screen the video will actually play.

flimbo
 
Posts: 29
Joined: April 29th, 2011, 4:43 am

Post Posted July 9th, 2017, 8:14 am

The greasemonkey script that was posted earlier in the thread does the job.

agentalbert
 
Posts: 9
Joined: October 28th, 2016, 5:05 pm

Post Posted July 19th, 2017, 5:56 pm

loby wrote:solution with Ublock, it works for me
add this in "my filters"
Code: Select all
dailymail.co.uk##.vjs-flyout-placeholder
source


Aces! This works for me too. I disabled Greasemonkey to make sure it was only this script doing the job, and the video box never opens, never slides down the screen, nothing.

:-D

jackpot
New Member
 
Posts: 1
Joined: August 3rd, 2017, 11:12 am

Post Posted August 3rd, 2017, 11:17 am

I have managed to stop the video autoplaying on the Daily Mail site, it still jumps down
to the right-hand corner but at least it is now slightly less annoying


1 Type "about:config" into the URL bar
2 Agree to the warning
3 Type “autoplay” into the search box
4 Find a preference named “media.autoplay.enabled”, which will be set to "true"
5 Double-click that preference and it will change to "false"

hope this helps
jackpot

Jimac
 
Posts: 5
Joined: May 11th, 2017, 9:23 am

Post Posted August 9th, 2017, 9:07 am

The Firefox add-on "Autoplay Toggle" allows you to turn autoplay on and off by clicking its toolbar icon. It won't stop the sticky video player however.

As I've posted earlier, the on/off javascript toggler add-on "YesScript" will stop both autoplay and the drop-down player, but it also stops everything else on a page requring javascript including the comments section. On the Drudge Report, it stops some photos from appearing that are using javascript to display them. You have to toggle it back on and refresh the page to see or use features requiring javascript, so it's not a perfect solution.

I haven't yet tried "Autoplay Toggle" or the Ublock method described above. Be sure to read the reviews for "Autoplay Toggle" for tips on how to use it.

https://addons.mozilla.org/en-US/firefox/addon/autoplay-toggle/

https://addons.mozilla.org/en-US/firefox/addon/yesscript/

ChrisLongski
 
Posts: 3
Joined: June 30th, 2017, 3:50 pm

Post Posted August 15th, 2017, 11:30 am

For the Experts posting 'solutions' here - just tell the poster you don't know. How many do you think will get into all that coding junk below ?

BeedyN
 
Posts: 1
Joined: August 20th, 2017, 4:17 am

Post Posted August 20th, 2017, 4:38 am

I too had tried everything.. Ghostery, UBlock, disabling all video plugins.. nothing worked

I MAY have found a solution (this is for firefox but I dare say other browsers have similar settings). The floating video popup occurs when your scroll or pass over an "auto running video" highlight clip of a story. So the trick is to stop that running. That can be done in the advanced config settings of Firefox.

Open a new Tab in Firefox and in the address bar type

About:config

Click on the accept risk button. On the resulting page type the following into the search box at the top of the window

media.autoplay (the actual entry is media.autoplay.enabled but typing the first part wil lfind the line entry)

Check the value of the last column on the line entry.. it probably says "True". If so, right mouse button click on the line and choose "Toggle", which turns it to false. Close that page and then restart Firefox. Go back to the offending news website (DM) and test it. It seems to work for me. I did this about 4 months ago but since wiped my computer and forgot about this setting until today. I have a sneaky feeling this config setting does affect other video streaming websites.. the main one being youtube which autoplays one suggested video after another... so all you need to do is change the setting back (which takes no more than 30 secs) for those websites you don't want that function to work (if you see what I mean).

I hope this works for everyone else

Bryan

ChrisLongski
 
Posts: 3
Joined: June 30th, 2017, 3:50 pm

Post Posted September 2nd, 2017, 3:44 pm

Not a practical solution for the pedestrian-level user. They'll see the code you posted and click out...

Protocol

User avatar
 
Posts: 433
Joined: October 18th, 2003, 12:44 am

Post Posted November 5th, 2017, 10:22 pm

jackpot wrote:I have managed to stop the video autoplaying on the Daily Mail site, it still jumps down
to the right-hand corner but at least it is now slightly less annoying


1 Type "about:config" into the URL bar
2 Agree to the warning
3 Type “autoplay” into the search box
4 Find a preference named “media.autoplay.enabled”, which will be set to "true"
5 Double-click that preference and it will change to "false"

hope this helps
jackpot

To stop the Daily Mail videos automatically popping up and playing, just add the following line to your adblocker.
dailymail.co.uk##.vjs-flyout-placeholder

Return to Firefox Features


Who is online

Users browsing this forum: No registered users and 2 guests