MozillaZine

AUTOCOMPLETE attribute not ignored?

Discussion of features in Mozilla Firefox
xerces8
 
Posts: 189
Joined: September 20th, 2005, 6:46 am

Post Posted February 9th, 2015, 12:13 pm

According to Site Compatibility for Firefox 30, the <form autocomplete="off"> no longer prevents passwords from being saved.

But i just tried this page : https://aips.um.si/Prijava.aspx
And neither the username or the password are remembered.

On this page: https://area51.phpbb.com/phpBB/ucp.php?mode=login
The username is remember right away, while for the password is asks.

(just enter any value for testing)

The first one uses the AUTOCOMPLETE="off" attribute.

So what is the state of AUTOCOMPLETE support?
Wasn't it removed?

In older versions of Firefox I could "hack" one of the XUL script files to ignore AUTOCOMPLETE completely and life was nice.
Now the code is changed and AUTOCOMPLETE is there to dictate browser behavior...

Any hints how to make FF remember entered form data in spite of AUTOCOMPLETE=off ?

Regards,
David

patrickjdempsey

User avatar
 
Posts: 23734
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted February 9th, 2015, 7:15 pm

AFAIK, the behavior was not completely disabled, but enabled only for type="password" forms. For passwords, the Password Manager popup should appear asking you if you want to store this password.

There are reasons why it might not work right:

- If the following preference has been set to false:
signon.storeWhenAutocompleteOff

- If you have previously visited this site and clicked Don't Remember on the password manager popup. You can sort that out on the about:permissions page, or in Page Info Permissions tab.

- If the website isn't properly using type="password" on the form, which doesn't appear to be the case here.

- If you are using a 3rd-party Password Manager that isn't configured properly.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

Gingerbread Man

User avatar
 
Posts: 7742
Joined: January 30th, 2007, 10:55 am

Post Posted February 10th, 2015, 7:38 am

xerces8 wrote:(just enter any value for testing)

I don't think that's going to work for aips.um.si, where the site checks if the credentials are correct via an XML request (so you end up staying on the same page if you enter fake info).

Do the following.
  1. Start Firefox in a brand new profile.
    https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
  2. Type about:config into the address bar and press Enter.
  3. To bypass the warning, press the big button labeled "I'll be careful, I promise!".
  4. In the search box, paste signon.debug
  5. In the search results, double-click signon.debug to change its value to true.
  6. Click the ≡ Menu Button, then the Developer icon (the wrench), then Browser Console.
  7. In the Browser Console window, click the drop-down arrow next to Net and CSS and make sure everything is unchecked in those menus. Click the drop-down arrows next to JS, Security and Logging and make sure everything is checked in those menus.
  8. Click the Clear button.
  9. Load the login page.
    https://aips.um.si/Prijava.aspx
  10. Log in to the website (that is, submit valid login information).
  11. After you're logged in, go back to the browser console if you still didn't get the doorhanger notification to save the password — also look on the left side of the address bar for a key icon; click it if it's there. Right-click an empty area, then choose Select All. Right-click the selection and choose Copy.
  12. Now file a new bug report.
    https://bugzilla.mozilla.org/enter_bug.cgi?product=Toolkit
    Give it a descriptive title, like “Password saving not offered on aips.um.si”. Put the report in Product: Toolkit, Component: Password Manager. In the description of your report, include the debug information from the browser console that you copied to the clipboard. Once you've filed the report, post the link to it in a reply here.
xerces8 wrote:On this page: https://area51.phpbb.com/phpBB/ucp.php?mode=login
The username is remember right away, while for the password is asks.

autocomplete="off" isn't used there, so I don't see what that page has to do with this topic. Anyway, Firefox has never remembered passwords without asking first. I don't think the username field has ever gotten special treatment, so as long as you have “Remember search and form history” checked, it'll be remembered. So nothing unusual about that page.
xerces8 wrote:So what is the state of AUTOCOMPLETE support?

autocomplete="off" works exactly as described in the article you linked to: it tells the browser not to automatically fill out that form field. To have Firefox fill out that field, you have to either double-click the username field and pick your username, or type in the first letter, then select the username from the list. Example:
https://mail.live.com

xerces8
 
Posts: 189
Joined: September 20th, 2005, 6:46 am

Post Posted February 10th, 2015, 2:31 pm


patrickjdempsey

User avatar
 
Posts: 23734
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted February 10th, 2015, 2:43 pm

Autocomplete=off is only disabled for "password" type inputs. Because this page has autocomplete=off on the username "text" type input as well, the username is not filled. If you type the username in, does the password not complete?
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

xerces8
 
Posts: 189
Joined: September 20th, 2005, 6:46 am

Post Posted February 11th, 2015, 3:38 am

No, it is never remembered (the password).
Unless it is remembered without asking (and then still not used to autofill).

Return to Firefox Features


Who is online

Users browsing this forum: No registered users and 1 guest