MozillaZine

Alt+S occupied in 2.0b1

Discussion of features in Mozilla Firefox
old zeniko
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted November 21st, 2006, 9:34 am

galapogos wrote:After changing the ui.key.chromeAccess and ui.key.contentAccess, Alt-S works, but Alt-C to clear download history doesn't work anymore. Does anyone know why?

Maybe because you've told Firefox to use Alt+Shift shortcuts for browser related shortcuts (i.e. Alt+Shift+C should clear the download history)? If that was the case, just reset ui.key.chromeAccess to 4 and all accesskeys will only use Alt - as was the case for Firefox 1.5 and earlier...

neilthecellist
 
Posts: 5
Joined: November 5th, 2006, 5:18 pm
Location: San Diego, CA

Post Posted November 22nd, 2006, 3:27 pm

Ok, this is starting to really annoy me.

Wikipedia uses shortcuts, for editing, for watching a page, for discussion of pages, for adding on.... I can't use any of my beloved shortcuts anymore.

Is there a function in Firefox that can COMPLETELY DISABLE all the crap shortcuts present? (File / Edit / View / History / Bookmarks / Tools / Help) ? I hate it all. And now when I try to go back to 1.5 , the shortcuts still exist. It's pissing me off. So I'm not allowed to revert anymore. I want my old settings back.

MadMax_nz
 
Posts: 1
Joined: December 9th, 2006, 2:06 am

Post Posted December 9th, 2006, 2:16 am

stonedyak wrote:Yes, I found this change annoying too. You can either use Shift-Alt+S to submit or you can change it back to how it was using about:config
Change:
ui.key.chromeAccess to 5
ui.key.contentAccess to 4

This will allow you to use Alt for webpage shortcuts and Shift-Alt for Firefox's menu shortcuts
thanks for that. when a page doesn't use shortcuts, alt+s etc still opens the menus with that change.

luku
 
Posts: 3
Joined: December 10th, 2006, 5:19 am

Post Posted December 10th, 2006, 8:21 am

I've tried all this, but I just can't seem to get it to work.
Every time I press ALT-S I just get the History menu :/

EDIT:

Nevermind! The userchrome.css workaround was what I needed, was just not easy finding the file on Vista :P

Threk
 
Posts: 8
Joined: July 18th, 2005, 9:39 pm

Post Posted December 29th, 2006, 3:48 pm

Well I just got an irate phone call from a client who was very angry that we'd "removed the keyboard shortcuts from their website"

Thank you so much for fixing that bug where people using a non standard configuration would get conflicts, and making it so Firefox's default configuration is more confusing.

Oh and on the whole numbers of browsers debate. By pretty much every account IE still has well over half the market. This means that (as much as I loath both IE and Microsoft) IE's behavior IS THE STANDARD for most users. (Google "accesskey tag" and look at what key the top 2 results say to use)

I think that the new behavior of Firefox should have been a configuration option available for people who wanted to use the ALT key for other things, but NOT AS THE DEFAULT behavior. I think there will be a lot of people who will be upset at having this forced on them.

Now I get to test the workaround (which I assume will work) and then call my client back and walk them through it on the phone (whee)

old zeniko
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted December 29th, 2006, 4:22 pm

Threk wrote:Well I just got an irate phone call from a client who was very angry that we'd "removed the keyboard shortcuts from their website"

So? Tell them that their browser works differently and adjust your online documentation (should you have any) and you're pretty much done. While you're at it: Opera uses Shift+Esc and Safari and Konqueror use Ctrl to trigger those shortcuts; Firefox and other Mozilla browsers use Alt+Shift on Windows and Linux and Ctrl on OS X.

Threk wrote:I think there will be a lot of people who will be upset at having this forced on them.

There probably are, but that's not a reason not to make a change you feel will benefit another lot of people who've had no option to keep web pages from interfering with their browser shortcuts so far.

Anyway, thanks for sharing. In case you also want the nice folks of Mozilla.com to know about the issue, using the Hendrix feedback system would be the way to go...

Threk
 
Posts: 8
Joined: July 18th, 2005, 9:39 pm

Post Posted January 2nd, 2007, 10:34 am

Zeniko, You just don't get the point. This was a bug which only affected people who re-configure their browser. You could have made the Shift-Alt accesskey AN OPTION, and solved the bug for them.

By making Shift-Alt the default behavior you created a lot of unnecessary trouble.

old zeniko
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted January 2nd, 2007, 11:48 am

Threk wrote:This was a bug which only affected people who re-configure their browser.

Wrong, unless you consider visiting e.g. Wikipedia a reconfiguration as well... (visit that page in Internet Explorer and try to open the File menu with Alt+F).

Threk wrote:You could have made the Shift-Alt accesskey AN OPTION

We did, except that it's the default option and we didn't want to bother most users with a choice they shouldn't have to make in the first place -- which is among others what the Firefox project is about.

WindsorFox

User avatar
 
Posts: 3
Joined: February 26th, 2005, 2:35 pm
Location: Louisiana

Post Posted February 18th, 2007, 10:45 am

zeniko wrote:
Threk wrote:This was a bug which only affected people who re-configure their browser.

Wrong, unless you consider visiting e.g. Wikipedia a reconfiguration as well... (visit that page in Internet Explorer and try to open the File menu with Alt+F).

Threk wrote:You could have made the Shift-Alt accesskey AN OPTION

We did, except that it's the default option and we didn't want to bother most users with a choice they shouldn't have to make in the first place -- which is among others what the Firefox project is about.


Most?? I think you are bass ackwards. "Most" people used the alt-s function the way it was, the dev team changed the default to suit people who are more or less non-standard users. The hassel of using an extra key or changing the default functionality, especially digging into the config should be left to the people who are the less default users.

silicon rat
 
Posts: 1
Joined: February 27th, 2007, 4:00 pm

Post Posted February 27th, 2007, 4:08 pm

We have exactly the same problem with out customers as Threk does, and this is just driving them back to IE. But it seems pretty plain to me that people like Zeniko simply are not going to listen until there is a user revolt.

I've found an online petition that has been languishing unnoticed. I suggest you all sign it. Personally, I'm going to make it into a meme.

http://www.petitiononline.com/a40504/petition.html

nanquan
 
Posts: 44
Joined: November 8th, 2006, 11:38 am

Post Posted October 29th, 2008, 9:26 am

stonedyak wrote:Yes, I found this change annoying too. You can either use Shift-Alt+S to submit or you can change it back to how it was using about:config
Change:
ui.key.chromeAccess to 5
ui.key.contentAccess to 4

This will allow you to use Alt for webpage shortcuts and Shift-Alt for Firefox's menu shortcuts

I did that also back when I upgraded to Firefox 2, but now that I have upgraded to Firefox 3, I have this problem again, but only with the shortcut Alt+U (for underline in phpBB). All the other shortcuts work fine (like Alt+B), and I still have these settings in my about:config section. Alt+U is supposed to function as the underline shortcut, but instead it just "focuses" on elements on the page starting with the letter "U" as if I was doing a search on the page.

What changed in firefox 3 that the Alt+U shortcut got reassigned? And how can I change it back so that I can use it as the underline shortcut again in forums?

Thanks!

monkey912

User avatar
 
Posts: 369
Joined: June 16th, 2008, 6:11 pm

Post Posted November 4th, 2008, 9:13 pm

can you use keyconfig to unbind that shortcut, to make the posting work?
monkey

dorando
 
Posts: 1203
Joined: January 9th, 2004, 9:57 am

Post Posted November 5th, 2008, 4:27 am

monkey912 wrote:can you use keyconfig to unbind that shortcut, to make the posting work?
Nope, keyconfig is for chrome <key>s and not for content accesskeys. Here both "Underline text" and "User Control Panel" have accesskey="u" defined (pressing accesskey+u multiple times switches between those). This behavior might be intentional or a bug (most likely bug 425496, but bug 438306 and bug 129268 might be related).

bonobird
 
Posts: 25
Joined: June 30th, 2006, 9:25 pm

Post Posted September 6th, 2009, 9:16 am

I use Alt-s all day long in Outlook, and I'm sick of not having it in T-bird. Seems like a huge oversight! I've looked through keyboard shortcut maps and extensions and KB ... and the closest I found was this thread - years old. I'm not a developer - if someone knows of an add-on that will allow the Alt-S keyboard combination to be assigned to the Send (now) function I'd sure appreciate the rec. If not, can someone provide more detail on the suggested fix in this thread:

Yes, I found this change annoying too. You can either use Shift-Alt+S to submit or you can change it back to how it was using about:config
Change:
ui.key.chromeAccess to 5
ui.key.contentAccess to 4


I'm on Tbird 2.0.0.23. When I go Help => about there is no option for "config" ... how can I access this?

TIA,
Devoted, but frustrated Tbird user ...

Dartman
Moderator

User avatar
 
Posts: 11998
Joined: February 9th, 2006, 9:43 pm

Post Posted September 6th, 2009, 10:21 am

You need to start a new thread in a Thunderbird forum.

1) This thread is over three years old.
2) Your question is about Thunderbird, this thread is located in a Firefox forum and is only talking about the program Firefox.
Alcohol and Calculus don't mix. Never drink and derive.

Return to Firefox Features


Who is online

Users browsing this forum: No registered users and 1 guest