MozillaZine

FF does not remember the Gmail password

Discussion of bugs in Mozilla Firefox
johann_p

User avatar
 
Posts: 8479
Joined: November 5th, 2002, 3:05 am
Location: Sheffield, UK

Post Posted October 30th, 2004, 9:36 am

I do not know if this is due to a Gmail bug or FF bug, but FF never remembers a password for the Gmail login screen as it does for other web login screens. (my list of sites for which never to save passwords is empty and I have that feature switched on).

I am using the 1.0RC1 for Linux now, but the same problem already existed with the 1.0PR.
“Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe.”

TheOneKEA

User avatar
 
Posts: 4864
Joined: October 16th, 2003, 5:47 am
Location: Somewhere in London, riding the Underground

Post Posted October 30th, 2004, 9:55 am

Unless this used to work and regressed, Gmail is most likely forcing the Fx Password Manager not to remember passwords typed into the box.
Proud user of teh Fox of Fire
Registered Linux User #289618

johann_p

User avatar
 
Posts: 8479
Joined: November 5th, 2002, 3:05 am
Location: Sheffield, UK

Post Posted October 30th, 2004, 10:14 am

I am mostly posting this here to learn whether all others are having problems too?

Or can somebody who knows how it is check the web page to see if Gmail "forces .... not to remember"? How can that be done?
“Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe.”

TheOneKEA

User avatar
 
Posts: 4864
Joined: October 16th, 2003, 5:47 am
Location: Somewhere in London, riding the Underground

Post Posted October 30th, 2004, 11:14 am

The autocomplete attribute for <input/> prevents the browser from remembering what was typed into the box and offering to fill it in.

This is what Gmail does:

<input type="password" name="Passwd" autocomplete="off" size="18">
Proud user of teh Fox of Fire
Registered Linux User #289618

fyo

User avatar
 
Posts: 530
Joined: February 17th, 2004, 5:09 pm

Post Posted October 30th, 2004, 11:34 am

If you want Password manager to work on pages like this, there is a VERY simple method:

BOOKMARKLETS

Go to this page: http://ostermiller.org/bookmarklets/utilities.html
Scroll down to "Remember Passwords" and DRAG the link to your personal toolbar. Go to a page with autocomplete=off, e.g. gmail. Press your new bookmarklet. A javascript popup informs you, that one form has had autocomplete disabled. Enter your username and password. Firefox now asks if you want to remember username/password.

Done.

-fyo
--------------------
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/2007022001 Firefox/2.0.0.2

fyo

User avatar
 
Posts: 530
Joined: February 17th, 2004, 5:09 pm

Post Posted October 30th, 2004, 11:37 am

Oh, btw johann_p... you're running SuSE right? Does Firefox look right to you? On my Suse 9.1 box (runnign KDE 3.2), I'm getting lots of extra spacing and large buttons (in the toolbars). Customize toolbars page looks completely wrong and selecting small icons doesn't change a thing (and is hard to select because the look is so utterly messed up).

Thanks,

fyo
--------------------
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/2007022001 Firefox/2.0.0.2

johann_p

User avatar
 
Posts: 8479
Joined: November 5th, 2002, 3:05 am
Location: Sheffield, UK

Post Posted October 30th, 2004, 11:50 am

Thank you TheOneKEA and fyo for your help!!

I am using Suse 9.1 professional with KDE updated to 3.3 and FF looks fine here - apart from the customize dialog that always looked odd, but I think that is on purpose :)

My icons look fine and small icons changes them to be small.
Are you using the default theme?
“Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe.”

fyo

User avatar
 
Posts: 530
Joined: February 17th, 2004, 5:09 pm

Post Posted October 30th, 2004, 2:30 pm

johann_p,

Yes, I am using the default theme. The problem for me is that Firefox has extra spacing around all the icons in the navigation bar (especially). Are you using KDE or Gnome with your SuSE?

Checking agian... changing to large icons does actually increase the size slightly, but the whole look is still wrong. Too much spacing and the background is "streaked". Like this: http://www.gjk.dk/~krn/snapshot1.jpg

Note the streaking and the extra space above and below the navigation bar.

-fyo
--------------------
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/2007022001 Firefox/2.0.0.2

johann_p

User avatar
 
Posts: 8479
Joined: November 5th, 2002, 3:05 am
Location: Sheffield, UK

Post Posted October 30th, 2004, 6:00 pm

I usually use KDE, but it also works fine in Gnome or other Window managers.
Your URL gives me a 404,
“Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe.”

fyo

User avatar
 
Posts: 530
Joined: February 17th, 2004, 5:09 pm

Post Posted October 30th, 2004, 7:48 pm

Grrr... the proper url is:

http://www.gjk.dk/~krn/firefox/snapshot1.png

Sorry.

-fyo
--------------------
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/2007022001 Firefox/2.0.0.2

Return to Firefox Bugs


Who is online

Users browsing this forum: No registered users and 2 guests

cron