MozillaZine

"View Selection Source" results in download dialog

Discussion of bugs in Mozilla Firefox
JessePelton
 
Posts: 20
Joined: November 6th, 2002, 6:37 am

Post Posted November 6th, 2002, 6:42 am

With Px0.4 on Win2000, if I select some page content, right-click the selection, and select "View Selection Source" from the context menu, a download dialog pops up with "Downloading viewPartialSource.xul" in the caption bar. It works fine with Moz 1.2b. I couldn't find any relevant bugs in Bugzilla; can anyone else confirm with 0.4 or a recent nightly?

hokiegenius

User avatar
 
Posts: 3
Joined: November 5th, 2002, 7:01 am

Post Posted November 6th, 2002, 6:55 am

JessePelton wrote:With Px0.4 on Win2000, if I select some page content, right-click the selection, and select "View Selection Source" from the context menu, a download dialog pops up with "Downloading viewPartialSource.xul" in the caption bar. It works fine with Moz 1.2b. I couldn't find any relevant bugs in Bugzilla; can anyone else confirm with 0.4 or a recent nightly?


I was able to view selection source fine for about 2 times but on the third I got the downloading thing you got for the rest of the time. So I closed my browser and tried again and I could view the selection source once and then if I tried it again I get the downloading thing. I'm using the 0.4 release on win2k. Very strange behavior. My guess is that when I close the view source window the code is not exiting correctly.

Richard
 
Posts: 67
Joined: November 5th, 2002, 7:29 pm
Location: Venezuela

Post Posted November 6th, 2002, 7:12 am

With Px0.4 and 4nov nightly on Mdk8.1 SavePage works without selecting any text from View Source mode but not directly with Ctrl-S nor with File-SavePageAs.

JessePelton
 
Posts: 20
Joined: November 6th, 2002, 6:37 am

Post Posted November 6th, 2002, 7:19 am

For what it's worth, I get the same dialog if I attempt to install an extension. Before I file a bug, do y'all see this behavior too?

michal017
 
Posts: 307
Joined: November 5th, 2002, 12:08 am
Location: EU

Post Posted November 6th, 2002, 7:30 am

it's theme bug.. use classic theme and try it out.. if the source doesn't appear, it's a bug..
for instance Phoenity theme has this bug

JessePelton
 
Posts: 20
Joined: November 6th, 2002, 6:37 am

Post Posted November 6th, 2002, 7:38 am

michal017 wrote:it's theme bug.. use classic theme and try it out.. if the source doesn't appear, it's a bug..
for instance Phoenity theme has this bug

Well, I'll be danged. I had no idea themes were capable of wreaking that sort of havoc. I switched from Phoenity, and View Selection Source and extension installation now work properly. I'll notify Phoenity's author if I can't find any indication that someone has done so.

Thanks!

michal017
 
Posts: 307
Joined: November 5th, 2002, 12:08 am
Location: EU

Post Posted November 6th, 2002, 8:00 am

yes, do it.. I use that theme too ;)

Return to Firefox Bugs


Who is online

Users browsing this forum: No registered users and 1 guest