MozillaZine

Disabling Hardware Acceleration still uses GPU for scrolling

Discussion of bugs in Mozilla Firefox
spirits247
 
Posts: 55
Joined: October 6th, 2009, 6:30 am

Post Posted November 17th, 2011, 2:44 pm

Decided to post a specific thread regarding the hardware acceleration disable switch in Firefox 8 not working correctly.

Firefox 8
Windows 7
AMD 6870
Catalyst 11.10

I have an issue with GPU temps and scrolling (reported in the General forum) which doesn't exist in hardware accelerated IE9 and Chrome, so I wish to disable hardware acceleration forcing Firefox 8 to act like 3.6.24 and uses the CPU only.

I have unchecked the following option Tools->Options->General->Use Hardware Acceleration when available.

I have verified it is disabled via about:config

Yet when I scroll pages my GPU clocks still rise to maximum and temps increase by 7-10c. This does not happen in 3.6.24, where hardware acceleration does not exist. Therefore this seems like a bug with the way Firefox 8 disables its hardware acceleration.

ndebord

User avatar
 
Posts: 631
Joined: December 7th, 2002, 9:53 am

Post Posted November 18th, 2011, 7:18 am

spirits247 wrote:Decided to post a specific thread regarding the hardware acceleration disable switch in Firefox 8 not working correctly.

Firefox 8
Windows 7
AMD 6870
Catalyst 11.10

I have an issue with GPU temps and scrolling (reported in the General forum) which doesn't exist in hardware accelerated IE9 and Chrome, so I wish to disable hardware acceleration forcing Firefox 8 to act like 3.6.24 and uses the CPU only.

I have unchecked the following option Tools->Options->General->Use Hardware Acceleration when available.

I have verified it is disabled via about:config

Yet when I scroll pages my GPU clocks still rise to maximum and temps increase by 7-10c. This does not happen in 3.6.24, where hardware acceleration does not exist. Therefore this seems like a bug with the way Firefox 8 disables its hardware acceleration.


Can you tell me what the wording is in about:config?

Tks.
XP PRO SP3, WebRoot, WinPatrol, MalwareBytes Anti-Exploit
Dulce bellum inexpertis

patrickjdempsey

User avatar
 
Posts: 22356
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted November 19th, 2011, 10:01 pm

Does this happen on all pages or only on pages with hardware accelerated content like Flash?
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

spirits247
 
Posts: 55
Joined: October 6th, 2009, 6:30 am

Post Posted November 20th, 2011, 7:30 am

about:supports lists:

Direct2D Enabled false
DirectWrite Enabled false

about:config lists:

gfx.direct2d.disabled true
gfx.direct2d.force-enabled false
gfx.font_rendering.directwrite.enabled false
gfx.font_rendering.directwrite.use_gdi_table_loading true

    This is on pages without flash, although I have Flashblock and Adblock plus installed so it should not be running flash acceleration.

    To be sure I tried running with all addons and plugins disabled, and then in safe mode - same result with both.

    Smooth scrolling is disabled.

    Not every webpage is affected, perhaps it depends on the pages content.

    The test webpages are http://forums.overclockers.co.uk/ and http://www.youtube.com/ (flash disabled makes no difference)

    The monitoring software is GPU-Z, to show spikes and rises in GPU clocks, temps and fan speed over time.

    I now know why this may be unconfirmed by many, as it relies on certain parameters to cause the scrolling issue.

WITH HARDWARE ACCELERATION DISABLED

Interestingly, the amount it ramps up the clocks is dependant on the size of the browser window. Maximised (NOT Fullscreen Mode) on a 1080p monitor sees the clocks rising to max all the time when scrolling and staying there for a few seconds after scrolling has ceased.

Make the browser window small enough OR put Firefox in Fullscreen Mode (weird I know), and the clocks stay at 2D speeds when scrolling!

The thing is, the clocks should not be changing at all with Hardware Acceleration disabled, hence this bug report.

WITH HARDWARE ACCELERATION ENABLED

The amount it ramps up the clocks is still dependant on browser window size, however it now hits max clocks over a certain size, does it Maximized (on a 1080p monitor) AND Fullscreen mode.

It's much more sensitive to ramping up the clocks - holding my GPU at max speeds for a few seconds after scrolling a page has ceased.

REPEATABLE?

Always. Ran the test several times, uninstalled Firefox 8 and ran 3.6.24 - no GPU usage registered at all, as expected. Upgraded to Firefox 8 - same issues again as outlined above.

WHY AN ISSUE?

IE9 and Chrome my GPU temp is always at 36C when surfing and scrolling (even smooth scrolling), with minor GPU clock spikes for acceleration now and again. Only time the GPU rises slightly in temp is to play flash video at UVD mid clocks where it goes up to 42C.

Firefox is ramping my clocks to Max for simply scrolling certain webpages and holds the clocks there for a few seconds even after activity has ceased. This results in temps rising to 47C and fan tone changing in an otherwise silent system.

OTHER INFORMATION

GPU-Z screenshots can be viewed in this thread: viewtopic.php?f=7&t=2361245

patrickjdempsey

User avatar
 
Posts: 22356
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted November 20th, 2011, 10:52 am

1. Switching back and forth between 3.6 and newer versions in the same profile is known to create profile corruption and is not recommended. No software is designed to be "downdated".

2. Check for Azure in about:config: gfx.canvas.azure.enabled
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

spirits247
 
Posts: 55
Joined: October 6th, 2009, 6:30 am

Post Posted November 20th, 2011, 12:52 pm

I didn't switch back and forth using the same profile. The initial problem surfaced with a fresh install of Windows 7 and drivers, I then fully uninstalled FF8 including the profile/addons and installed FF 3.6.24, then upgraded back to FF8.

I'll check for that Azure once I'm back on my main desktop.

The links in that thread at the bottom of my opening post show that this isn't an isolated issue. A quick search shows many others have found the same problem. I guess Firefox needs its GPU acceleration to mature, now that we have these quick releases, or it's a driver issue with AMD. Perhaps a bit of both - driver and Firefox GPU acceleration need balancing out. All I know is there isn't a problem with IE9.

Until then, I'd just like this obvious bug of not being able to fully disable hardware acceleration to be addressed but on Bugzilla it continues to remain unconfirmed. Perhaps it's specific to certain hardware only and I've been unlucky.

spirits247
 
Posts: 55
Joined: October 6th, 2009, 6:30 am

Post Posted November 20th, 2011, 4:34 pm

Ok checked gfx.canvas.azure.enabled and it's set to true which is the default

patrickjdempsey

User avatar
 
Posts: 22356
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted November 20th, 2011, 5:06 pm

Try setting it to false, azure uses HA as well... but disabling HA in Options *should* have disabled all of this stuff. Are you restarting after making each change? (Not trying to condescend, just curious).

Edit: probably the only way to get rid of this is to disable Smooth Scrolling.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

spirits247
 
Posts: 55
Joined: October 6th, 2009, 6:30 am

Post Posted November 23rd, 2011, 7:10 am

Thanks for your help patrickjdempsey.

I tried setting Azure to false and smooth scrolling was never enabled.

It just seems in recent Firefox releases you can't detach the browser fully from the GPU. Scrolling still triggers max clocks from time to time. It may be a driver issue with AMD as nVidia recently released a fix for their cards ramping up during scrolling after users complained. Of course, they have the black screen issue now!

For now I'll just use 3.6.24, hoping either GPU acceleration will be fixed to work like IE9/Chrome or at least have the option of going back to CPU only.

Return to Firefox Bugs


Who is online

Users browsing this forum: No registered users and 2 guests