MozillaZine

ugly, jagged fonts in Firefox (Chrome way better)

Discussion of bugs in Mozilla Firefox
michaelbeijer
 
Posts: 9
Joined: March 21st, 2015, 12:56 pm
Location: Hastings, UK.

Post Posted March 22nd, 2015, 3:23 am

@patrickjdempsey:

Wow, thanks, that solved it! It now looks as good as in Chrome.

Why is is set to false by default? Shouldn’t it be set to true in a fresh install? I tweaked a few things in about:config (all speed-related), but don't think I changed "gfx.font_rendering.directwrite.enabled".

I also found these interesting pages:
viewtopic.php?f=23&t=2010809 (thread title "What is gfx.font_rendering.directwrite.enabled?")
https://blog.mozilla.org/nattokirai/201 ... firefox-6/ (blog post title "DirectWrite Text Rendering in Firefox 6")
MICHAEL BEIJER
NL>EN translator & terminologist
Skype/Twitter: michaelbeijer

rsx11m
Moderator
 
Posts: 14425
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted March 22nd, 2015, 7:48 am

As stated in the other thread, gfx.font_rendering.directwrite.enabled is set to false because it can be used to force DirectWrite fonts even when HWA is disabled. Usually, DirectWrite would be enabled automatically when HWA is detected. Help > Troubleshooting Info (about:support) should tell you whether or not HWA is blocked and why.

dfoulkes

User avatar
 
Posts: 22325
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted March 22nd, 2015, 10:44 am

It must be my 70 Y.O. eyes... even with glasses...23inch screen ...I don't/can't see the big deal ... even in the side-by-side samples provided... I just compared this FF-profile with my portable Google with the link...
http://www.google.com/fonts/specimen/Open+Sans
... and see no problems with either results... in fact Firefox looked better than Chrome to me...

michaelbeijer
You mention that you just installed Firefox... did you do these tests with it prior to making any changes to your profile?
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

michaelbeijer
 
Posts: 9
Joined: March 21st, 2015, 12:56 pm
Location: Hastings, UK.

Post Posted March 22nd, 2015, 10:59 am

Hi dfoulkes,

Look at the line:

"Double your browser's speed in just five minutes" in these two screenshot comparisons:

https://dl.dropboxusercontent.com/u/680 ... ter%29.png
https://dl.dropboxusercontent.com/u/680 ... ght%29.png

(click on them to view at full size)

There is a very real and visible difference there.

Actually, I have tried Firefox many times over the last few years but always found myself switching back to Chrome because I thought that font rendering in ff was just poor by default and could nopt be improved. It now turns out all I had to do was set "gfx.font_rendering.directwrite.enabled" to true.

I can reproduce this problem in a fresh installation/profile.
MICHAEL BEIJER
NL>EN translator & terminologist
Skype/Twitter: michaelbeijer

DanRaisch
Moderator

User avatar
 
Posts: 120443
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 22nd, 2015, 11:08 am

I see the difference. I just don't see the difference as significant enough to put up with the problems of Chrome.

patrickjdempsey

User avatar
 
Posts: 23734
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted March 22nd, 2015, 1:05 pm

If it happens in a new profile, most likely your hardware is blocked for some reason as rsx11m mentioned, and I suspected. You might try updating your graphics card drivers.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

dfoulkes

User avatar
 
Posts: 22325
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted March 22nd, 2015, 1:27 pm

michaelbeijer wrote:Hi dfoulkes,

Look at the line:

"Double your browser's speed in just five minutes" in these two screenshot comparisons:

https://dl.dropboxusercontent.com/u/680 ... ter%29.png
https://dl.dropboxusercontent.com/u/680 ... ght%29.png

(click on them to view at full size)

There is a very real and visible difference there.

OK... taking a deep look into it... I see a diff... but not much at all... even in your pics...

I did test the actual site in here and Chrome and in my test found Firefox to be better looking that Chrome.... magic of computers ](*,)
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

2ark0
New Member
 
Posts: 1
Joined: August 12th, 2015, 10:07 pm

Post Posted August 12th, 2015, 10:10 pm

I used to have the same problem with Google fonts (specially Google Spreadsheets) using Firefox. What it worked for me was the next:

1. Open in Firefox the document or URL that is displaying "ugly fonts". Make sure to open a Firefox window on each monitor/screen that you have available. In my case I have the display of my laptop and 2 external monitors.
2. Open the link [Refresh Firefox][https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings]
3. Click on the button "Refresh Firefox".
4. In the popup window, confirm clicking the button "Refresh Firefox".
5. Your Firefox configuration and addons will be reset to default, don't worry techie guys: All your bookmarks and passwords will be saved.
6. Wait until Firefox closes itself and gets open again.
7. Once The Firefox is refreshed you are good to go, check again the page with ugly fonts and the problem should be gone.

Other option insteas the link showed in the step #2 is go to url [about:support][about:support]. The button "Refresh button" is on the up right corner.

malliz
Folder@Home

User avatar
 
Posts: 43516
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted August 13th, 2015, 3:23 am

You would more than likely got the same result just clearing your cache and cookies
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

rsx11m
Moderator
 
Posts: 14425
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted August 13th, 2015, 12:39 pm

Well, the "Refresh" button (which used to be more accurately named "Reset" before) is a bit of a sledgehammer to resolve issues. Some setting (or, as malliz hinted, some content) may have "uglified" the fonts in this particular case, thus resetting (almost) everything to default cleared that (but it's certainly not a generally recommended approach given that it likely resets more than you want to, unless you have a very-very vanilla installation).

patrickjdempsey

User avatar
 
Posts: 23734
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted August 13th, 2015, 12:59 pm

I'd bet that at some point you disabled hardware acceleration to resolve some other issue you were having. Crashes? Black squares on pages? There's all kinds of reasons. By "refreshing" your profile you have now lost all of your custom settings including the disabling of HWA which means it is possible that whatever issue you experienced before could reappear. The preference I posted on the previous page solves the font issue without re-enabling HWA.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

LIMPET235
Moderator

User avatar
 
Posts: 38451
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted September 3rd, 2018, 5:53 am

kimi85,
I split your post off to here, as this thread died in 2015.
ref; > viewtopic.php?f=38&t=3041462

Locking this oldie..
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0-61.0-62.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. (Always choose the "Custom" Install.)

Return to Firefox Bugs


Who is online

Users browsing this forum: No registered users and 3 guests