MozillaZine

Disabling VP9

Discussion of bugs in Mozilla Firefox
KasperskyITA
 
Posts: 30
Joined: January 27th, 2016, 3:23 pm

Post Posted January 23rd, 2018, 9:50 am

How can i disable VP9? Installing version 58 of Firefox, the VP9 has been activated. How can i disable "MSE & WebM VP9" ?? (https://www.youtube.com/html5)

therube

User avatar
 
Posts: 19040
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 23rd, 2018, 10:57 am

Have you filtered about:config, for 'vp9', for 'mse', for 'webm'?

Anyhow, why do you want to disable VP9?
Oh, I know, it doesn't look as good as mp4. But have you actually looked?


(Backup your Profile before messing.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

KasperskyITA
 
Posts: 30
Joined: January 27th, 2016, 3:23 pm

Post Posted January 23rd, 2018, 11:20 am

therube wrote:Have you filtered about:config, for 'vp9', for 'mse', for 'webm'?

Anyhow, why do you want to disable VP9?
Oh, I know, it doesn't look as good as mp4. But have you actually looked?


(Backup your Profile before messing.)


I hate VP9 because cause to me a lot of dropped frames. Already tried set "media.benchmark.vp9.threshold" to 1000 but VP9 still active.

therube

User avatar
 
Posts: 19040
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 23rd, 2018, 12:02 pm

Not that I know what they do, but:

media.peerconnection.video.vp9_enabled
media.encoder.webm.enabled
media.mediasource.webm.audio.enabled
media.mediasource.webm.enabled
media.webm.enabled
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

KasperskyITA
 
Posts: 30
Joined: January 27th, 2016, 3:23 pm

Post Posted January 24th, 2018, 6:54 am

therube wrote:Not that I know what they do, but:

media.peerconnection.video.vp9_enabled
media.encoder.webm.enabled
media.mediasource.webm.audio.enabled
media.mediasource.webm.enabled
media.webm.enabled


The first 3 pref do nothing, "media.mediasource.webm.enabled" it's what interests me but it's already in "false", "media.webm.enabled" disable "MSE & WebM VP9" AND "WebM VP8" (WebM VP8 should not be deactivated).
The problem persists.

KasperskyITA
 
Posts: 30
Joined: January 27th, 2016, 3:23 pm

Post Posted January 24th, 2018, 8:15 am

I don't have "media.benchmark.vp9.fps" and "media.benchmark.vp9.versioncheck". Is ok?

therube

User avatar
 
Posts: 19040
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 24th, 2018, 11:14 am

just use the EME-free builds

I don't think "EME-free" has a bearing on (WebM) VP8/9 support (at least in this threads context).


With all of these set to 'false':

media.encoder.webm.enabled
media.mediasource.webm.audio.enabled
media.mediasource.webm.enabled
media.webm.enabled

(In FF 52) https://www.youtube.com/html5 shows WebM VP8, & MSE & WebM VP9 as unsupported.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

James
Moderator

User avatar
 
Posts: 27380
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted January 24th, 2018, 12:12 pm

therube wrote:(In FF 52) https://www.youtube.com/html5 shows WebM VP8, & MSE & WebM VP9 as unsupported.

Firefox on WinXP can only do four out of six on HTML5 test page without doing some workarounds.

therube

User avatar
 
Posts: 19040
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 24th, 2018, 5:43 pm

Yes, but without making said changes, WebM VP8, & MSE & WebM VP9 are supported, do work.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 19040
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 24th, 2018, 5:48 pm

With all of these set to 'false':

media.encoder.webm.enabled
media.mediasource.webm.audio.enabled
media.mediasource.webm.enabled
media.webm.enabled

(In FF 58) https://www.youtube.com/html5 shows WebM VP8, & MSE & WebM VP9 as unsupported.
And with that, Youtube serves you mp4, https://www.youtube.com/watch?v=e5r3GoTAXcE.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

KasperskyITA
 
Posts: 30
Joined: January 27th, 2016, 3:23 pm

Post Posted January 25th, 2018, 9:08 am

therube wrote:With all of these set to 'false':

media.encoder.webm.enabled
media.mediasource.webm.audio.enabled
media.mediasource.webm.enabled
media.webm.enabled

(In FF 58) https://www.youtube.com/html5 shows WebM VP8, & MSE & WebM VP9 as unsupported.
And with that, Youtube serves you mp4, https://www.youtube.com/watch?v=e5r3GoTAXcE.


The problem is if I also disable VP8 I still have the annoying dropped frames, so it must be all active except "MSE & WebM VP9". So it was in the last versions of Firefox and I had no problems.

therube

User avatar
 
Posts: 19040
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 25th, 2018, 10:46 am

it must be all active

And you know that how?
Did you right-click, "check stats for nerds" (or whatever it says)?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

KasperskyITA
 
Posts: 30
Joined: January 27th, 2016, 3:23 pm

Post Posted January 25th, 2018, 2:39 pm

therube wrote:
it must be all active

And you know that how?
Did you right-click, "check stats for nerds" (or whatever it says)?

Every time I install a new version of Firefox I go to the Youtube Html5 page to see if anything changes and that's what happened with FF 58, unfortunately.

Return to Firefox Bugs


Who is online

Users browsing this forum: No registered users and 1 guest