MozillaZine

after v67, a new default profile created every restart

Discussion of bugs in Mozilla Firefox
LeechBot
 
Posts: 30
Joined: June 9th, 2003, 3:51 pm

Post Posted September 19th, 2019, 8:05 pm

I'm just coming back to Firefox after two years. My new installation re-sets the default profile every time the app is relaunched. Using about:profiles to clean this up doesn't work, and it's rather a pain to get back to the old profile (which does still exist in the filesystem). I saw people reported this problem began with version 67 (for example at https://www.ghacks.net/2019/05/27/how-to-fix-firefox-starting-with-a-blank-user-profile/), so I did a clean install of the last version 66, and it runs fine.

Meanwhile, v69 just got updated today, but of course, I'm afraid to try it, as the release notes don't mention the profiles bug. When my profile on my single-user computer gets de-defaulted, the only fix has been to re-sync, then manually re-do rather a lot of remaining settings for the plug-ins and about:config preferences. Yet, I don't see this bug at Bugzilla or here at mozillaZine. Is the issue being tracked anywhere so that when I try again, it stands a reasonable chance of working?

WaltS48

User avatar
 
Posts: 4043
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted September 20th, 2019, 5:33 am

There is no profiles bug that I can see.

See this support post https://support.mozilla.org/en-US/kb/de ... stallation
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

LeechBot
 
Posts: 30
Joined: June 9th, 2003, 3:51 pm

Post Posted September 20th, 2019, 7:12 am

Thanks for the link to the description of how profiles are supposed to work. I'm reporting the problem of them not working the way they're supposed to. Happily, profiles work for you as you reported, but that doesn't help in any way the people who report having the same problem as me, namely, after v67, a new default profile gets created every time I restart Firefox, and it's rather difficult to get back to the old profile. I must then do a clean install of Firefox. Every time Firefox gets restarted.

DanRaisch
Moderator

User avatar
 
Posts: 122167
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted September 20th, 2019, 10:01 am

Think link you included in your first post doesn't mention repetitive creation of new profiles on each start up. It only refers to that new profile creation as a function of the first launch upon update. I don't recall seeing any other reports of repetitive profile creation on these forums.

LeechBot
 
Posts: 30
Joined: June 9th, 2003, 3:51 pm

Post Posted September 20th, 2019, 4:19 pm

Since your feedback indicates the problem isn't as widespread as I thought, I tried letting Firefox update itself from v66 to the most current version, v69. The update works with no problem.

My first installation was a clean install, not an update from an earlier version. Upon restarting Firefox, it would present a message that said something like, "this installation of Firefox has no profile, so a new one will be created," then it would do exactly that. Examining the situation with about:profiles presented an inconsistent situation, and deleting profiles and designating existing ones as default didn't work right. I forget the details now, but since the problem is solved, I'm just happy the feedback here gave me the confidence to risk trashing everything one more time to get updated, and it worked.

Return to Firefox Bugs


Who is online

Users browsing this forum: No registered users and 2 guests