MozillaZine


Video playback aborted due to a network error

Discussion of bugs in Mozilla Firefox
atlanto
 
Posts: 97
Joined: March 7th, 2015, 4:19 pm
Location: Japan

Post Posted July 30th, 2020, 5:22 pm

Since I could reproduce this issue on my local env(linuxmint 20, apache 2.4.41, enmod ssl+http2+brotli) by adding "AddOutputFilterByType BROTLI_COMPRESS video/mp4", remove it if you have such conf. (you must have it because of "content-encoding: br" in the response header on your site)
(btw, maybe it's better to submit a bug report because chromium edge has no problem with "content-encoding: br" for video/mp4)

antonsvideo
 
Posts: 65
Joined: August 15th, 2012, 7:47 pm

Post Posted December 10th, 2020, 5:54 pm

well, it has been a long time with many FF updates and the issue remains unsolved

I can't even play a 1min clip without the network error (no other browser has issues)
https://www.videoproductions.com.au/vid ... k-2020.mp4

antonsvideo
 
Posts: 65
Joined: August 15th, 2012, 7:47 pm

Post Posted January 13th, 2021, 3:53 pm

the issue is now resolved

here is what a server support person did:

I've added this to the .htaccess file:
SetEnvIf Request_URI "\.mp4$" no-brotli=1

Which tells Apache that if the requested file ends in "mp4", then set the environment variable for disabling brotli for that file.

therube

User avatar
 
Posts: 20582
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 18th, 2021, 9:57 am

(Ah, so it sounds like atlanto had come up with the correct answer. [Well, I guess the correct answer is that things work without having to finagle... but...].)
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Bugs


Who is online

Users browsing this forum: Bing [Bot], Google [Bot], sadiqdm and 1 guest