MozillaZine

XML parse error

Discussion of bugs in Mozilla Firefox
crippled-bird
Guest
 

Post Posted January 29th, 2003, 11:41 am

Bug #189536 was marked as fixed just after midnight today Wednesday, Jan 29. It's about a problem with page info not working. I checked out and built Phoenix. When I tested it, I got a curious error:

XML Parsing Error: error in processing external entity reference
Location: chrome://browser/content/pageInfo.xul
Line Number 6, Column 3:

%pageInfoDTD
__^

For what I know, everything looks fine in pageInfo.xul and the referenced pageInfo.dtd.

A little research turned up an old bug in libexpat:
http://mail.libexpat.org/pipermail/expa ... 00313.html

So, what do I do to get this info to the right folks? The bug is certainly reproducible on my system, but it could be a bug in Mozilla or libexpat or neither as far as I know.

This is the Linux version.

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted January 29th, 2003, 1:19 pm

Do you get that with the official linux build? Does it exist in Mozilla?

Could it be a result of http://bugzilla.mozilla.org/show_bug.cgi?id=181764 ?

Has it been fixed? Are you using an old copy of that lib?
Former UMO Admin, Former MozillaZine General Mod
I am rarely on mozillaZine, so please do not send me a private message.
My Old Firefox config files

cdn

User avatar
 
Posts: 999
Joined: November 4th, 2002, 5:47 pm
Location: UK

Post Posted January 29th, 2003, 1:41 pm

pageInfo.xul must have been amongst the files that changed recently, it has today as it's date

my version (linux cvs) has this:

<!DOCTYPE window [
<!ENTITY % pageInfoDTD SYSTEM "chrome://browser/locale/pageInfo.dtd">
%pageInfoDTD;
]>

perhaps yours is missing the semi-colon ? or something ?

edit:

mine has this as well

edit 2:

partial cvs diff
[1004 cn@emperor content]$ cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot diff -r 1.6 pageInfo.xul
Index: pageInfo.xul
===================================================================
RCS file: /cvsroot/mozilla/browser/base/content/pageInfo.xul,v
retrieving revision 1.6
retrieving revision 1.7
diff -r1.6 -r1.7
25c25
< <?xml-stylesheet href="chrome://navigator/skin/pageInfo.css" type="text/css"?>
---
> <?xml-stylesheet href="chrome://browser/content/pageInfo.css" type="text/css"?>
28,32c28
< <!ENTITY % brandDTD SYSTEM "chrome://global/locale/brand.dtd">
< %brandDTD;
< <!ENTITY % navigatorDTD SYSTEM "chrome://navigator/locale/navigator.dtd">
< %navigatorDTD;
< <!ENTITY % pageInfoDTD SYSTEM "chrome://navigator/locale/pageInfo.dtd">
---
> <!ENTITY % pageInfoDTD SYSTEM "chrome://browser/locale/pageInfo.dtd">


clearly some Px work going on, presumably to have less reliance on "legacy" Mozilla things

cdn

User avatar
 
Posts: 999
Joined: November 4th, 2002, 5:47 pm
Location: UK

Post Posted January 29th, 2003, 1:54 pm

to fix html-type comment out the NPL licence block, which is using bash like # at present

possibly you will need to change the <!DOCTYPE > as well

to

<!DOCTYPE window SYSTEM "chrome://browser/locale/pageInfo.dtd">

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted January 29th, 2003, 2:01 pm

That was pch's port of the fix for http://bugzilla.mozilla.org/show_bug.cgi?id=181764

<a href="http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/base/content&command=DIFF_FRAMESET&file=pageInfo.xul&rev1=1.6&rev2=1.7&root=/cvsroot">Diff highlights for that file</a>
Former UMO Admin, Former MozillaZine General Mod
I am rarely on mozillaZine, so please do not send me a private message.
My Old Firefox config files

cdn

User avatar
 
Posts: 999
Joined: November 4th, 2002, 5:47 pm
Location: UK

Post Posted January 29th, 2003, 2:06 pm

alanjstr wrote:That was pch's port of the fix for http://bugzilla.mozilla.org/show_bug.cgi?id=181764

<a href="http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/base/content&command=DIFF_FRAMESET&file=pageInfo.xul&rev1=1.6&rev2=1.7&root=/cvsroot">Diff highlights for that file</a>


hopefully mailing him was the appropriate thing to do ?

I suppose another bug in bugzilla would have gone done well ? : )

the problem wasn't in the <!DOCTYPE >, but the licence boilerplate commenting

alanjstr
Moderator

User avatar
 
Posts: 9100
Joined: November 5th, 2002, 4:43 pm
Location: Anywhere but here

Post Posted January 29th, 2003, 2:07 pm

I PM'd pch to ask if it should go into Bugzilla.
Former UMO Admin, Former MozillaZine General Mod
I am rarely on mozillaZine, so please do not send me a private message.
My Old Firefox config files

pch
 
Posts: 32
Joined: November 5th, 2002, 2:57 pm
Location: France, Paris

Post Posted January 29th, 2003, 3:01 pm

that should be fixed, thanks!!!

crippled-bird
Guest
 

Post Posted January 29th, 2003, 5:16 pm

[quote="cdn"]
the problem wasn't in the <!DOCTYPE >, but the licence boilerplate commenting[/quote]

I temporarily removed the license block from mozilla/browser/base/locale/pageinfo.dtd and it works.

Looks like pch has a fix in CVS already.

Return to Firefox Bugs


Who is online

Users browsing this forum: No registered users and 1 guest