MozillaZine

[Solved] White page before content loads?

Discussion about official Mozilla Firefox builds
vasa1
 
Posts: 604
Joined: December 24th, 2010, 5:32 am

Post Posted February 11th, 2011, 6:51 am

I have the following code in userContent.css:
Code: Select all
* { background-color: #b0b0b0 !important; }
* html, body { background-color: #b0b0b0 !important; transparent !important; }
* { color: black !important; }


This forces pages to have a light grey background which I find less stressful (on my eyes) than pure white. (It does cause quite a few problems with background images but I manage.)

What I have to say below relates to the times I have to use a slow internet connection.

I've noticed that pages (new links unrelated to the current page) often are completely blank and white before my useContent.css (and page content) kicks in. This never used to happen with Fx 3.6, IIRC, but is quite common with the Firefox betas and with the latest Minefields. To my mind, with Fx 3.6, I'd first get a blank but grey page before page content would load.

I've even gone into Tools > Options > Content and set the background color there to grey to override web page colors but the page still flashes white before the content loads.

My workaround is to open pages in a new tab in the background but I'd like to know if others see the same issue and if there's a solution available.
Last edited by vasa1 on February 11th, 2011, 8:49 pm, edited 1 time in total.

LIMPET235
Moderator

User avatar
 
Posts: 37721
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted February 11th, 2011, 6:53 am

Moving to Builds...
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-56.0.1-57.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting.
(Always choose the "Custom" Install.)

a;skdjfajf;ak

User avatar
 
Posts: 17002
Joined: July 10th, 2004, 8:44 am

Post Posted February 11th, 2011, 7:09 am

Try today's nightly build, there was a patch, I think yesterday that should have fixed that.

EDIT: https://bugzilla.mozilla.org/show_bug.cgi?id=594821 was the bug I was thinking of...

vasa1
 
Posts: 604
Joined: December 24th, 2010, 5:32 am

Post Posted February 11th, 2011, 9:14 am

Littlemutt, thanks for the link. I went through it and it certainly seems related. I'm on 4.0b12pre (2011-02-10). Most of the concern was about Win 7 but I'm on Win XP (still). I will surely check out the next build and hope for the best. As I said, the problem is more visible if I browse with a slow internet connection which I guess isn't an issue for the devs ;) !

vasa1
 
Posts: 604
Joined: December 24th, 2010, 5:32 am

Post Posted February 11th, 2011, 10:32 am

Well, I downloaded 4.0b12pre (2011-02-11) and the problem is still there just as before. I guess I'll just have to open pages in the background and switch to them when they're "ready".

Bozz
 
Posts: 2673
Joined: October 18th, 2007, 1:53 pm

Post Posted February 11th, 2011, 4:26 pm

Try this in userChrome.css. It works for me.

Code: Select all
tabbrowser tabpanels {
background-color: #your choice !important;
}

lithopsian
 
Posts: 3663
Joined: September 15th, 2010, 9:03 am

Post Posted February 11th, 2011, 4:36 pm

There's a definite delay. You might be able to change the delay with some preferences, but obviously nothing is going to paint until there is something to paint.

So the question might be what you'd like to see before content appears? I have an interesting case on Linux. My current GTK library version (with a new window) shows a window frame but does not paint over the existing content so is effectively transparent until Firefox content paints. I like this. A newer version of the libraries draws a plain grey screen for a few tenths of a second and then draws content, which I find very distracting. I can change the colour of the plain screen but no colour will stop it being jarring.

KWierso
 
Posts: 8831
Joined: May 7th, 2006, 10:29 pm
Location: California

Post Posted February 11th, 2011, 4:38 pm

For me, I set about:blank pages to use Aero Glass for the full browser screen in Stylish.

Seems to do the trick.

vasa1
 
Posts: 604
Joined: December 24th, 2010, 5:32 am

Post Posted February 11th, 2011, 8:48 pm

Bozz wrote:Try this in userChrome.css. It works for me.

Code: Select all
tabbrowser tabpanels {
background-color: #your choice !important;
}



Thank you very much! That works perfectly for me!

Return to Firefox Builds


Who is online

Users browsing this forum: quirK and 2 guests