MozillaZine

Thunderbird and wrapping plain text messages

User Help for Mozilla Thunderbird
sojusnik
 
Posts: 23
Joined: April 14th, 2011, 2:07 am

Post Posted April 19th, 2011, 2:09 am

Hello,

Using TB 3.1.8 on Ubuntu 10.10 64-bit.

When typing messages in plain text, wrapping works correctly, but the quotation that is inserted is not wrapped at all. See 1. screenshot. Is this by design or is there a workaround for this?

When I receive this message, the text is not wrapped after 72 chars, but is instead wrapped at the end of the window. See 2. screenshot.

I want to send messages, that are always wrapped after 72 chars and that the recipient should see them always this way, like in the 3. screenshot.

How do I accomplish this?

1. screenshot
Image

2. screenshot
Image

3. screenshot
Image

Thanks in advance!

sojusnik
 
Posts: 23
Joined: April 14th, 2011, 2:07 am

Post Posted April 20th, 2011, 12:29 pm

Is this a very uncommon request, so that nobody knows how to manage this or is the answer so obvious, so that nobody wants to give a hint?

mgagnonlv
 
Posts: 731
Joined: February 12th, 2005, 8:33 pm

Post Posted April 21st, 2011, 6:33 pm

I don't think it can be handled natively in Thunderbird. However, there are two extensions to do so.

1. QuoteAndComposeManager.
Available here: http://nic-nac-project.org/~kaosmos/realborders-en.html
I know it works.

2. Toggle Word Wrap, at https://addons.mozilla.org/fr/thunderbi ... word-wrap/
It is an official extension, but I'm not sure it does what you want.
Michel Gagnon
Montréal (Québec, Canada)

sojusnik
 
Posts: 23
Joined: April 14th, 2011, 2:07 am

Post Posted April 22nd, 2011, 1:23 am

@mgagnonlv

Thanks for answering.

These two add-ons are not really what I'm searching for.

I simply want to send e-mails in plain text, that are wrapped and that other people will get them wrapped too. From time to time I receive e-mails from others in plain text that is wrapped, see below. I also want to have my e-mails this way, isn't there a convenient method in TB to do so?

Image

DanRaisch
Moderator

User avatar
 
Posts: 121116
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 22nd, 2011, 3:54 am

Try adding that quotation "without formatting" so that any wrapping code in the pasted material does not override your own formatting selections.

sojusnik
 
Posts: 23
Joined: April 14th, 2011, 2:07 am

Post Posted April 22nd, 2011, 4:44 am

Either I am inserting the text from cache as a quotation or normal. The "insert without formatting" option is disabled, because I have plain text (not HTML). When I enable to write my e-mails in HTML, than I can insert without formatting, but I want to have plain text e-mails.

DanRaisch
Moderator

User avatar
 
Posts: 121116
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 22nd, 2011, 5:05 am

Pasting as a quotation adds a > to the start of each line, formatting of a sort. Do you see the same issue if you just paste rather than as a quotation?

What happens if you do a plain paste and then highlight the pasted material and press Ctrl+R (or use menu path Edit->Rewrap)?

rsx11m
Moderator
 
Posts: 14425
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted April 22nd, 2011, 7:31 am

sojusnik is talking about flowed format, which is specific to plain-text messages and allows the receiving e-mail client to rewrap the message to fit the current window width.

There are two hidden preference settings which you can access through Edit > Preference > Advanced > General tab > Config Editor button:
  • mailnews.display.disable_format_flowed_support double-click to change to "true" to avoid the Thunderbird rewraps messages received for which the sender allows flowed formatting;
  • mailnews.send_plaintext_flowed double-click to change to "false" to avoid the Thunderbird marks messages sent as flowed.
This should fix it as intended. There is also mailnews.wraplength which allows you to change the 72 default to a different line length for messages you compose.

sojusnik
 
Posts: 23
Joined: April 14th, 2011, 2:07 am

Post Posted April 24th, 2011, 12:39 am

@rsx11m

Thank you for taking part in this conversation. Flowed format is excactly what I was talking about.

That solved my problem!

rsx11m
Moderator
 
Posts: 14425
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted April 24th, 2011, 6:59 am

You are welcome.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 0 guests