MozillaZine

Unable to write the email to the mailbox

Discussion of bugs in Mozilla Thunderbird
Nosix
 
Posts: 1
Joined: January 2nd, 2005, 8:08 am

Post Posted January 2nd, 2005, 8:33 am

I got the same problem once my 'Inbox' file reached 2 GB. I noticed that last time that file had been modified was about the same time as when the error message started showing up.

I tried the "Compact Folders" on the File menu, but it didn't help.

<b>What helped was:</b>
I right-clicked the Inbox folder, and chose "Compact This Folder". It compacted for a few minutes, and when I checked in Explorer, the corresponding file was indeed a lot compacter now...
After this, the "Compact Folders" on the File menu worked for all folders.

If any developers read this, I suggest making an auto-compacting thing before those files reach 2 GB. Or do something about that 2 GB limit.

reldred
 
Posts: 1
Joined: January 2nd, 2005, 2:11 pm

Post Posted January 2nd, 2005, 2:18 pm

Hi guys I found a solution to the problem. It might not be the right solution for everyone but it worked for me.

Go to WINDOWS and APPLICATION DATA. Go to THUNDERBIRD then MAIL and LOCAL FOLDER. Select all the files and right click go to Properties. Uncheck 'Read-Only' and click OK.

Problem solved.

guanxi
 
Posts: 399
Joined: April 6th, 2003, 11:15 am

Post Posted January 11th, 2005, 8:52 pm

(A path like this:
C:\Documents and Settings\<USER NAME>\Application Data\Thunderbird\Profiles\default\<PROFILE>.slt\Mail\<ACCOUNT FOLDER> )

I noticed that there was a file (not the folder of the same name) in that folder called, simply "Inbox" with no file extension.

IMPORTANT
To clarify: That file is your inbox. If you delete it, you will delete your whole inbox!

Absolutely back it up before you do anything!


I don't know if that's what gdorrk meant, but I want to ensure there's no confusion.

yanw
 
Posts: 1
Joined: January 28th, 2005, 3:17 am

Post Posted January 28th, 2005, 3:22 am

I had the same problems running TB 1.0 on XP SP2.

I tried everything above but with no joy.

I uninstalled, moved my profiles folder and installed.

After setting up the problem mailbox I got the same error.

I twigged it my be AVG Free 7.0 when the "Personal Email Scanner" pop-up stayed above the tool bar.

I went into AVG, disabled the scanner, picked up my mail (it worked), went back into AVG, switched on the email scanner.

Now everything is OK, Thunderbird works, AVG works. Now I just have to restore all my old mail......

mzkellz
 
Posts: 3
Joined: November 15th, 2004, 12:55 am

Post Posted January 29th, 2005, 2:24 am

I am using AVG 7 aswell. I will have to try what you done. And maybe go back to Norton.



** ** Ok I just tried that, but still not working :( I will keep trying

greys4u
 
Posts: 12
Joined: January 5th, 2005, 12:45 am

Post Posted January 29th, 2005, 11:04 pm

I have tried everything and nothing is working, the only thing I havent done is to uninstall/reinstall. I am also using AVG, disabled it and nothing, still cant use the program. Since this bug has been so prevelant since the inception, why cant it be fixed, its very disheartening to get a new program up and running, get emails and then the program quits working, back to Eudora I go.

elJerbo
 
Posts: 1
Joined: January 31st, 2005, 4:03 am

Post Posted January 31st, 2005, 4:05 am

to the same problem was quite easier.
Simply there was a problem with a single email, not with the inbox (although i was getting the same error message). So I went to my Webmail Interface, deleted that single email, and when i pressed "get mail" in my thunderbird, it worked perfectly.
Hope it helps...

umsken
 
Posts: 1
Joined: February 4th, 2005, 6:52 pm

Post Posted February 4th, 2005, 8:17 pm

Chanc2g wrote:I've been using NETSCAPE 7x for quite a while now...have always used Netscape Browser and mail client. Just today, suddenly got that "Cannot write email to the mailbox, etc..."

I've emptied my trash folder...have emptied my mail server (sbc.yahoo) online...but still cannot get my Netscape mail client to retrieve/write the emails...it will notify me of mail...and it will send, just fine...


I suddenly got this message today from Netscape 7x also. InBox file was 2+GB (about 7500 emails).

Here's what worked for me to fix it:

1. Delete some InBox emails. The specific number you delete probably doesn't matter that much. I deleted 1000. Note the number of emails in the InBox after the deletion.

2. In Netscape, right click on InBox. Select "Compact this folder".

3. When this is done, the InBox appears unchanged and apparently it is unchanged. But Netscape created - tucked in between the InBox and Sent folders - a new mail folder called "NSTMP".

4. Left click on NSTMP. Netscape will automatically build a summary file/index and open NSTMP. You should see your reduced number of InBox emails in NSTMP. You may need to re-set your sort criteria to get it to sort the way you want.

5. Close Netscape.

6. In Windows Explorer, go to your Netscape mail files. Rename the InBox files to InboxOLD and InboxOLD.msf, respectively.

7. Rename your NSTMP files to InBox and InBox.msf, respectively. (You'll see that NSTMP is smaller than 2GB).

8. Open Netscape and it will read your new, compacted InBox and allow you to get new emails. It will also show your InBoxOld folder but you can ignore it for now.

9. Once you're satisfied that all your InBox email is there and you're able to get new emails, close Netscape and go to Windows Explorer again. You can now delete the two InBoxOLD files.

10. When you open Netscape again, only your new, compacted InBox will be there and you'll be able to get new emails.

gwhirsch
 
Posts: 3
Joined: February 9th, 2005, 8:45 am

Post Posted February 9th, 2005, 8:57 am

Well, as I understand it, that's the way the mail "boxes" are organized. For each "box" you have (inbox, sent, drafts, etc.), you will have a file with that name and a corresponding <file name>.msf file. The .msf file is the index to the file where the actual messages are stored. Deleting messaged out of the inbox, however, doesn't appear to change the size of the file. Therefore, the file size just keeps increasing and the need for occasional compacting. We've run across most of the various problems and have found that the "fix" will be determinate on what the actual cause is. A vast majority of the time, just renaming the .msf file for the respective "box" and starting email up again will cause the index to be recreated and all will be fine. However, this does not work when the inbox itself is corrupt . . . which is why deleting the inbox worked for you. The downside of that is that you lose all of the messages currently in the inbox. Some of my clients, regardless of my preaching, have hundreds of messages in their inbox. Well, I'm off to fight this same situation for one client. I'll post my results when I've finished. I hope this helps a little with an understanding of how the "boxes" are organized and indexed.

gwhirsch
 
Posts: 3
Joined: February 9th, 2005, 8:45 am

Post Posted February 9th, 2005, 9:10 am

Well, as I understand it, that's the way the mail "boxes" are organized. For each "box" you have (inbox, sent, drafts, etc.), you will have a file with that name and a corresponding <file name>.msf file. The .msf file is the index to the file where the actual messages are stored. Deleting messaged out of the inbox, however, doesn't appear to change the size of the file. Therefore, the file size just keeps increasing and the need for occasional compacting. We've run across most of the various problems and have found that the "fix" will be determinate on what the actual cause is. A vast majority of the time, just renaming the .msf file for the respective "box" and starting email up again will cause the index to be recreated and all will be fine. However, this does not work when the inbox itself is corrupt . . . which is why deleting the inbox worked for you. The downside of that is that you lose all of the messages currently in the inbox. Some of my clients, regardless of my preaching, have hundreds of messages in their inbox. Well, I'm off to fight this same situation for one client. I'll post my results when I've finished. I hope this helps a little with an understanding of how the "boxes" are organized and indexed.

NeoTritium
 
Posts: 1
Joined: February 10th, 2005, 11:28 am

Post Posted February 10th, 2005, 11:33 am

I had the same problem, unable to download emails from one of my three email accounts anymore, throwing that "Cannot write to mailbox" error. I ran through most of the solutions that worked for other people here, and the one that solved the problem for me was to disable my virus scanner temporarily. I am using Kaspersky Anti-Virus Personal 5.0.156 on Windows XP Professional and version 1.0 of Thunderbird.

gwhirsch
 
Posts: 3
Joined: February 9th, 2005, 8:45 am

Post Posted February 10th, 2005, 3:03 pm

Just finished "rescueing" a client with the same problem. Following the NSTMP route took care of both of them. The NSTMP file only showed up in windows explorer, not as a folder in netscape. Also, this was with a client with over 1800 messages in her inbox. She even had the nerve to get testy with me when I again suggested she start organizing her messages! Ya' just gotta' love 'em!

zorblek
 
Posts: 11
Joined: February 19th, 2005, 8:49 pm

Post Posted February 19th, 2005, 9:02 pm

I've encountered this same problem, and so far, I've had no luck fixing it.

I'm using version 1.0 (20041206) on Windows ME with a Gmail account. The error message appeared without warning. I don't think it's being caused by a specific email, because no emails were downloaded before the message appeared, and most of the emails that were in my Gmail inbox have since been archived. So far, I've tried compacting the inbox folder (which did nothing) and deleting the Inbox file. After doing that, instead of the error message appearing, the program simply failed to download anything. The status bar said that it was beginning to to download the first of many messages, but it never did. Also, oddly enough, deleting the Inbox file did nothing to the emails that were in my inbox...

I'd be very grateful for any help.

Thanks,

Morgan

YoniPYokA
 
Posts: 5
Joined: November 8th, 2004, 10:08 pm

Post Posted April 11th, 2005, 4:48 pm

it get me 2 days on reading all the instruction and suggestions by our fellow friend. Well at last it work now i get my new emails on our mail server...
What i did on this problem was
1. uncheck the read only attributes at Documents and Settings.
2. I compact the inbox folder twice ( 2x )...

goodluck

warriorPoet
 
Posts: 1
Joined: April 12th, 2005, 7:52 am
Location: Mid-Hudson NY state

Post Posted April 12th, 2005, 8:01 am

My situation: Windows 98, NOD32 antivirus scanner (which I cannot recommend enough ... truly the fastest and best I have used), Zone Alarm free, Spybot S&D (running TeaTimer ... which I find a must nowadays) and been using Tbird for a month or so (having imported a ton of email from Netscape Messenger 4.79) and have suffered minor flaws that have almost all been somewhat easily fixed. All of a sudden, we get the "unable to write ...."

Tried to compact ..... no go, but I am glad that I made the inbox smaller anyway ... good idea...

Tried the read only thing from above, but found they were already 'unchecked'

I will not shut down antivirus temporarily and I don't suggest that these days, to play master of the obvious to many...

What worked: Going in through webmail (as someone else suggested) and deleting the offending spam/virus email. Worked like a charm ...


Thanks for the input, everyone. You are all a great help.

Return to Thunderbird Bugs


Who is online

Users browsing this forum: No registered users and 1 guest