MozillaZine


[Ext] Gmail Manager 0.6.4.1 - Manage multiple Gmail accounts

Announce and Discuss the Latest Theme and Extension Releases.
BG69FU
 
Posts: 70
Joined: October 24th, 2010, 2:14 am

Post Posted September 6th, 2011, 10:50 pm

He stopped working again. Constant popups appears...

chelt_steve
 
Posts: 1
Joined: September 6th, 2011, 10:53 pm

Post Posted September 6th, 2011, 10:56 pm

Its died here too, not sure why and there seems to be no way of turning on any sort of diagnostic logging. I can log into Gmail if I use the gmail web site so its not my accounts that have broken.

Could it be to do with the SSL certs that got revoked the other day?

fuzzyscorpio

User avatar
 
Posts: 23
Joined: May 10th, 2009, 10:20 am

Post Posted September 7th, 2011, 4:14 am

I stopped bothering with this for several months… it was still working IIRC—I just wanted to lighten Firefox's load, for other reasons. But I REALLY need this functionality right now. So yesterday, I installed the latest version and was pleased to find it functional.

Oh, but not so fast… Today I have the problem others have reported: it just won't log in, to either account.

I wonder if it makes any sense to go back to 6.3.x?

I need to update Firefox from 3.6.21 to 3.6.22, I just remembered… so maybe I'll uninstall GMM, update FF, and try reinstalling GMM… or maybe I'll just punt. <sigh> Unfortunately there still seems to be nothing out there as good and useful as this is when it works. I guess it's because Gmail's constant tweaking is too much for the devs to deal with.

dallen50

User avatar
 
Posts: 63
Joined: June 18th, 2004, 3:13 am
Location: Harrison, Ohio

Post Posted September 7th, 2011, 4:41 am

Try "Gmail Checker" v2.5.0.2. Its in Mozilla Updates. It works with 3.6.20, 6.01, and 7.0beta. Not quite as good, but at least it works!!

fuzzyscorpio

User avatar
 
Posts: 23
Joined: May 10th, 2009, 10:20 am

Post Posted September 7th, 2011, 5:09 am

@Dallen50 Thanks very much—I was just looking at that and debating whether to try it. Everything makes me nervous at this point because my system is getting so out of date. Example: I actually broke Safari recently trying to import bookmarks to it from another browser. You don't want to know how many times I've reinstalled, restored from backup, deleted preferences, etc. No matter what, it starts to load the "welcome" page and then hangs. One of the reasons I wanted GMM back is that I can't use Safari any more to log into the second account. So, off I go to try Gmail Checker. :)

Edit: I was really hoping GM Checker wasn't one of the ones I'd already tried during periods of total GMM dysfunction… but it found its prefs file. And it still sucks compared to a functioning GMM. But it's better than nothing, I guess :)

zerman
 
Posts: 3
Joined: January 16th, 2011, 5:43 am

Post Posted September 7th, 2011, 9:08 am

since today it stopped working only for gmail accounts. Google apps accounts keep working.

how can I debug it?

dmartensson
New Member
 
Posts: 1
Joined: September 7th, 2011, 9:57 am

Post Posted September 7th, 2011, 10:04 am

I also have a problem but interestingly only on one of two computers.

Both use FF 6.0.2 and Gmail Manager 0.4.6.1, but on my home computer running Vista, it does not work.

On my work computer running Windows 7 it DOES work.

And I have closed and reopened FF on both, so it looks like there might be some corruption on settings or conflict with other addons causing this, unless it's something with windows.


Could the recently revoked certificates from Netherlands have anything with this to do?

funTomas

User avatar
 
Posts: 104
Joined: April 15th, 2004, 4:34 am
Location: Czechia

Post Posted September 7th, 2011, 10:17 am

Tried to log in with GMM but failed. No exception throwed, at least in the Error console. I guess it has somehting to do with the banned CA.

BeLGaRaTh

User avatar
 
Posts: 17
Joined: January 30th, 2004, 7:15 pm

Post Posted September 7th, 2011, 12:45 pm

Stopped working for me today too, it was after I upgraded Fx to 6.0.2 and rebooted, so is it the update blocking it or what? I use GMM all the time the other checkers are far inferior :(
Image
There are only 10 types of people in the world:
Those who understand binary and those who don't.

M3Rocket
 
Posts: 4
Joined: September 7th, 2011, 4:21 pm

Post Posted September 7th, 2011, 4:25 pm

Arrrgh! It was working till my FF upgraded itself to 3.6.22 today. :( Is this a GMail problem, or something to do with the FF update?

Giin70
 
Posts: 8
Joined: January 29th, 2010, 6:58 am

Post Posted September 7th, 2011, 5:24 pm

Odd thing is, i have 1 pc that still has no issues and 3 that do. All 4 seem to have same FF build and extensions installed. Being that i can log into gmail without issues manually i would say something changed on google end to stop the addon possibly.

Odilatinam
 
Posts: 8
Joined: October 19th, 2004, 3:52 pm
Location: Fremont, CA

Post Posted September 7th, 2011, 6:47 pm

I am also having the problem of Win Vista / Snow Leopard not logging in correctly, but Win 7 working fine.

Odilatinam
 
Posts: 8
Joined: October 19th, 2004, 3:52 pm
Location: Fremont, CA

Post Posted September 7th, 2011, 9:09 pm

Ok, I've figured out a work around:

To see more info in the Error Console, you need to visit about:config and change longfocus.gmanager.debug to true. After restarting the browser, you will see all the debugging information.

On my Win 7 machine at work, it was successfully getting the auth cookies at https://www.google.com/accounts/ServiceLoginAuth. However, on my Snow Leopard machine at home, it was getting a cookie to go to https://accounts.google.com/ServiceLoginAuth instead. The code will check the current URL for "ServiceLoginAuth" and say oh, wrong password.

The solution:

Go to your Firefox profile directory
Go to the extensions directory
Gmail Manager is {582195F5-92E7-40a0-A127-DB71295901D7}
(if it is an xpi, then you need to copy it, rename to zip, unpack, do the following changes, rezip, rename; if it is a directory, you can just do the changes directly)
Edit install.rdf to make it 6.0.* instead of 4.0.* (I guess Firefox only checks this during installation or if you change something in the extension)
Edit components/gmServiceGmail.js and change www.google.com/accounts to accounts.google.com
Restart Firefox, and it works for me on both my Snow Leopard and Win Vista machines.

dasjenige
 
Posts: 6
Joined: May 31st, 2011, 6:13 am

Post Posted September 7th, 2011, 10:23 pm

Odilatinam,
THANKS A LOT!
a little scary for a beginner who never dealt with editing such files, but it helped!

hiarmen
 
Posts: 4
Joined: November 17th, 2010, 10:17 pm

Post Posted September 7th, 2011, 11:27 pm

Thanks Odilatinam,
works like a charm! Wofff...

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest