MozillaZine

http://search.searchcompletion.com/ ?

User Help for Mozilla Firefox
Jacobolola
Guest
 

Post Posted June 24th, 2011, 11:45 am

Hi, whenever I search by entering text in the address bar and press enter, the search goes to http://search.searchcompletion.com/ . I found out that this is malware.How could have I got it? Also, can you please tell me how do I get back to google search? Thanks.

P.S. : The google search bar is working properly.

Vitesse
 
Posts: 979
Joined: April 21st, 2011, 6:03 pm

Post Posted June 24th, 2011, 12:01 pm

You could have got it any number of ways.

First thing to do is remove it, using a good anti-malware tool like Malwarebytes or SuperAntiSpyware. Once you've done that, you may find Google will return as your default search. If not, ask again. :)

Jacobolola
Guest
 

Post Posted June 24th, 2011, 12:27 pm

I did just that. I used malwarebytes and spybot to search and clean my system. It did delete the malware file from the system but the search problem still exists. Thanks.

Vitesse
 
Posts: 979
Joined: April 21st, 2011, 6:03 pm

Post Posted June 24th, 2011, 12:45 pm

Type about:config into your address bar, promise to beware of the dragons and then in the search box on the page that opens type keyword.URL

Double click on that line and a box should pop up: type http://www.google.com/search?q= into the box and click OK. Close the about:config tab and restart Firefox. You should now have Google back.

phdo74
Guest
 

Post Posted August 22nd, 2011, 11:51 pm

Vitesse wrote:Type about:config into your address bar, promise to beware of the dragons and then in the search box on the page that opens type keyword.URL

Double click on that line and a box should pop up: type http://www.google.com/search?q= into the box and click OK. Close the about:config tab and restart Firefox. You should now have Google back.


Vitesse, thanks a lot! You're a genius!!!

Julysuu
 
Posts: 1
Joined: September 10th, 2011, 9:50 pm

Post Posted September 13th, 2011, 4:43 pm

Having the same search.searchcompletion.com problem and just find a guide on this page http://blog.teesupport.com/how-to-remov ... ect-virus/
Trying to figure out how to start, hope it works

patrickjdempsey

User avatar
 
Posts: 22156
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted September 13th, 2011, 5:19 pm

Always beware of editing the registry.... it's a good way to break more than you fix.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

calikidd
Guest
 

Post Posted September 21st, 2011, 4:32 am

VITESSE

I DID THE MALWAREBYTES SCAN AND THE ABOUT:CONFIG AND THE PROBLEM IS STILL HAPPENING .. WHAT SHOULD I DO??? PLEEASE AND THANK YOU

GlobetrotterSA
New Member
 
Posts: 1
Joined: September 21st, 2011, 3:47 pm

Post Posted September 21st, 2011, 3:58 pm

I have the same problem. I type a query in Google search, then the suggested search queries appear in the dropdown list but when I hover the mouse over the options, a "google search" and "web search" link also appears beneath it. When I click on it, I'm redirected to search.searchcompletion.com

I ran CCleaner and deleted all temp files etc, ran Spybot-SD, ran Malwarebytes and it all came up clean. Yet the browser search hijack problem remains.

Vitesse,
I checked the keyword.URL string and it was not changed, it still said google, therefore fine. I only get the problem with the suggested search queries list in google search that display very dubious links below it that definitely is not part of standard google search. It's therefore still hijacked by searchcompletion.com

patrickjdempsey

User avatar
 
Posts: 22156
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted September 21st, 2011, 4:30 pm

Try Safe Mode: Help > Restart with Add-ons disabled. If that fixes it, then you have an extension causing the behavior. Check the Add-ons Manager and see if there is anything you don't recognize.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

giest4life
Guest
 

Post Posted September 23rd, 2011, 10:38 am

The Keyword.url way doesn't work. But I found that this will.

Type "about:config" in your url tab and acknowledge the warning. In the filter bar, type "search" and it will give you a list of values. Wherever the value is "Web Search" or if it's simply not Google, set it to "Google" or right click and then select the "reset" option. If done carefully, this should do the trick. It did for me.

Emer
Guest
 

Post Posted November 28th, 2011, 5:23 am

Type about:config into URL bar, and find :keyword.URL and change it on: http://www.google.com/search?q=

Problem Solved:)

Golasgil
Guest
 

Post Posted November 29th, 2011, 3:48 pm

That worked perfectly - thank you.

patrickjdempsey

User avatar
 
Posts: 22156
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted November 29th, 2011, 4:13 pm

Emer wrote:Type about:config into URL bar, and find :keyword.URL and change it on: http://www.google.com/search?q=

Problem Solved:)


Until whatever initially *caused* the search engine to be changed runs again and resets it.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

prata78
Guest
 

Post Posted December 22nd, 2011, 3:47 am

Vitesse wrote:Type about:config into your address bar, promise to beware of the dragons and then in the search box on the page that opens type keyword.URL

Double click on that line and a box should pop up: type http://www.google.com/search?q= into the box and click OK. Close the about:config tab and restart Firefox. You should now have Google back.



Works fine. Thank you.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 20 guests