MozillaZine

New Camino 2.1 not working (pages take forever to load)

Talk about the native Mac OS X browser.

Moderator: Camino Developers

YB.
 
Posts: 7
Joined: December 2nd, 2011, 3:06 pm

Post Posted December 2nd, 2011, 3:15 pm

Downloaded the update now Camino takes 10 minutes or more to open
a page if it even does that.
I restarted Camino, restarted the computer (PowerPC G5 Leopard)
Checked preferences... I am at a loss. ](*,)

Help needed quickly.. Thanks

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted December 2nd, 2011, 3:25 pm

Can you please follow the steps in bug 706969 comment 11 and comment 13 and report back?
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

YB.
 
Posts: 7
Joined: December 2nd, 2011, 3:06 pm

Post Posted December 2nd, 2011, 3:39 pm

Problem fixed with comment 11.
Bless you sir :banana: :locked:

cflawson

User avatar
 
Posts: 4721
Joined: December 26th, 2004, 2:54 pm
Location: Flying over your house in a red, white, and blue jet

Post Posted December 2nd, 2011, 4:33 pm

Note that's not a permanent workaround; you should definitely see if your router firmware has an update available, and there's a serious bug with disabling DNS prefetch at the moment. (Namely, the browser won't record any history while it's disabled.)

cl

YB.
 
Posts: 7
Joined: December 2nd, 2011, 3:06 pm

Post Posted December 3rd, 2011, 7:47 am

I found the history problem out.. hope a fix is found soon. will check on the Firmware.

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted December 3rd, 2011, 12:27 pm

The history problem is caused by a bug in Gecko that causes turning off prefetch to also turn off history :O I found the source of this bug last night and made a fix; we're now waiting for approval from the Gecko drivers to be able to land the patch…
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted December 3rd, 2011, 11:21 pm

I've made a build with the patch for bug 705610, so that people experiencing this problem and whose routers have no firmware upgrades available can turn off prefetch without losing history (while we wait for approval to land the patch for bug 705610).
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

YB.
 
Posts: 7
Joined: December 2nd, 2011, 3:06 pm

Post Posted December 6th, 2011, 12:20 pm

Sweet... working nicely.. Good Job :) Thank you

Uncle Asad
Camino Developer

User avatar
 
Posts: 3957
Joined: July 24th, 2004, 1:38 pm
Location: بين العالمين

Post Posted December 6th, 2011, 1:07 pm

And the fix for bug bug 705610 is now in the nightly builds (what will become Camino 2.1.1).

Everyone who is using my build should switch to the official nightly, because my build won't ever prompt you to upgrade to Camino 2.1.1 when it's released, while the official nightlies will.
Mac OS X 10.3.9 • PowerBook G4 17" 1.33 GHz | Mac OS X 10.5.x • MacBook Pro 15" 2.2 GHz
Snow7's Camino Forum FAQSearch the Forum  Camino. HelpTroubleshoot Camino

Melin

User avatar
 
Posts: 67
Joined: August 29th, 2006, 10:26 am

Post Posted December 11th, 2011, 12:30 am

thank you :)

Return to Camino


Who is online

Users browsing this forum: No registered users and 0 guests