MozillaZine

Hardware Acceleration conflicted with Nvidia drivers...

Discussion about official Mozilla Firefox builds
Xetmes

User avatar
 
Posts: 527
Joined: December 7th, 2011, 8:54 am
Location: Poland/Germany

Post Posted January 20th, 2012, 5:30 am

Since few days I was facing problems with my display driver for GPU GTX 460 (Palit Sonic Edition), problem happen only during browsing, never in games, graphic programs etc, since smooth scrolling landed in Nightly (yes I use only Nightly, always latest) problem happen almost every half hour, display become black and I got system info about crashed driver and successful recovery... I've disable smooth scrolling and that helped for a while, but suddenly when I was browse some pages with a lot images then problem with driver happen again, so I've decided to disable Hardware Acceleration, since then no single driver crash....

I've read "100" threads in Net, Nvidia Forum is full of topics with this problem, at least in 80% of them there is info about browsing Net with Firefox, so I've open this thread to get some feedback from other Nightly/Aurora users, if Moderators think that I'm in wrong section please move it to right one-thank You.

I've also Nightly crash together with display driver crash, at this moment I don't have link to crash but I will update this thread ASAP, I like to start some discussion about this problem, I like to use HA in My Nightly, so maybe we can push Ppl from Mozilla to take closer look at this problem...

GRT.

(Sorry for language errors, English isn't my native language...)

Zlip792

User avatar
 
Posts: 1332
Joined: May 7th, 2011, 1:47 pm
Location: Pakistan

Post Posted January 20th, 2012, 6:14 am

It is nvidia driver issue and they fixed it in newer driver. nvidia forceware 290.53 Beta also contain one type of TDR fix while second is coming with newer driver during January. Meanwhile try this:
http://www.raymond.cc/blog/fix-nvidia-d ... esponding/

pal-moz
 
Posts: 5935
Joined: September 23rd, 2005, 5:40 pm
Location: Tokyo , Japan

Post Posted January 20th, 2012, 8:34 am

which driver version ?

no problem with v275.33.
and with smooth scrolling for years.
Last edited by pal-moz on January 20th, 2012, 5:17 pm, edited 1 time in total.
[Desktop] Windows 7 Professional (32bit/SP1) / Geforce GTX 660Ti 2GB (350.12) / 4GB RAM

rob64rock

User avatar
 
Posts: 2122
Joined: November 11th, 2009, 6:16 am

Post Posted January 20th, 2012, 8:38 am

pal-moz wrote:which diver version ?

no problem with v275.33.
and with smooth scrolling for years.

Diddo...WFM :roll:

Nvidia v285.58 with smooth scrolling

djpip27
 
Posts: 12
Joined: July 16th, 2011, 1:51 pm

Post Posted January 20th, 2012, 11:24 am

I'd also like to confirm this problem.
I'm using the latest beta drivers 290.53 on a GeForce GTX 560 Ti. Exactly as described in the original post approx every 30 seconds after exiting a full screen game whilst having nightly open the display would turn off and windows would explain that the screen/drivers had been recovered.
I have never previously seen this message and until now had not connected Nightly being the issue.

Theliel
 
Posts: 101
Joined: November 10th, 2005, 8:41 am

Post Posted January 20th, 2012, 1:01 pm

it not a fault that can be attributed exactly to nvidia. The error apparently depends on many factors, which may make this more or less often, or not exist in many cases. Depend of Drivers, Manufactured BIOS/CARD, some applications (Firefox for example)... I have a Zotac GTX 460 1GB Model and only I have got one or two TDR issue some time ago.

Next Driver release date for this mouth add some more possible drivers fix for TDR

colfer

User avatar
 
Posts: 635
Joined: December 4th, 2002, 9:34 am
Location: Virginia

Post Posted January 20th, 2012, 1:49 pm

I had a similar problem going from IE8 to IE9 on Vista with a VIA chipset. Blank browser. Finally figured out it was hardware acceleration. Control Panel / Internet Options / Advanced / Accelerated graphics. Maybe offtopic, but it shows MS's own software can have the same bugs. To tell you the truth, I find it hard to believe that software in the year 2012 cannot avoid this kind of problem. Or, why are features that can disable the browser enabled by default? When IE breaks, I figure it is malware, especially when other browsers work.

Str0ngwun

User avatar
 
Posts: 211
Joined: January 29th, 2011, 9:50 am

Post Posted January 21st, 2012, 5:40 am

I have MSI N560GTX Twin Frozr II and I have the same issue.
It is even quite worse for me: if the driver started falling (and was restored) - it will fall again and again.
It happens even without a full-screen game being run. It may happen with just Fx running.
Moreover, it happened and happens with different versions of video drivers: it happens with different betas and stable releases.
So to cure that issue I have to turn off computer completely (and exactly turn off, not just reset).
After turning off the PC and turning it on again - the issue is gone. For quite long (maybe for a week).
My personal opinion that due to global fails of Mozilla UX team, limi should resign.

Xetmes

User avatar
 
Posts: 527
Joined: December 7th, 2011, 8:54 am
Location: Poland/Germany

Post Posted January 22nd, 2012, 8:05 am

Thanks for feedback an sorry for late response from my side (observing Anonymous attack on Polish gov. sites better then movies ;) )

Zlip792 wrote:It is nvidia driver issue and they fixed it in newer driver. nvidia forceware 290.53 Beta also contain one type of TDR fix while second is coming with newer driver during January. Meanwhile try this:

This didn't help, I got another driver crash.... And I didn't see in nVidia changelog fixes for TDR but maybe I didn't search so deep, anyway hope this stable driver will fix problems a bit...

pal-moz wrote:which diver version ?

no problem with v275.33.
and with smooth scrolling for years.


Driver always latest and stable (no beta or alpha)
Smooth scrolling: i was think about latest bug fix which was landed in one of latest Nightly but I know now that wasn't problem, problem is with HA...

And finally, since 2 days, when HA is disabled I didn't had single driver crash....

GTK66
 
Posts: 1896
Joined: May 30th, 2004, 5:20 am

Post Posted January 22nd, 2012, 8:35 am

Zlip792 wrote:It is nvidia driver issue and they fixed it in newer driver. nvidia forceware 290.53 Beta also contain one type of TDR fix while second is coming with newer driver during January. Meanwhile try this:
http://www.raymond.cc/blog/fix-nvidia-d ... esponding/


No it is not fixed. I get the same TDR error using this driver. The only Nvidia driver that works well with Nightly is 275.33.

I will try that quick fix method.

Xetmes

User avatar
 
Posts: 527
Joined: December 7th, 2011, 8:54 am
Location: Poland/Germany

Post Posted January 22nd, 2012, 9:27 am

GTK66 wrote:
I will try that quick fix method.

For me this fix didn't help, I keep fingers crossed for You ;)

GTK66
 
Posts: 1896
Joined: May 30th, 2004, 5:20 am

Post Posted January 22nd, 2012, 9:31 am

Xetmes wrote:
GTK66 wrote:
I will try that quick fix method.

For me this fix didn't help, I keep fingers crossed for You ;)


Thanks but I made up my mind to just wait for the new driver. I am staying with 275.33. I know that it works .

Padanian1
 
Posts: 17
Joined: November 29th, 2008, 5:54 am

Post Posted January 23rd, 2012, 8:35 am

I have the very same problem as above described since some time. I thought it was caused by CUDA engine of some BOINC projects, but actually it's not.
I will try disable HA to see if this improves, and will feedback asap.

Harald.L
 
Posts: 280
Joined: October 22nd, 2004, 12:36 am
Location: Bavaria/Germany

Post Posted January 23rd, 2012, 9:20 am

I also had TDR issues with my GTX460 (Zotac with 2 GB memory) and 285.x drivers. I got an unofficial test driver from a nNidia guy searching for people at nVidia forums who have this issue and are willing to do tests. Link: http://forums.nvidia.com/index.php?show ... try1338004

This test driver should collect more debug data and I sent them a dozen of TDR debug dumps, most of them happened while using Firefox Aurora. For now I'm back to official 275.33 driver and no more TDRs now. I hope my debug data helps nVidia to resolve the issue with newer drivers. Perhaps they are still interested in more different people who have this issues to get more debug data.
My primary ffox test system: http://www.sysprofile.de/id20064 (Direct2D: enabled, DirectWrite: enabled, WebGL: ANGLE, GPU Accelerated Windows: Direct3D 10)
Even if my user agent shows Firefox Release version number I'm always using Aurora (updated daily) cloaked by UserAgentSwitcher

Str0ngwun

User avatar
 
Posts: 211
Joined: January 29th, 2011, 9:50 am

Post Posted January 23rd, 2012, 9:23 pm

Harald.L,
I've send 70.6Mb of my dumps to him.
My personal opinion that due to global fails of Mozilla UX team, limi should resign.

Return to Firefox Builds


Who is online

Users browsing this forum: Google [Bot] and 2 guests