MozillaZine

TB 12 Automatically Compact Folders Not Working

Discussion about official Mozilla Thunderbird builds
L.A.R. Grizzly

User avatar
 
Posts: 5349
Joined: March 15th, 2005, 5:32 pm
Location: Akron, Ohio, USA

Post Posted February 5th, 2012, 10:05 am

I have recently been experiencing very slow response to deleting messages from my Inbox (starting in TB 11 and continuing into TB 12). I found a cure from Daifne and my problem has been alleviated.

The cure was to delete my Inbox.* and Inbox.msf files and they were regenerated as expected. After doing so, I tested by sending myself a bunch of emails. I then deleted all emails from my Inbox.

My question: I checked the file sizes in my Profile folder and the Trash.* file is 0 kb when the Trash is empty, yet my Inbox.* still shows 130,042 kb (presently) when TB is closed. Is this normal? Shouldn't it be 0 kb if the Inbox is empty? I'm just wondering if my Profile may be borked (thus leading to the Inbox delays).
Last edited by L.A.R. Grizzly on February 9th, 2012, 10:29 pm, edited 1 time in total.
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.7.2, Interlink Mail 52.9.7238, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

DanRaisch
Moderator

User avatar
 
Posts: 122165
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 5th, 2012, 11:13 am

Did you compact the Inbox folder after deleting the test messages?

L.A.R. Grizzly

User avatar
 
Posts: 5349
Joined: March 15th, 2005, 5:32 pm
Location: Akron, Ohio, USA

Post Posted February 5th, 2012, 11:21 am

DanRaisch wrote:Did you compact the Inbox folder after deleting the test messages?


Ah ha! I forgot to compact my folders after the test! It's now 0 kb. Thanks. BTW, I had my "Automatically compact folders" pref set to 10 mb. Older TB versions had a default of 100 kb, so I now have it set to the lowest setting of 1 mb. I hope this helps.
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.7.2, Interlink Mail 52.9.7238, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

wsmwk
 
Posts: 2582
Joined: December 7th, 2004, 6:52 am

Post Posted February 5th, 2012, 8:26 pm

did you save them as testcases?

L.A.R. Grizzly

User avatar
 
Posts: 5349
Joined: March 15th, 2005, 5:32 pm
Location: Akron, Ohio, USA

Post Posted February 5th, 2012, 10:26 pm

wsm wrote:did you save them as testcases?


No need to, my sorry brain is already a test case! #-o
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.7.2, Interlink Mail 52.9.7238, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

wsmwk
 
Posts: 2582
Joined: December 7th, 2004, 6:52 am

Post Posted February 6th, 2012, 4:35 am

L.A.R. Grizzly wrote:
wsm wrote:did you save them as testcases?


No need to, my sorry brain is already a test case! #-o

Sorry, you've lost me. Are you saying you can reproduce this?

L.A.R. Grizzly

User avatar
 
Posts: 5349
Joined: March 15th, 2005, 5:32 pm
Location: Akron, Ohio, USA

Post Posted February 6th, 2012, 11:34 am

wsm wrote:
L.A.R. Grizzly wrote:
wsm wrote:did you save them as testcases?


No need to, my sorry brain is already a test case! #-o

Sorry, you've lost me. Are you saying you can reproduce this?


I was just being jovial. I didn't try to reproduce it. I'm sure I would run into the same problem if I raised my automatic compact pref to 10 mb, but it takes so long for the problem to show its ugly head (we're talking weeks, if set to 10mb). It will take that long to see if it returns again with my pref set to 1 mb.
Last edited by L.A.R. Grizzly on February 9th, 2012, 3:09 pm, edited 1 time in total.
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.7.2, Interlink Mail 52.9.7238, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

L.A.R. Grizzly

User avatar
 
Posts: 5349
Joined: March 15th, 2005, 5:32 pm
Location: Akron, Ohio, USA

Post Posted February 9th, 2012, 3:08 pm

I think I found a bug. Since correcting my lag by manually compacting my folders, my Inbox has now grown to over 3.7mb and there still hasn't been any automatic compacting.

Setting my folders to automatically compact at 1mb doesn't work. In fact, I don't think it was working when I had it set to 10mb (because I developed the lag problem mentioned here). My Inbox.* file has recently grown to 3.7mb and it still hasn't compacted (even when the Inbox is empty). I tried a new, clean profile with the same results. I transferred my "mail" directory from my TB profile to my SeaMonkey profile and SM compacts it without a problem.

The UI pref setting for Automatically Compact isn't sticking. Once set to 1mb, I later find it reverted back to 20mb. I think I found the trigger. If I set it to 1mb, it reverts back to 20mb as soon as I delete any message from my Inbox, Drafts, or Sent folders.

I filed a bug report:

https://bugzilla.mozilla.org/show_bug.cgi?id=725810
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.7.2, Interlink Mail 52.9.7238, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

L.A.R. Grizzly

User avatar
 
Posts: 5349
Joined: March 15th, 2005, 5:32 pm
Location: Akron, Ohio, USA

Post Posted February 21st, 2012, 2:19 pm

For those who may be experiencing this anomaly, this add-on cures the problem:

https://addons.mozilla.org/en-US/thunde ... on/xpunge/

You can set a timer to compact the folders when you want. It also has a feature to empty the Trash folder.
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.7.2, Interlink Mail 52.9.7238, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

Return to Thunderbird Builds


Who is online

Users browsing this forum: No registered users and 1 guest