MozillaZine

Right click message text: Thunderbird chooses Bing search!

User Help for Mozilla Thunderbird
mileena
 
Posts: 43
Joined: May 14th, 2005, 10:13 pm

Post Posted January 29th, 2015, 2:04 pm

When I right click on text in a message, it offers to search Bing for me! I want to use google instead. How do I disable Bing? [Note: If the solution is to add a google add-on, ok, but I want to also disable Bing so even without an add-on, Bing doesn't appear.]

I also thought Mozilla was an open software organization? Why the partisanship? I switched to Mozilla to get away from Microsoft.

DanRaisch
Moderator

User avatar
 
Posts: 117696
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 29th, 2015, 2:29 pm

What? It's not partisanship if it defaults to Google?

Try menu path Tools->Options->Advanced->click on the "Config Editor" button->enter "browser.search.defaultenginename" (without quotation marks) into the filter field. Right click on the entry when it is displayed, select "Modify" from the context menu and enter "Google" (again, without quotation marks) then click on the "OK". Close and restart Thunderbird to complete the change.

mileena
 
Posts: 43
Joined: May 14th, 2005, 10:13 pm

Post Posted January 29th, 2015, 3:15 pm

Thanks Dan, but the solution above does not work. The config editor says google now, but when I right click on text, it still says "Bing". Even after restarting Thunderbird twice.

Also, google is partisan, but their motto is "[d]o no evil". So they are unlike most corporations. Also, what I wanted is something like Firefox has, where Options > Search lets you choose the default search engine. I wish Thunderbird was like this.

Eckard

User avatar
 
Posts: 1274
Joined: September 5th, 2011, 8:17 am
Location: Paris (not TX)

Post Posted January 29th, 2015, 3:17 pm

DanRaisch wrote:.... ->enter "browser.search.defaultenginename" (without quotation marks) into the filter field. Right click on the entry when it is displayed, select "Modify" from the context menu and enter "Google" (again, without quotation marks) then click on the "OK".

This is not sufficient since by default the Google search plugin "google.xml" is no longer included in the "searchplugins" folder within the Thunderbird application.

One must also
• either install the the add-on "Google Search for Thunderbird" https://addons.mozilla.org/en-US/thunde ... thunderbi/
https://support.mozilla.org/en-US/kb/op ... ngine-list

• or add the "google.xml" plugin manually to the "searchplugins" folder within the Thunderbird profile folder
https://support.mozilla.org/en-US/kb/ad ... pen-search

mileena
 
Posts: 43
Joined: May 14th, 2005, 10:13 pm

Post Posted January 29th, 2015, 3:30 pm

Thank you Eckard! It worked!

viper69
 
Posts: 266
Joined: April 18th, 2006, 9:41 pm

Post Posted December 22nd, 2015, 7:09 pm

Thanks for these links Eckard, worked perfectly. I installed the add on, and BEFORE also went into the config file. Done with Bing1

ruauu2
 
Posts: 135
Joined: February 2nd, 2006, 3:59 pm

Post Posted September 21st, 2017, 7:48 am

I searched Add-ons, but the Google add-on isn't compatible with my version of TB (52.3.0).

I attempted to manually add the xml file as explained https://support.mozilla.org/en-US/kb/ad ... pen-search but that did not work. I still see Bing as the default and Google doesn't appear in the drop-down list Tools>Options>General>Default Search Engine.

Any suggestions on how to get Google as default search would be appreciated.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 1 guest