Firefox 40 doesn't show images on some websites [SOLVED]

Discussion about official Mozilla Firefox builds
Posts: 3
Joined: July 8th, 2015, 8:08 am

Post Posted July 8th, 2015, 9:42 am


I'm using GNU/Linux Debian Stretch (32 bits), video card Radeon 9200, browser Firefox beta 40.

I have been visiting the following sites before asking for help in this forum: ... o_not_load ... s-not-show

The Firefox 40 beta version doesn't show images on some websites. I have been testing the Firefox 42 Nightly version too, but from version 39 on..., there is some problem that cause images to not show from some sites.

For example, I cannot see images on Reddit. Instead of pictures, these areas display a black box. When I visit the site, or if I press the F5 key to refresh the browser window, I can see the images during one second o maybe less time, but then the images disappear at all.

If I use the contextual menu (right-click) on any black box and choose "View Image", I'm able to see the picture in a new tab.

If I configure the navigator for "No Style" (View - Page Style - No Style), the images are shown without problem.

I think, not sure, if the image file has png format there is no problem to be shown, so maybe the problem could be associated with the jpg format only, or something associated with .aspx from Microsoft, I don't know.

This is a snapshot of Reddit without images: ... 3070co.png

The same site, but with the page style off: ... 6083do.png

I have been asking in a Spanish forum too. This is the link's site:

This is another example site I cannot see the images (that website uses .aspx):

Thanks for reading this and all the best.

Sorry, when I showed the last snapshots, I have made a mistake loading the right profile from konsole because I have three Firefox versions installed at one time. This is a new snapshot without NoScript extension. I'm running Firefox with a clean profile. I'm not using NoScript extension at all while running Firefox 40 beta: ... a645fo.png
Last edited by logiuser on July 9th, 2015, 9:07 am, edited 1 time in total.


User avatar
Posts: 128
Joined: November 24th, 2007, 4:06 pm
Location: France

Post Posted July 9th, 2015, 12:30 am

I have open a bug (I have the same issue on an old machine)

Posts: 3
Joined: July 8th, 2015, 8:08 am

Post Posted July 9th, 2015, 8:14 am

patclash wrote:I have open a bug (I have the same issue on an old machine)

Thank you very much for the information.

Posts: 3
Joined: July 8th, 2015, 8:08 am

Post Posted July 9th, 2015, 9:07 am


Reading the bug information open by patclash I fixed the problem changing "image.downscale-during-decode.enabled" from "true" to "false" in the about:config

It works at least for me.

Thank you very much.

image.downscale-during-decode.enabled true ... f8238o.png

image.downscale-during-decode.enabled false (fixed) ... 69d8co.png

Edit. Don't forget to refresh the browser window pressing Ctrl+F5 keys once you change the settings.


User avatar
Posts: 2587
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted July 9th, 2015, 9:37 am

I would call this more of a workaround than solved for the general public at least. The default setting is true.
Intel Core i9-9900K @ 5.2 GHz | Gigabyte Z390 AORUS MASTER | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 32GB RAM | EVGA RTX2080 Ti FTW3 11GB | BenQ PD3200U 32" 4K LCD | 3-512GB Samsung 970 PRO NVMe | 2TB Samsung 860 EVO | 1TB Sabrent Rocket NVMe | Windows 10 Pro | FIOS 1Gb

Return to Firefox Builds

Who is online

Users browsing this forum: SLK350 and 4 guests