MozillaZine

Thunderbird hangs on message delete.

User Help for Mozilla Thunderbird
agasoft
 
Posts: 2
Joined: August 7th, 2015, 6:21 am

Post Posted August 7th, 2015, 8:01 am

Hello Folks,
Aleksandar is here,
I have the same, identical problem.
Thunderbird 38.1 installed, on fresh 2 Windows 10 computers.
Last 17 months, I used pop3 protocol on gmail, and, everything worked fantastic and great!
I also used pop3 on Windows 10, and had no problems at all.
Now, I decided to switch to imap protocol.
Maybe it will be worth to note, that I am connecting using 2 step verification, and using OAuth2, google authorization, but its set once, verified and working.
And, after I
switched to imap, catastrofy happened!

After every random number of deleted messages, TB freezes, 30 to 55 seconds.
Also, no procesor used, no another processes involved...
Uninstalled TB, deleted profiles, created and recreated new one...
But, nothing.
Furthermore, I installed TB with imap on my another laptop, and the same happening.
On the same laptop, Pop3 worked great under every OS.
I am really taking care of my email, and holding folders clean and fresh.
I excluded all mail folder, and everything else.
I left only inbox and spam active.
Inbox is mostly cleaned, and spam too.
No thousands of messages to block or freez TB.
Later, I come here, found this topic.
And, I set compatibility to Windows XP SP3.
You can guess, its working now...
I am ready to work with developers, volounteers, or everyone else who can help with some diagnostics and solving
this irritating problem...
No addons installed.

agasoft
 
Posts: 2
Joined: August 7th, 2015, 6:21 am

Post Posted August 14th, 2015, 4:47 pm

After a further investigation, I found that option windwos indexing of mail conflicting.
I disabled indexing in TB, and now everything returns to normal without hangs.

kgcode
 
Posts: 23
Joined: June 13th, 2014, 9:04 am

Post Posted January 3rd, 2016, 7:30 pm

I had been experiencing the "hanging on delete" issue as late as 38.5.0. After reading this post, I went to the folder where the mail files are stored, right-clicked Properties and clicked General | Advanced, unchecked Allow files in this folder to have contents indexed in addition to file properties, and applied it to all subfolders. Once I did this, the hanging problem went away. I no longer have to run in Windows XP SP3 compatibility mode.

Thanks for the post. I wish I had seen it sooner. :D

wsmwk
 
Posts: 2564
Joined: December 7th, 2004, 6:52 am

Post Posted January 3rd, 2016, 9:24 pm

kgcode wrote:I had been experiencing the "hanging on delete" issue as late as 38.5.0. After reading this post, I went to the folder where the mail files are stored, right-clicked Properties and clicked General | Advanced, unchecked Allow files in this folder to have contents indexed in addition to file properties, and applied it to all subfolders. Once I did this, the hanging problem went away. I no longer have to run in Windows XP SP3 compatibility mode.

Thanks for the post. I wish I had seen it sooner. :D

This is all very interesting. If XP SP3 compat and windows safe mode both solve your problems per viewtopic.php?p=13857407 then a) disabling Windows' indexing (that certainly makes sense for safe mode)

Unfortunately you were never referred to https://wiki.mozilla.org/Thunderbird:Te ... e_Problems which talks both about Windows' indexing AND Thunderbird's option for "Allow Windows Search to search messages". So you either have that option checked at Tools | Options | Advanced | General OR your folder where mail is stored is not inside the standard profile. (https://wiki.mozilla.org/Thunderbird:Te ... e_Problems also talks about this)

Can you tell us which it is?

kgcode
 
Posts: 23
Joined: June 13th, 2014, 9:04 am

Post Posted January 4th, 2016, 7:46 am

I have always placed my mail folder in a separate location (not the default location) from the very first time I used Thunderbird (and even before that). This was done out of habit, because a former employer had required storing mail files at a specific location, so that they could more easily find it and back it up separately. It was never a problem until I upgraded to 24.6.0 on Windows 8.1. (See viewtopic.php?f=39&t=2843195 for the original report). I have been trying each version since then, and have consistently run into the issue and had to revert to Windows XP SP3 compatibility mode. I happened upon this thread over the weekend, turned off indexing for the folder where I have all my mail files, and problem solved. After reading your post just now, I went in and looked at Allow Windows Search to search messages, and it was indeed checked. So, I unchecked that as well. But I have not run into the hanging issue since turning off indexing on the folder itself, even though this box was checked in Thunderbird.

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 10 guests