MozillaZine

High GPU load with GTX 970

User Help for Mozilla Thunderbird
void73
 
Posts: 4
Joined: March 16th, 2015, 4:55 am

Post Posted September 8th, 2015, 6:57 am

I got a new graphic card (ZT-90107-10P) and noticed that my GPU load goes from idle (135 MHz) to base (1227 MHz) when Thunderbird is open or minimized (checked with MSI Afterburner and FireStorm). My old card (ATI 5770) was idle while Thunderbird (38.2.0) was running.

Using Thunderbird safe mode, the card stays idle, so I tried all of those fixes:
- Disabling all extensions & plugins
- Deleting userChrome.css and userContent.css
- Disabling smooth scrolling
- Disabling JavaScript (javascript.enabled: false)
(I only have the default theme)
(hardware acceleration was always disabled in options menu and config: gfx.direct2d.disabled: true & layers.acceleration.disabled: true)

None of those fixed the high GPU load.

Is there something I missed that safe mode disables (maybe JIT JavaScript compiler)?
Any other ideas how to fix the high GPU load?

Edit: OS: Win7 64, Driver: 355.82

tanstaafl
Moderator

User avatar
 
Posts: 45678
Joined: July 30th, 2003, 5:06 pm

Post Posted September 8th, 2015, 10:11 am

I looked on the Nvidia web site and it looks like you are using the latest driver. Perhaps you enabled some optional feature in the graphics driver that is causing a problem? You tried running Thunderbird in safe mode, you might try running windows in "safe mode with networking" to use generic drivers/disable non-core windows services. If that doesn't have the problem then I'd focus on what drivers/services you have.

https://bugzilla.mozilla.org/buglist.cg ... d=12532852 lists bugs that mention Nividia GPU, though most of them are for Firefox. I suggest you try a custom installation of a older version of Thunderbird in a different directory, and see if it has the same problem. It will use your existing profile. See http://kb.mozillazine.org/Go_back_to_an ... hunderbird for links to the setup programs.

void73
 
Posts: 4
Joined: March 16th, 2015, 4:55 am

Post Posted September 8th, 2015, 1:05 pm

tanstaafl wrote:Perhaps you enabled some optional feature in the graphics driver that is causing a problem?


I reset all options under "Manage 3D Settings -> Global Settings" to default and this fixed the problem. I did not think that those 3D settings would affect Thunderbird with deactivated hardware acceleration, also no other applications like Firefox or LibreOffice caused that GPU increase.

Anyway, I am happy that it is fixed now and thanks a lot for your quick and detailed help! :D

Return to Thunderbird Support


Who is online

Users browsing this forum: DeepakBisht and 3 guests