MozillaZine

Thunderbird Randomly Hangs, then Recovers (Windows 10)

User Help for Mozilla Thunderbird
gtilflm
 
Posts: 7
Joined: August 3rd, 2016, 5:35 pm

Post Posted August 3rd, 2016, 7:10 pm

I recently migrated from Windows 7 to 10 from an old hard drive to a new one. Therefore, I had to re-install Thunderbird. When I did that, I copy/pasted the contents of my profile folder from the old Win. 7 drive/installation into the newly created profile on the new drive/installation.

Everything seems to be working fine, except that there are all of these random freezes that are EXTREMELY annoying to deal with. They suddenly happen, and last for around a min. or less (maybe more if I'm clicking on things during the freeze).

Other info...
* During a freeze, task manager shows that Thunderbird is using no CPU.
* Yes, I've already compacted my folders on the new drive/install.
* Version: I'm on 44.0 and says that I'm on the "Beta Channel Update"... whatever that means.

If anyone can help, please do. Thanks!

DanRaisch
Moderator

User avatar
 
Posts: 122167
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 4th, 2016, 5:08 am

First, you're using an obsolete version of Thunderbird. Try the following procedure:

Clear the browser cache and the Windows Temp directory.
Shutdown any anti-virus software you are running.
Download a new copy of the full installer from http://www.mozillamessaging.com/en-US/thunderbird/
Delete the directory C:\Program Files\Mozilla Thunderbird
Run the installer.
Restart the anti-virus program.

Note that your saved messages, address books, settings, passwords, etc (if any) are stored in a different directory from the program files and will not be removed by deleting the directory identified above.

This thread viewtopic.php?f=39&t=996475&p=5239885#p5239885 has a more detailed version of the above instructions if needed.

gtilflm
 
Posts: 7
Joined: August 3rd, 2016, 5:35 pm

Post Posted August 4th, 2016, 9:51 am

I did what you said (without the clearing the browser cache and Windows Temp dir.) and it's still happening. What's next?

DanRaisch
Moderator

User avatar
 
Posts: 122167
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 4th, 2016, 10:09 am

How is the account set up in Thunderbird, as POP or IMAP? Find out using menu path Tools->Account Settings->Server Settings->Server Type at the top right of the dialogue.
Is Thunderbird set to "Allow Windows Search to search messages" under Tools->Options->Advanced->General->System Integration block? If so, uncheck that option, close and restart Thunderbird.

makaiguy

User avatar
 
Posts: 16783
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted August 4th, 2016, 11:13 am

When I went from Win7 to Win10 I encountered a similar oroblem, especially noticeable after deleting messages (all accounts IMAP). Upon somebody's suggestion here I turned off Windows indexing of email messages, and the freezes cleared up.

Tools | Options | Advanced | General
UNcheck: Allow Windows search to search messages
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF Quantum 70.0.1 (64bit), TB 60.9.0 (32-bit) ║ Android 8.0/7.1.1: FF Mobile 68.2.0, No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

gtilflm
 
Posts: 7
Joined: August 3rd, 2016, 5:35 pm

Post Posted August 4th, 2016, 7:40 pm

I have 3 email accounts feeding into Thunderbird: 2 IMAP, and 1 POP However, this is the same setup that I had on Windows 7 and didn't have any problems there.

I unchecked the search box (Windows indexing) and that seems to have cured it. I'll reply back to this thread if the issue persists.

Assuming it's the indexing problem... any ideas on when/if Thunderbird will rectify it?

Thanks for the support!

DanRaisch
Moderator

User avatar
 
Posts: 122167
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 5th, 2016, 4:28 am

Assuming it's an indexing problem, it's unlikely there is anything that Mozilla needs to do to rectify it. The problem would be with the way that Win 10 deals with Thunderbird message files to perform the indexing.

foxyshadis
 
Posts: 37
Joined: August 22nd, 2004, 8:08 pm

Post Posted August 6th, 2016, 10:57 am

Might want to watch bug#1249056, that seems to be the only open bug that deals with this problem.

thorstencoordes
New Member
 
Posts: 1
Joined: May 15th, 2019, 1:41 am

Post Posted May 15th, 2019, 1:52 am

I am having this issue with temporarily freezing Thunderbird 60.6.1 under Windows 10 1809, too. Also in previous versions of Windows 10 and Thunderbird. I have deavtivated Windows Search. I am using 10 e-mails accounts with TB. Three POP3S and seven IMAPS. The freezing is happening radomly, while writing, while searching, while reading. I also stopped indexing of hard disk C:, but it still freezes. I have already removed all Add-Ons and tried it in safe mode. No success. Any ideas what I can do with this strange behaviour?

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 2 guests