MozillaZine

Cookies or metadata saved across sessions

Discussion about official Mozilla Firefox builds
share666
 
Posts: 109
Joined: September 2nd, 2004, 6:49 pm

Post Posted August 29th, 2016, 8:40 am

I have FF 49b7. I have noticed that whenever I start FF a folder shows up in my profile called "Storage". I have also noticed that when I go to www.theguardian.com that cookies or some kind of metadata gets deposited in this folder. This is in spite of the fact that I explicitly block this site from setting cookies in the options / privacy / exceptions setting and I set the option to delete all settings upon close of FF. I discovered this by running CCleaner and noticing that FF still showed cookies or at least something present. I opened probably another 100 sites and monitored what they did - no issues. Not sure what is going on but I'm bothered that FF does not clear or delete this folder. I have deleted this folder and reopened FF and the folder is recreated - empty to start with. Until I visit this one web site. I have attached a log from CCleaner below.


Analysis Complete - (4.881 secs)
------------------------------------------------------------------------------------------
3.73 MB to be removed. (Approximate size)
------------------------------------------------------------------------------------------

Details of files to be deleted (Note: No files have been deleted yet)
------------------------------------------------------------------------------------------
System - Temporary Files 40 KB 4 files
Advanced - Old Prefetch data 24 KB 1 files
Firefox - Internet Cache 225 KB 2 files
Firefox - Cookies 67 KB 5 files
Firefox - Crash Reports* 1 KB 1 files
Firefox - Firefox HTML5 Storage* 115 KB 7 files
Firefox - Lock Files* 0 KB 1 files
Firefox - Session 1 KB 1 files
Firefox - Site Preferences 320 KB 2 files
Firefox - Saved Form Information 192 KB 1 files
Firefox - Startup Cache* 2,731 KB 1 files
Firefox - webappsstore.sqlite* 96 KB 1 files
Windows - Recent Items More* 14 KB 2 files
------------------------------------------------------------------------------------------
Cookie: www.theguardian.com 0 KB
C:\Users\Steve\AppData\Roaming\Mozilla\Firefox\Profiles\0gg1muji.sam\storage\default\https+++www.theguardian.com\.metadata 1 KB
C:\Users\Steve\AppData\Roaming\Mozilla\Firefox\Profiles\0gg1muji.sam\storage\default\https+++www.theguardian.com\.metadata-v2 1 KB
C:\Users\Steve\AppData\Roaming\Mozilla\Firefox\Profiles\0gg1muji.sam\storage\default\https+++www.theguardian.com\cache\caches.sqlite 64 KB
C:\Users\Steve\AppData\Roaming\Mozilla\Firefox\Profiles\0gg1muji.sam\storage\default\https+++www.theguardian.com\cache\morgue\94\{ccac44b0-2aeb-4b83-8f32-22a95e1c0e5e}.final 3 KB

DanRaisch
Moderator

User avatar
 
Posts: 117678
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 29th, 2016, 9:08 am

Moving to Firefox Builds.

redwolfe_98
 
Posts: 252
Joined: September 26th, 2008, 2:13 am
Location: South Carolina, USA

Post Posted August 29th, 2016, 11:43 am

it's "dom-storage".. you can disable "dom-storage" but doing that could cause problems with some websites, so disabling it is not recommended..

i had problems with "google-drive" when "dom-storage" was disabled so i leave it enabled..

"twitter.com" uses dom-storage.. i don't know if disabling dom-storage would cause problems with using the "twitter.com" website or not..

in FF's "about:config", the setting for dom-storage is "dom.storage.enabled"..

i went to the "theguardian.com" website, just now, and i am not seeing that it is using any dom-storage..not on my computer..
Last edited by redwolfe_98 on August 29th, 2016, 12:13 pm, edited 6 times in total.
find answers at "Mozilla Support":
https://support.mozilla.org/en-US/products/firefox

DanRaisch
Moderator

User avatar
 
Posts: 117678
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 29th, 2016, 11:49 am

Ccleaner is not a recommended option on these forums. It has often been reported to cause problems by deleting elements of Firefox that are necessary for proper operation.

barbaz
 
Posts: 1677
Joined: October 1st, 2014, 3:25 pm

Post Posted August 29th, 2016, 12:03 pm

redwolfe_98 wrote:it's "dom-storage"

Nope, it's IndexedDB. localStorage goes inside the "webappsstore.sqlite" file.

You can disable by setting about:config > dom.indexedDB.enabled to false
It's not as widely used as localStorage, so I'd say if this really concerns you then you can try disabling it, but make sure to remember you disabled IndexedDB in case of site breakage.
*Always* check the changelogs BEFORE updating that important software!

redwolfe_98
 
Posts: 252
Joined: September 26th, 2008, 2:13 am
Location: South Carolina, USA

Post Posted August 29th, 2016, 12:36 pm

redwolfe_98 wrote:it's "dom-storage"

barbaz wrote:Nope, it's IndexedDB. localStorage goes inside the "webappsstore.sqlite" file

i don't really follow that.. i just saw that the "storage" folder was being used so i thought it was "dom-storage".. (i have always thought of the content in the "storage" folder as "dom-storage" )..

barbaz wrote:You can disable by setting about:config > dom.indexedDB.enabled to false

translation: in FF's "about:config", you can disable "dom.indexedDB.enabled" by setting it to "false"..

in my experience, setting "dom.indexedDB.enabled" to "false" caused problems with the "intel.com" and "c-span.org" websites (so i don't disable it)..
Last edited by redwolfe_98 on August 29th, 2016, 7:22 pm, edited 4 times in total.
find answers at "Mozilla Support":
https://support.mozilla.org/en-US/products/firefox

therube

User avatar
 
Posts: 17733
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted August 29th, 2016, 12:54 pm

See also, Indexeddb.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

barbaz
 
Posts: 1677
Joined: October 1st, 2014, 3:25 pm

Post Posted August 29th, 2016, 1:50 pm

redwolfe_98 wrote:i don't really follow that.. i just saw that the "storage" folder was being used so i thought it was "dom-storage".. (i have always thought of the content in the "storage" folder as "dom-storage" )..

The phrase "DOM storage" is confusing, to me.. why Mozilla put IndexedDB in a folder called "storage" I don't know, so if you need help following that, maybe ask them?

redwolfe_98 wrote:
barbaz wrote:in FF's "about:config", you can disable "dom.indexedDB.enabled" by setting it to "false"
You can disable by setting about:config > dom.indexedDB.enabled to false

Don't misquote me ever again. I choose my wording carefully and wrote the statement the way I wrote it for a reason.
Please fix it in your post, thanks.
*Always* check the changelogs BEFORE updating that important software!

share666
 
Posts: 109
Joined: September 2nd, 2004, 6:49 pm

Post Posted August 29th, 2016, 2:00 pm

I disabled it. The storage folder is still created but nothing is stored. Haven't done a lot of browsing to see if I am impacted. Interesting. Thanks.

share666
 
Posts: 109
Joined: September 2nd, 2004, 6:49 pm

Post Posted August 29th, 2016, 2:35 pm

Rats. I spoke too quickly. The situation is still there. Out of all the web sites I visit this is the only one that exhibits this behavior. Why would they do this and what does it do?

share666
 
Posts: 109
Joined: September 2nd, 2004, 6:49 pm

Post Posted August 29th, 2016, 4:10 pm

For whatever it is worth I went into umatrix and blocked scripts from assets.guim.co.uk

redwolfe_98
 
Posts: 252
Joined: September 26th, 2008, 2:13 am
Location: South Carolina, USA

Post Posted August 29th, 2016, 7:42 pm

share666 wrote:The situation is still there

go back and check your settings for cookies.. maybe you have the "theguardian.com" cookies set to "allow" rather than having them set to "block".. if you have them set to "allow", that could be the difference..

the only time that i see the same thing that you are seeing, in the "storage" folder, is after having visited "twitter.com", and i have cookies for "twitter.com" set to "allow"..

incidentally, to block the "theguardian.com" cookies, you need to use "https://www.theguardian.com" in the cookie-settings, not "http://www.theguardian.com".. note that one is for a secure-connection while the other isn't.. at least i assume that is the way that it works since you have to use similar settings for "allow-ed" cookies..

however, it might be best to not have any custom-settings for the "theguardian.com" cookies: it is possible that blocking cookies there could cause problems with the website..

on my computer, i have FF set to allow first-party cookies and to block third-party cookies, and i use some custom-settings for a few cookies that i want to be saved, setting them to "allow"..

i already said that i ran into some problems with some websites after disabling "dom.indexedDB.enabled".. my advice is to not disable it.. if you leave it disabled and then find that you have problems with some websites, you will need to restore the default setting for it, which is "true", or else create a new FF-profile, to resolve the problem, if you can't figure out which tweaked settings are causing problems..

here is a webpage with information about how to "refresh" FF (to create a new FF profile), in case you can't remember to re-enable "dom.indexedDB.enabled" after finding that FF doesn't function properly on some websites when it is disabled:

https://support.mozilla.org/en-US/kb/re ... sh-firefox

share666 wrote:I went into umatrix and blocked scripts from assets.guim.co.uk

imo, you should unblock scripting for "assets.guim.co.uk" if you want the "theguardian.com" website to function properly.. "assets.guim.co.uk" is a legitimate domain that belongs to "guardian news" and is used for delivering some of the content for the "theguardian.com" webpages..

again, if you find that the "theguardian.com" website is not functioning properly, try unblocking scripting for "assets.guim.co.uk".. you might need to re-enable "dom.indexedDB.enabled", too..

if you can't get anything to work, refer back to the link, above, for "refreshing" firefox, which will restore the default settings..
find answers at "Mozilla Support":
https://support.mozilla.org/en-US/products/firefox

barbaz
 
Posts: 1677
Joined: October 1st, 2014, 3:25 pm

Post Posted August 29th, 2016, 9:19 pm

redwolfe_98 wrote:here is a webpage with information about how to "refresh" FF (to create a new FF profile), in case you can't remember to re-enable "dom.indexedDB.enabled" after finding that FF doesn't function properly on some websites when it is disabled:

No need to use a jackhammer to put a push-pin. Creating a new profile for troubleshooting purposes is best done while leaving the old profile in place, by starting Firefox with the -profilemanager command-line flag.
For more information http://kb.mozillazine.org/Profile_Manager
*Always* check the changelogs BEFORE updating that important software!

share666
 
Posts: 109
Joined: September 2nd, 2004, 6:49 pm

Post Posted August 30th, 2016, 6:17 pm

I have been using a clean profile. And I reset dom.indexedDB.enabled. My experience with the website after blocking "assets.guim.co.uk" has been fine. I am still able to read content. I still don't know why or what information is being stored on my PC. Until I have a better handle on it I intend to keep it blocked. I've asked the Guardian but I have not received a reply and probably won't. I wonder if they do the same thing in the EU. This is more idle curiosity than any paranoia. I have free time after retiring and I like to go down rabbit trails just the see where they lead.

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 8 guests