MozillaZine

The Official 20170811 builds are out

Discussion about official Mozilla Firefox builds
Peja Stija

User avatar
 
Posts: 548
Joined: June 4th, 2008, 8:46 am
Location: Belgium (proud producer of waffles)

Post Posted August 10th, 2017, 5:26 pm


The day the marginal userbase wins of the last weeks dried up again.
I'm telling you folks, that kind of "climate change" is a hard cookie to crack.

Anleck
 
Posts: 98
Joined: March 5th, 2011, 6:38 pm

Post Posted August 10th, 2017, 6:57 pm

I guess someone is in a fun mood ..nightly icon/branding... https://image.ibb.co/k5zkHF/Screenshot_447.png (inbound build)

dbcooper.dk
 
Posts: 893
Joined: March 14th, 2010, 3:44 am

Post Posted August 10th, 2017, 8:33 pm

Are there any performance issues with the uBlock Origin webextension?

Lurtz
 
Posts: 145
Joined: June 12th, 2016, 12:25 pm

Post Posted August 11th, 2017, 12:07 am

Peja Stija wrote:

The day the marginal userbase wins of the last weeks dried up again.
I'm telling you folks, that kind of "climate change" is a hard cookie to crack.

I don't think so.
Resonance for Nightly 57 has been staggeringly positive and more and more people are getting their head around the new addons ecosystem and what it means for them.

dbcooper.dk wrote:Are there any performance issues with the uBlock Origin webextension?

Not anymore, as far as I can tell by everyday use.

dbcooper.dk
 
Posts: 893
Joined: March 14th, 2010, 3:44 am

Post Posted August 11th, 2017, 12:15 am

Thanks dude.

avada
 
Posts: 1707
Joined: February 10th, 2008, 6:30 am
Location: Hungary

Post Posted August 11th, 2017, 12:25 am

avada wrote:Hi!

Can anyone confirm thatColor That Site! addon isn't functioning when the page is opened from gmail. And it won't function for that tab (content process?). If I load the same url in a different tab manually the colors are changed normally.

I think it's likely that it's because of the redirect you get when you open links from gmail. Which sound awfully similar. The wretched Bug 1319111 (Expose result principal URL ("final channel URL") on LoadInfo, convert current consumers of LOAD_REPLACE) which was backed out at least five times caused issues with redirects.


Well bisection pointed to the nightly build of 2017-07-22.

(The particular bug it points to is "Bug 1381842 - follwup: Fix wpt manifest file, r=bustage-fix a=bustage-fix". But mozregression always points to the wrong bug at the end...)

Peja Stija

User avatar
 
Posts: 548
Joined: June 4th, 2008, 8:46 am
Location: Belgium (proud producer of waffles)

Post Posted August 11th, 2017, 2:41 am

EDIT: Seems to happen with "View Selection Source" on specific content, for example, when "View Selection Source" from something on this forum, all stays fine, doing the same from anything on sites below triggers the bug.

Code: Select all
    http://userscripts-mirror.org/scripts/review/71722
    http://www.majorgeeks.com/

Reproducible ?

STR:
- Have a couple of Web-extensions installed (in my case : uBlock Origin, Tampermonkey)
- Select a "View Selection Source" from some part of a tab, so a view-source**** tab opens.
- All Web-extensions stop working, their icons no longer open up, it seems they stall, and opening new tabs all fail to fetch content. (That last one may be due to uBo locking up)

Alice0775

User avatar
 
Posts: 2571
Joined: October 26th, 2007, 11:25 pm
Location: OSAKA JPN

Post Posted August 11th, 2017, 5:25 am

Peja Stija wrote:EDIT: Seems to happen with "View Selection Source" on specific content, for example, when "View Selection Source" from something on this forum, all stays fine, doing the same from anything on sites below triggers the bug.

Code: Select all
    http://userscripts-mirror.org/scripts/review/71722
    http://www.majorgeeks.com/

Reproducible ?

STR:
- Have a couple of Web-extensions installed (in my case : uBlock Origin, Tampermonkey)
- Select a "View Selection Source" from some part of a tab, so a view-source**** tab opens.
- All Web-extensions stop working, their icons no longer open up, it seems they stall, and opening new tabs all fail to fetch content. (That last one may be due to uBo locking up)


yes, reproduced.

Filed
[*]#1389496 [Toolkit:WebExtensions: Untriaged]-WebExtensions do not work properly anymore once after open "View Selection Source" [Uns]
Last edited by Alice0775 on August 11th, 2017, 6:55 am, edited 1 time in total.

mdew

User avatar
 
Posts: 339
Joined: March 2nd, 2005, 2:34 am

Post Posted August 11th, 2017, 5:49 am

Why is mozilla ignoring the no tinderbox builds bug? :(

Nightwish

User avatar
 
Posts: 171
Joined: September 8th, 2003, 5:26 am

Post Posted August 11th, 2017, 5:51 am

dbcooper.dk wrote:Are there any performance issues with the uBlock Origin webextension?

I use uBlock Origin and Tampermonkey web extensions and don't see any performance problems in daily use. Memory footprint of the extension child process might still be a bit high, other than that it seems to work well enough by now.

WaltS48

User avatar
 
Posts: 3402
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted August 11th, 2017, 6:16 am

mdew wrote:Why is mozilla ignoring the no tinderbox builds bug? :(


Maybe because the Triage Owner is on PTO until August 14th?
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

BruceAWittmeier

User avatar
 
Posts: 2620
Joined: June 9th, 2008, 10:53 am
Location: Near 37.501685 -80.147967

Post Posted August 11th, 2017, 8:07 am

This may not be the right answer but seems to work for now. One or the other may work for you.

about:config

https://www.reddit.com/r/firefox/commen ... h=5a197875
extensions.allow-non-mpc-extensions; << set true to bypass


This was posted before but does not seem to have any effect.

toggle this to make addons work regardless legacy addons
xpinstall.signatures.required >> set false to bypass
~ I'm only here to Pay it Forward. ~

"I often take a very long windy road to my destination. When I arrive I often wonder how I missed the shortcut".

Peja Stija

User avatar
 
Posts: 548
Joined: June 4th, 2008, 8:46 am
Location: Belgium (proud producer of waffles)

Post Posted August 11th, 2017, 8:08 am

Alice0775 wrote:
Peja Stija wrote:...


yes, reproduced.

Filed
[*]#1389496 [Toolkit:WebExtensions: Untriaged]-WebExtensions do not work properly anymore once after open "View Selection Source" [Uns]

Thanks for reproducing & filing Alice ! :wink:

trustjmh
 
Posts: 52
Joined: May 25th, 2008, 5:49 am

Post Posted August 11th, 2017, 8:20 am

mdew wrote:Why is mozilla ignoring the no tinderbox builds bug? :(

The builds likely stopped due to switch to taskcluster.

Edds

User avatar
 
Posts: 314
Joined: July 21st, 2010, 1:13 pm
Location: SVK

Post Posted August 11th, 2017, 9:38 am

Is there a bug for this ?
Image
Caption buttons for maximized pop up windows are not rendered as they should, at least on Win 10.
PC: CPU: Core i7 6700K@4.6Ghz, MB: MSI Z270 GAMING M7, VGA: MSI GTX 1080 GAMING X, RAM: 16GB DDR4 Corsair, SSD: Samsung 850 EVO 500GB, OS: W10 x64
NB: CPU: Core i3 4030U@1.9Ghz, VGA: Intel HD4400, RAM: 4GB DDR3, SSHD: Seagate 500GB, OS: W10 x64 Phone: LG G4 Android 6.0

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 7 guests