MozillaZine

How are we supposed to find Add-ons for Nightly (57+)?

Discussion about official Mozilla Firefox builds
DN123ABC
 
Posts: 316
Joined: January 9th, 2017, 10:10 am

Post Posted August 14th, 2017, 9:32 am

Brummelchen wrote:Session Manager 0.8.1.13pre20170130b

why not the latest final which is newer than pre?
but SM is buggy.

...


Are you saying the version I have is not current? It sure looks old, but it hasn't asked for updates, and I'm pretty sure I went looking and found none. If you have some directions, that would be good. HOWEVER, it does seem to work for me at least somewhat. I try not to push it, as I sometimes keep a bunch of stuff open.

Brummelchen
 
Posts: 2747
Joined: March 19th, 2005, 10:51 am

Post Posted August 14th, 2017, 1:04 pm

i "love" people to imply me lies when i tell them facts. there is NO pre available
https://addons.mozilla.org/de/firefox/a ... /versions/
again: you are not using the latest.

btw this thread is about extension on v57, not yon your used v56 - with v57 SM will fail.

Virtual_ManPL

User avatar
 
Posts: 1914
Joined: July 24th, 2008, 5:52 am

Post Posted August 14th, 2017, 2:11 pm

Session Manager 0.8.1.13pre20170130b and Session Manager 0.8.1.13 are the same versions.
Session Manager doesn't work anymore in latest Mozilla Firefox Nightly 57.0a1 (2017-08-14).
Virtualfox persona

Are you ready for deprecation of XUL & XBL & XPCOM extensions? Not?! Try Firefox ESR

DN123ABC
 
Posts: 316
Joined: January 9th, 2017, 10:10 am

Post Posted August 14th, 2017, 2:14 pm

Brummelchen wrote:i "love" people to imply me lies when i tell them facts. there is NO pre available
https://addons.mozilla.org/de/firefox/a ... /versions/
again: you are not using the latest. ...


If there is no "pre" available, how did I get that installed? I don't make up my own versions. I also asked how to get to the latest. I don't see it. There is no update to the version I listed. That is it. Am I doing something wrong?




Brummelchen wrote:btw this thread is about extension on v57, not yon your used v56 - with v57 SM will fail.


Yes, I know this. This is one of the reasons I'm not on 57 yet. I am hoping it gets fixed, and that will be indicated in 56, and then eventually work in 57.

Brummelchen
 
Posts: 2747
Joined: March 19th, 2005, 10:51 am

Post Posted August 15th, 2017, 11:23 am

currently the API is not ready, thats why TMP also fails. converting a similar WE from chrome to firefox showed me a lot of "api not ready". code for tabs is rare, i read a comment from the author who made "toolbar buttons" (webextensions are limited to only one button, thats why TB is dead)

James
Moderator

User avatar
 
Posts: 27119
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted August 16th, 2017, 1:31 pm

Brummelchen wrote:i "love" people to imply me lies when i tell them facts. there is NO pre available
https://addons.mozilla.org/de/firefox/addon/session-manager/versions/
again: you are not using the latest.

The pre version is on the development channel for extension https://addons.mozilla.org/en-US/firefox/addon/session-manager/versions/beta and not listed in the Release
https://addons.mozilla.org/en-US/firefox/addon/session-manager/versions/

SLK350

User avatar
 
Posts: 113
Joined: July 21st, 2011, 3:19 am

Post Posted August 16th, 2017, 1:46 pm

James wrote:
Brummelchen wrote:i "love" people to imply me lies when i tell them facts. there is NO pre available
https://addons.mozilla.org/de/firefox/addon/session-manager/versions/
again: you are not using the latest.

The pre version is on the development channel for extension https://addons.mozilla.org/en-US/firefox/addon/session-manager/versions/beta and not listed in the Release
https://addons.mozilla.org/en-US/firefox/addon/session-manager/versions/

The links are showing old version from january, what are you talking about?
Fractal Design Define R5 Blackout * Intel Core i7 7700K @ 4,8 GHz * Asus Maximus IX Formula * G.SKILL DDR4 4x8GB PC4000 CL18 Trident Z * Samsung 960 Pro 512GB * Benq BL3201PT * ASUS GeForce GTX 1080 TI ROG Strix * Creative Soundblaster X7 * Windows 10 Pro x64 build 16251

bjherbison
 
Posts: 711
Joined: October 6th, 2003, 5:40 am
Location: Bolton, MA, US

Post Posted August 16th, 2017, 2:01 pm

The "Find a Replacement" link for legacy extensions now includes legacy extensions, but "legacy content will be removed from the Featured Extensions collection on 1 September".

https://github.com/mozilla/addons-server/issues/6162

James
Moderator

User avatar
 
Posts: 27119
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted August 16th, 2017, 2:35 pm

SLK350 wrote:
James wrote:
Brummelchen wrote:i "love" people to imply me lies when i tell them facts. there is NO pre available
https://addons.mozilla.org/de/firefox/addon/session-manager/versions/
again: you are not using the latest.

The pre version is on the development channel for extension https://addons.mozilla.org/en-US/firefox/addon/session-manager/versions/beta and not listed in the Release
https://addons.mozilla.org/en-US/firefox/addon/session-manager/versions/

The links are showing old version from january, what are you talking about?

Brummelchen was saying there is no pre version and I showed where it is.

DN123ABC
 
Posts: 316
Joined: January 9th, 2017, 10:10 am

Post Posted August 16th, 2017, 4:05 pm

SLK350 wrote:The links are showing old version from january, what are you talking about?



James wrote:The pre version is on the development channel for extension https://addons.mozilla.org/en-US/firefox/addon/session-manager/versions/beta and not listed in the Release
https://addons.mozilla.org/en-US/firefox/addon/session-manager/versions/

The links are showing old version from january, what are you talking about?[/quote]
Brummelchen was saying there is no pre version and I showed where it is.[/quote]



THIS IS WHAT I WAS SAYING!

The version I listed is from January, and that is the latest available, as backed up by James and triple-confirmed by SLK350.

WaltS48

User avatar
 
Posts: 3474
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted August 17th, 2017, 6:15 am

About Session Manager.

You can follow the progress of the Not compatible with 57+ bug, found by clicking the link to the Support site
here.

If a developer of a favorite extension doesn't have a support site or email, then I guess you wait until all the pieces of the puzzle are in place.

Makes it a bit hard to use Nightly for some right now, but I'm making do with what I got.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

Return to Firefox Builds


Who is online

Users browsing this forum: No registered users and 7 guests