MozillaZine

Firefox 55 Javascript Scrolling Panning Positioning

Discuss how to use and promote Web standards with the Mozilla Gecko engine.
Freyberg
 
Posts: 3
Joined: August 30th, 2017, 2:54 am

Post Posted August 30th, 2017, 3:06 am

I don't know if this should be called a bug, but there is an error on our pages that occurs only with new Version of Firefox (55 and 56Beta). If you go to https://wb-web.de every page jumps after a short moment to the end of the page, due to a very tricky Javascript reacting on scrolling. We are not able for debugging because the error disappears.
But there is a message: "This site appears to use a scroll-linked positioning effect. This may not work well with asynchronous panning; see https://developer.mozilla.org/docs/Mozi ... kedEffects for further details and to join the discussion on related tools and features! "
Any idea?
Thank you
Johan

DanRaisch
Moderator

User avatar
 
Posts: 118022
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 30th, 2017, 4:13 am

Moving to Web Development.

You might try reviewing the the errors and warning messages generated by the W3C Validator tool -- https://validator.w3.org/unicorn/check? ... nformance#

Freyberg
 
Posts: 3
Joined: August 30th, 2017, 2:54 am

Post Posted August 30th, 2017, 4:46 am

Thank you,
You are right. There are a lot of CSS errors that might have to do with the problem. But the main error is caused by Javascript and the page works fine since 2 years with all browsers. Even with Firefox 54. With Fx 55 the page seems to wait a tenth of second after rendering and is then scrolling down.
Johan

Frenzie

User avatar
 
Posts: 2110
Joined: May 5th, 2004, 10:40 am
Location: Belgium

Post Posted August 30th, 2017, 7:52 am

What's the tricky part in debugging? I would imagine it's related to that menu on top that gets smaller as you scroll down. Just throw some console.log statements in scrollToPosition and where it's called (I just searched for the word "scroll", not to be taken as an exhaustive suggestion) to see which value is out of whack. ;)
Intelligent alien life does exist, otherwise they would have contacted us.

Freyberg
 
Posts: 3
Joined: August 30th, 2017, 2:54 am

Post Posted August 31st, 2017, 2:16 am

Thanks a lot.
Meanwhile we didn't found the technical reason, but the script that is responsible for the error. It is the rich text editor wysihtml we use for posting comments.
On github the error was already confirmed.
https://github.com/Voog/wysihtml/issues/385
We're gonna deactivate this script first...

thank you for your help and reading
johan

Return to Web Development / Standards Evangelism


Who is online

Users browsing this forum: No registered users and 0 guests