No filenames shown when trying to add attachment

User Help for Mozilla Thunderbird
Posts: 7
Joined: September 6th, 2017, 7:42 am

Post Posted September 6th, 2017, 8:06 am

I am using Thunderbird 52.3.0 on two computers running Windows 7 Professional (64 bit).

During the past few days I have experienced this problem on both computers. When clicking on 'Attach' Windows Explorer opens showing only icons with no filenames. I have tried the following:

Reinstalled Thunderbird
Installed earlier version of Thunderbird
Ran Thunderbird in Safe Mode with all add-ons disabled.
Carried out System Restore to a date when I know the problem did not exist.
Ran virus and malware scans which are clean.

None of these worked. Windows Explorer opens properly outside of Thunderbird and there is no problem if I add attachments by accessing my email address directly from webmail. I have also tried downloading another email client and the add attachments process works correctly with all filenames showing properly.

This led me to believe that the profile may have become corrupted and my next step was to be to rename the current profile to _OLD. This will presumably lead to a new profile being created when I open Thunderbird and if this solves the problem I will be able to copy and past my email folder into it so that all my old emails are there. I did not want to do this until I get confirmation that this would be the next step.

If all else fails I have Acronis images for both computers from a couple of weeks ago but why has this happened at the same time on two different PCs? I have not installed any new software and there have been no Windows updates since the problem manifested itself and, as I said before, virus and malware scans are negative.

The only thing that has happened with both PCs is that I have had a problem with Adobe Reader DC which will not open properly on either machine and I have now uninstalled it on both PCs. I don't know if the two things are connected but I am at a loss to think of anything else.

Any suggestions would be much appreciated.

EDIT: Whilst waiting for my message to appear I have been searching the forum and found that it is possible to open Windows Explorer from outside of Thunderbird and drag the file to be attached into the attachment panel. This works but I would still like a more permanent solution if possible.


User avatar
Posts: 120091
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted September 6th, 2017, 10:12 am

AFAIUI, the file manager window that appears when you use menu path File->Attach->File (or press Ctrl+Shift+A) is Windows functionality, not part of Thunderbird's own code. Have you confirmed that you have the drop down at the lower right of that explorer window set to "All files (*.*)"?

Posts: 7
Joined: September 6th, 2017, 7:42 am

Post Posted September 7th, 2017, 12:01 am

I don't get that option. The Windows Explorer box is completely corrupted. This is what I get:

As I said before, the Windows Explorer box opens correctly if I attach from my webmail or any other email client. The problem is just with Thunderbird.

Posts: 1
Joined: September 9th, 2017, 3:17 am

Post Posted September 9th, 2017, 3:27 am

I am having exactly the same problem including the malfunction of Adobe Reader which I had to uninstall. Adobe wouldn't display properly even after re-installing so I am now using Nitro. I have no idea how long I have had the problem because I don't attach many files. I have tried running Thunderbird in safe mode and updating to the latest version without any success. I am running Windows 7 Ultimate and I had set Thunderbird to not update automatically so I am at a loss to know what has happened. Don't really feel like doing a clean install of windows just to solve this problem! Anyone any ideas?


User avatar
Posts: 44224
Joined: July 30th, 2003, 5:06 pm

Post Posted September 9th, 2017, 12:56 pm

The attach files window appears to have three panes. It normally has two. It seems like more than just poor View settings for windows explorer. Do you have similar problems with File -> Open in Notepad?

I haven't found anything about how to repair windows explorer for your particular problem. The most common advice (where windows explorer won't run at all) seems to be:

Solved by running sfc /scannow.

First I launched the Task Manager using ALT+CTRL+DEL.
Then from select New Task and browse to C:\Windows\System32 and Right click and select Run as Administrator.
Then used command to sfc /scannow
Now it will take some minutes to solve the issue after that just restart the pc using shutdown /rf command and here you go you got Explorer back.

Posts: 7
Joined: September 6th, 2017, 7:42 am

Post Posted September 11th, 2017, 3:04 am

I am glad to see I am not the only one with this problem. Adobe Reader was automatically updated by Windows Update (even though I have automatic updates turned off) and it is since then that I have had the problem. Add attachments still works on my laptop even though Adobe was updated but I didn't try to open it as I did with my two PCs. I have now uninstalled Adobe Reader from all of my computers and am using PDF-Exchange Viewer instead.

I haven't yet tried to solution offered by tanstaafl but will do so when I have the time to concentrate on it.

Thank for the help so far.


Before trying the solution I thought I would just check Thunderbird again and Lo and Behold it is now opening the attach window correctly (on both PCs!). I don't know how it happened, exactly, because the only thing I have done is to uninstall Acrobat Reader but the 'attach files' problem was still there even after that and even after restarting the computer.

Anyway, thanks again to everyone.

Return to Thunderbird Support

Who is online

Users browsing this forum: Alexa [Bot], Google [Bot] and 4 guests