MozillaZine

Block emojis and weird symbols in subject line?

User Help for Mozilla Thunderbird
scubscub
 
Posts: 21
Joined: December 5th, 2008, 10:30 am

Post Posted September 22nd, 2017, 7:57 am

Hello,

Lately I've started receiving more and more messages with weird symbols and "emojis" in the subject line. Most if not all of these are spam, and they generally creep me out. How can I either:

1. Disable support for these icons so that my emails have a nice, text-only subject line; or
2. Block emails with icons in the subject line?

Thanks for any help!

tanstaafl
Moderator

User avatar
 
Posts: 43933
Joined: July 30th, 2003, 5:06 pm

Post Posted September 22nd, 2017, 9:38 am

Its possible for a message to set the character set independently for the Subject. You could write a message filter that tests whether the Subject: header contains any mention of certain character sets (risky as it might be used legitimately, with no emoji) or contains certain emoji characters. However, that doesn't let you block display of them. The only display option you normally have is whether to interpret a message as plain text or HTML. If the emoji is a non-standard one it won't be displayed if you view the message as plain text. But most have a text equivalent for the graphics image.

Sometimes the weird symbols are because the message used a different character set encoding than what view -> text encoding is set to support. Setting it to Unicode frequently works best. Use view -> message source or control->U to look at the raw message source and look at the ContentType: header nearest the Subject header. Frequently it specifies a character set. If its spam it might specify a Chinese character set such as Big5 or GBK. If so you could test if the Content-Type header "contains" Big5 etc. and treat it as spam. See http://kb.mozillazine.org/Foreign_language_spam

scubscub
 
Posts: 21
Joined: December 5th, 2008, 10:30 am

Post Posted September 26th, 2017, 6:13 pm

Thank you tanstaafl. I've looked at one of the offeding emails and it is using unicode to include a "trophy" image in the subject line. To get this to not show, or to show as a string of characters rather than a trophy, I would have to change the text encoding from unicode to some other setting?

tanstaafl
Moderator

User avatar
 
Posts: 43933
Joined: July 30th, 2003, 5:06 pm

Post Posted September 26th, 2017, 8:11 pm

You could set the default text encoding to western using view -> text encoding. That would probably display the emoji character as a black diamond with a white question mark embedded in it (due to it not being a supported character). You could try getting away using that to read most of your mail as Western and Unicode overlap in the first 256 characters.

tools -> options -> display -> formatting -> advanced has a checkbox to "allow messages to use other fonts". But it doesn't have a similar setting for text encodings. But I'd set the default for sending/receiving to western.

Other than that I can't think of any workaround other than manually editing the message's contents using something like the header tools lite add-on. That's not very practical, though I guess you could do that for any non-spam messages you want to keep.

tanstaafl
Moderator

User avatar
 
Posts: 43933
Joined: July 30th, 2003, 5:06 pm

Post Posted March 22nd, 2018, 8:06 am

viewtopic.php?f=39&t=3039069 and viewtopic.php?f=39&t=3039252 are more recent threads on the same subject, if you're still interested.

morat
 
Posts: 2664
Joined: February 3rd, 2009, 6:29 pm

Post Posted March 22nd, 2018, 1:35 pm

If I delete the <installation folder>\fonts\EmojiOneMozilla.ttf file, then the emoji images change to normal characters in Windows.

Please add option to hide emojis (WONTFIX)
http://bugzilla.mozilla.org/show_bug.cgi?id=1398391
http://bugzilla.mozilla.org/show_bug.cgi?id=1354922

For reading only as Bugzilla is not a forum.

Edit:

I meant monochrome images when I said normal characters.

Here is a emoji screenshot and a monochrome screenshot in Windows.
Last edited by morat on March 23rd, 2018, 7:14 am, edited 2 times in total.

tanstaafl
Moderator

User avatar
 
Posts: 43933
Joined: July 30th, 2003, 5:06 pm

Post Posted March 22nd, 2018, 2:35 pm

I just tried that and it had no effect. I verified afterwards that the directory wasn't somehow resurrected. Perhaps that workaround depends upon what range the Unicode character uses.

It's getting worse nowadays as even Mozilla is using those colored icons. It just got one where it was announcing interactive examples on MDN that used it.

morat
 
Posts: 2664
Joined: February 3rd, 2009, 6:29 pm

Post Posted March 22nd, 2018, 3:30 pm

Try this:

* close email client
* temporarily move the EmojiOneMozilla.ttf file to C:\
* open email client with the -purgecaches command line option

i.e.

thunderbird.exe -purgecaches
ThunderbirdPortable.exe -purgecaches

I think if you rename the file, then the font still loads.

How to disable colored emoji font in Firefox?
http://superuser.com/questions/1111369
http://bugzilla.mozilla.org/show_bug.cgi?id=1231701#c135

tanstaafl
Moderator

User avatar
 
Posts: 43933
Joined: July 30th, 2003, 5:06 pm

Post Posted March 22nd, 2018, 3:35 pm

The directory was already deleted so I didn't move that file. Instead I closed Thunderbird, edited the properties for the shortcut to add -purgecaches and restarted. I still see the unicode emoji.

morat
 
Posts: 2664
Joined: February 3rd, 2009, 6:29 pm

Post Posted March 22nd, 2018, 3:43 pm

Perhaps Windows 10 already has native support for emoji.

tanstaafl
Moderator

User avatar
 
Posts: 43933
Joined: July 30th, 2003, 5:06 pm

Post Posted March 22nd, 2018, 4:35 pm

According to http://www.surfacetablethelp.com/2017/1 ... pdate.html and https://pureinfotech.com/emoji-hardware ... indows-10/ windows 10 does have built-in support for emoji.

I'm running windows 10 x64 version 1709. The easiest way for me to see the built in emoji is to launch Microsoft Edge, select the address bar and then press the windows key and a semicolon at the same time. That displays a small popup window with a panel at the bottom with 8 icons. Seven of those icons display different tables (categories) of emoji , the other lets you search for an emoji.

I think the number of unicode emoji greatly exceeds the number of emoji that Windows 10 has native support for. See https://unicode.org/emoji/charts/full-emoji-list.html and https://emojipedia.org/microsoft/ . For example the unicode list has 10 snowflake, 10 solid blue circle and 11 solid red circle emoji, while the windows 10 popup only has one of each.

https://emojipedia.org/snowflake/ lists different representations of a single snowflake by different vendors, including Mozilla. It looks like they are the same snowflakes at unicode codepoints U+2744 in https://unicode.org/emoji/charts/full-emoji-list.html, but most vendors chose a different one from that set.

scubscub
 
Posts: 21
Joined: December 5th, 2008, 10:30 am

Post Posted March 23rd, 2018, 9:33 am

I'm glad to see I'm not the only person this bothers. Since the majority of messages containing these images are basically spam, I've been marking them as such. When occasionally I get an actual person using them, I send a reply message pointing out that their subject line looks like spam.

KorvinSilver

User avatar
 
Posts: 4
Joined: March 28th, 2018, 3:48 am

Post Posted March 28th, 2018, 3:55 am

This annoys me, too. Everybody started to include all sorts of emojis in the subject. Here's the latest one from a little company called eBay:

Image

I mean... what the @$*#!?

tanstaafl
Moderator

User avatar
 
Posts: 43933
Joined: July 30th, 2003, 5:06 pm

Post Posted March 28th, 2018, 5:28 am

The emoji shouldn't be displayed as a graphics image that overlays several headers if its just a unicode character that is mapped to a emoji. Please use Control-U or view -> message source and copy and paste the raw message source for that Subject into a post. I'd to verify it is done using unicode and edit a header in a message on my system to see if I can duplicate your symptoms.

KorvinSilver

User avatar
 
Posts: 4
Joined: March 28th, 2018, 3:48 am

Post Posted March 28th, 2018, 5:55 am

tanstaafl wrote:The emoji shouldn't be displayed as a graphics image that overlays several headers if its just a unicode character that is mapped to a emoji. Please use Control-U or view -> message source and copy and paste the raw message source for that Subject into a post. I'd to verify it is done using unicode and edit a header in a message on my system to see if I can duplicate your symptoms.


Code: Select all
Subject: =?UTF-8?Q?=E2=9C=85_Order_confirmed:_Osculum_Type_LCD_Veh...?=
“I became insane, with long intervals of horrible sanity.” -- E.A. Poe

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 5 guests