MozillaZine

Block emojis and weird symbols in subject line?

User Help for Mozilla Thunderbird
scubscub
 
Posts: 20
Joined: December 5th, 2008, 10:30 am

Post Posted September 22nd, 2017, 7:57 am

Hello,

Lately I've started receiving more and more messages with weird symbols and "emojis" in the subject line. Most if not all of these are spam, and they generally creep me out. How can I either:

1. Disable support for these icons so that my emails have a nice, text-only subject line; or
2. Block emails with icons in the subject line?

Thanks for any help!

tanstaafl
Moderator

User avatar
 
Posts: 43346
Joined: July 30th, 2003, 5:06 pm

Post Posted September 22nd, 2017, 9:38 am

Its possible for a message to set the character set independently for the Subject. You could write a message filter that tests whether the Subject: header contains any mention of certain character sets (risky as it might be used legitimately, with no emoji) or contains certain emoji characters. However, that doesn't let you block display of them. The only display option you normally have is whether to interpret a message as plain text or HTML. If the emoji is a non-standard one it won't be displayed if you view the message as plain text. But most have a text equivalent for the graphics image.

Sometimes the weird symbols are because the message used a different character set encoding than what view -> text encoding is set to support. Setting it to Unicode frequently works best. Use view -> message source or control->U to look at the raw message source and look at the ContentType: header nearest the Subject header. Frequently it specifies a character set. If its spam it might specify a Chinese character set such as Big5 or GBK. If so you could test if the Content-Type header "contains" Big5 etc. and treat it as spam. See http://kb.mozillazine.org/Foreign_language_spam

scubscub
 
Posts: 20
Joined: December 5th, 2008, 10:30 am

Post Posted September 26th, 2017, 6:13 pm

Thank you tanstaafl. I've looked at one of the offeding emails and it is using unicode to include a "trophy" image in the subject line. To get this to not show, or to show as a string of characters rather than a trophy, I would have to change the text encoding from unicode to some other setting?

tanstaafl
Moderator

User avatar
 
Posts: 43346
Joined: July 30th, 2003, 5:06 pm

Post Posted September 26th, 2017, 8:11 pm

You could set the default text encoding to western using view -> text encoding. That would probably display the emoji character as a black diamond with a white question mark embedded in it (due to it not being a supported character). You could try getting away using that to read most of your mail as Western and Unicode overlap in the first 256 characters.

tools -> options -> display -> formatting -> advanced has a checkbox to "allow messages to use other fonts". But it doesn't have a similar setting for text encodings. But I'd set the default for sending/receiving to western.

Other than that I can't think of any workaround other than manually editing the message's contents using something like the header tools lite add-on. That's not very practical, though I guess you could do that for any non-spam messages you want to keep.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 2 guests