MozillaZine

How do I not see these non ascii characters in email?

User Help for Mozilla Thunderbird
ronbo
 
Posts: 101
Joined: July 2nd, 2004, 3:52 pm

Post Posted September 29th, 2017, 9:26 am

Häagen-Dazs Vanilla
Preferences  Forward  Unsubscribe Â
âž¡ Share with a Friend. âž¡
Classic Albums – Meat

These stay in a reply also. They are not present when viewed in my gmail account with FF.

I need to change a setting--but which one?
Thanks, Ron

tanstaafl
Moderator

User avatar
 
Posts: 43265
Joined: July 30th, 2003, 5:06 pm

Post Posted September 29th, 2017, 10:27 am

Try changing view -> text encoding from Western to Unicode. You might also want change to using Unicode yourself in any message using tools -> options -> display -> formatting -> advanced -> text encoding

If that doesn't help use view -> message source or control-U and look at the raw message source, and see if the Content-Type: header nearest the Subject mentions a character set. For example,

Content-Type: text/plain; charset=UTF-8

says it uses Unicode. UTF-8 is a implementation of Unicode that is designed for backward compatibility with ASCII.

DanRaisch
Moderator

User avatar
 
Posts: 117720
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted September 29th, 2017, 10:27 am

Check the setting under Tools->Options->Display->Advanced button->Text Encoding and try setting both to "Western (ISO-8859-1)."

ronbo
 
Posts: 101
Joined: July 2nd, 2004, 3:52 pm

Post Posted September 29th, 2017, 12:02 pm

I appreciate the replies,
Ok they are now both set to Western (ISO-8859-1)
Do the fonts matter?
The top one is Arabic, and the ones underneath are:
Serif
Aril
Aril Narrow
Aril
Both Font Controls are checked
When possible use default fonts is unchecked

Changing the text encoding did not change the characters in already received emails.
Perhaps they are only used as the email message is received??
Thanks, Ron

tanstaafl
Moderator

User avatar
 
Posts: 43265
Joined: July 30th, 2003, 5:06 pm

Post Posted September 29th, 2017, 12:25 pm

view -> text encoding does not effect how the text is encoded/stored, it only effects how it is viewed/interpreted. It overrides what is set in Tools->Options->Display->Advanced button->Text Encoding -> Incoming Mail.

The fonts settings normally don't matter unless you chose something funky such as wingdings or the font size is too small to easily read the character.

Western (ISO-8859-1) is limited to 256 characters and supports many European languages, but it is not complete. For example, it doesn't support Č, č, Ď, ď, Ě, ě, Ň, ň, Ř, ř, Š, š, Ť, ť, Ů, ů, Ž, ž in Czech. That's why I suggested trying Unicode.

I repeat my suggestion that you look at the Content-Type header of several messages to see if they indicate what character set was used.

ronbo
 
Posts: 101
Joined: July 2nd, 2004, 3:52 pm

Post Posted September 29th, 2017, 12:56 pm

Thanks Tanstaafl--somehow I missed the View instructions. Yes when I change from Western to Unicode--the current message is cleaned up.
the header contains:
Content-Type: multipart/alternative; boundary="--==_mimepart_59cb96ac5d51c_5c9468a58a8575575e"; charset=UTF-8
Content Transfer Encoding: 7bit

As soon as I look at another message, and come back to affected one--the setting has resorted back to Western. I've changed the options/display--advanced button from Western to Unicode on both. after closing TB and reopening it--the View/Text Encoding default is still Western.
How do I keep it Unicode?
Ron

tanstaafl
Moderator

User avatar
 
Posts: 43265
Joined: July 30th, 2003, 5:06 pm

Post Posted September 29th, 2017, 1:16 pm

Set it to Unicode in "view -> text encoding". Make certain that auto-detect (just above Unicode) in that list box is set to "off". Don't assume it is just because you don't see a checkbox next to it. I'm not aware of anything other than auto-detect possibly messing with that setting.

It doesn't hurt to set tools -> option to Unicode or UTF-8 but that setting seems to be superseded by whats set in view -> text encoding when reading a message.

When its set to Unicode it can still display Western as its backwards compatible.

ronbo
 
Posts: 101
Joined: July 2nd, 2004, 3:52 pm

Post Posted September 29th, 2017, 2:02 pm

Thanks--but it does not stick. The Auto-Detect is set to Off--it must be default for the US. I change to Unicode and view the message and all is fine.
I go to a different message and it has the extra characters, so I change it to Unicode. I go back to the previous message and it's screwed up again because Text Encoding is set to Western.
Is this a bug--it doesn't stay set? Is there anything I can edit (or maybe add) in About:Config? I search for Text, Encode, Unicode, Western and nothing appears obvious.
Ron

tanstaafl
Moderator

User avatar
 
Posts: 43265
Joined: July 30th, 2003, 5:06 pm

Post Posted September 29th, 2017, 2:33 pm

Try setting Tools->Options->Display->Advanced button->Text Encoding -> Incoming Mail to Unicode too. When I view a message with some Unicode characters that I know are not included in the ISO-8859-1 character set they are displayed correctly if that setting is set to Western and view -> text encoding is set to Unicode. But perhaps your system works differently for some unknown reason.

I searched using the config editor . mailnews.view_default_charset is updated when I modify Tools->Options->Display->Advanced button->Text Encoding -> Incoming Mail . See if its set to UTF-8 . I also found a intl.charsetmenu.mailview.cache which currently has windows-1252, UTF-8, ISO-8859-1 . Those are the different character encodings I've been testing with.

http://kb.mozillazine.org/Mail_and_news_settings

ronbo
 
Posts: 101
Joined: July 2nd, 2004, 3:52 pm

Post Posted October 1st, 2017, 12:16 pm

Sorry to be a pita--I don't have any idea of what to do next. My mailnews.view_default_charset;UTF-8 is set correctly, and
mailnews.send_default_charset;UTF-8 is set correctly.
The real problem is--when first viewing a message--the View/Text-Encoding is always Western. I change it to Unicode and it stays there for the current message. If I view another message, and come back to the 1st one--the unwanted characters are present, and when I click View/Text Encoding it is back to Western. IOW it doesn't stick on Unicode--the setting is not saved. My laptop Ver 45.7.1 works correctly.

There is nothing in Config which contain Unicode. So nothing to change there--I guess.
Oddly--this config has:
intl.charsetmenu.mailview.cache;UTF-8, windows-1251, ISO-8859-2, windows-1250, ISO-8859-15 my laptop does not. So I reset it to Default. I closed TB, reopened it and still does the same thing, the string is gone. I have no idea how it got there--but I guess it works without it.

There must be a line that is set incorrectly. btw I'm using version--52.3.0 (32 bit). But what? Over the last 15yrs of using TB, I have changed some of the Config lines--but ONLY when someone on this forum suggested it--and it had nothing to do with these unwanted characters. Also possible--I may have installed a version and did not like where the tabs were or something, and I reinstalled a previous version. I know in Firefox I have done that and moved folders from my backup files to my User directory. Maybe I screwed something up. Once a get a few spare hours--I compare the Config line by line with my laptop.
Hopefully someone will have a suggestion.
Ron

tanstaafl
Moderator

User avatar
 
Posts: 43265
Joined: July 30th, 2003, 5:06 pm

Post Posted October 1st, 2017, 12:28 pm

A search for utf-8 in the config editor on my system finds (first three are in bold due to not being default values):

intl.charsetmenu.mailview.cache windows-1252, UTF-8, ISO-8859-1
mailnews.view_default_charset UTF-8
extensions.importexporttools.export.charset_list ARMSCII-8,GEOSTD8,ISO-8859-1,ISO-8859-2,ISO-8859-3,ISO-8859-4,ISO-8859-5,ISO-8859-6,ISO-8859-7,ISO-8859-8,ISO-8859-9,ISO-8859-10,ISO-8859-11,ISO-8859-12,ISO-8859-13,ISO-8859-14,ISO-8859-15,ISO-8859-16,KOI8-R,KOI8-U,UTF-8,UTF-8 (BOM),WINDOWS-1250,WINDOWS-1251,WINDOWS-1252,WINDOWS-1253,WINDOWS-1254,WINDOWS-1255,WINDOWS-1256,WINDOWS-1257,WINDOWS-1258
extensions.importexporttools.export.text_plain_charset UTF-8
mailnews.send_default_charset UTF-8

Ignore the two settings for importexporttools (thats an add-on) . If none of this helps try running in safe mode (help -> restart with add-ons disabled). Add-ons that no longer work correctly due to not having been updated to deal with API changes in a latter version of Thunderbird can have weird side effects.

ronbo
 
Posts: 101
Joined: July 2nd, 2004, 3:52 pm

Post Posted October 13th, 2017, 12:06 pm

I just reviewed some old posts, and one of yours (tanstall) suggested right clicking the Inbox and choosing Properties. This version of TB has Fallback Text Encoding set as Western. Changing it to Unicode results in View/Text Encoding/Unicode staying set when going to the next email message with no garbage characters. :)

Hopefully this will help others solve their problem.
Thanks, Ron

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 6 guests