Firefox doesnt load certain pages after update to 56 64bit

User Help for Mozilla Firefox
Posts: 7
Joined: September 30th, 2017, 2:21 am

Post Posted October 2nd, 2017, 12:22 am

Hi, I've refreshed and tried to create a new profile. At first, it works but how I know that the new profile will not broken again like this one. I do not know why it starts to work but then stops working and I've to either refresh or create a new one :(

New Member
Posts: 1
Joined: October 2nd, 2017, 1:23 am

Post Posted October 2nd, 2017, 1:25 am

I have the same problem, Firefox 56.0 is a joke.

Wondering why I had so many problems since upgrading.

My guess is maybe some of the add-ons are causing this fault, since they all now say incompatible.

I tried deleting all my cache and it did not help, disabling all the add-ons did not help either. I am downgrading to 55.03.

Please fix this garbage.


User avatar
Posts: 27445
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted October 2nd, 2017, 1:35 am

Kozac wrote:Please fix this garbage.

If you look at comment on right sidebar and at you will see that this is a independent forum. Mozilla does have its own users helping users forum at that has not been around as long as here.

Posts: 7
Joined: September 30th, 2017, 2:21 am

Post Posted October 2nd, 2017, 7:24 am

Hi! I think that maybe the problem could be this:

If you have the MEGA extension, you should try to disable it by the moment. I've updated Firefox on my work to version 56 and works fine. At home, I had the Mega extension on 55.0.3 so when I updated to version 56 that's the reason of the failure. Then, when I refresh or create my profile again all addons were deleted so Firefox 56 worked well. I installed later the MEGA extension but since it does not require restart Firefox worked well, until I restarted the PC and needed to open again Firefox and on that moment, it stopped work as usual.

I will try to update Firefox and disable MEGA extension when I arrive at home, if it works for me I will post it here.


Posts: 7
Joined: September 30th, 2017, 2:21 am

Post Posted October 2nd, 2017, 10:14 am

I can confirm it. Disable Mega extension until it's updated. Now Firefox 56 works as expected and if I reactivate again Mega extension the issue appears again.


Posts: 49
Joined: April 11th, 2012, 3:14 pm

Post Posted October 3rd, 2017, 10:31 pm

I'm posting here because mozilla disabled my mega addon and I've been using FF56 on 7 10 and Linux with the MEGA addon (I have them synced) since 56 came out without an issue, do you guys maybe use an user script addon like greasemonkey cos I have a lot of legacy addons and as I said no issues with mega I re-enabled it still having no issues?

Posts: 23
Joined: July 14th, 2004, 2:00 pm

Post Posted October 5th, 2017, 10:31 am

DanRaisch wrote:
This is what I discovered. Open Firefox 56, manually enter any web address (first tab will load). Open a new tab (with your mouse or ctrl + t) and manually enter another address (it will not load), open another new tab and manually enter another address (it will not load).

Not seeing that issue here in 56. Have you tried starting Firefox in Mozilla Safe Mode?
If no improvement using Safe Mode, do you have the same problem if you create a new profile and test it with no extensions or non-default themes installed?
and ... on_Windows

Stupid me, I tried opening Firefox in Safe Mode and everything works. Then I went plugin hunting and found the mega nz plugin was causing the issue. Removed the plugin and everything works again.

Posts: 55
Joined: June 5th, 2007, 12:40 pm

Post Posted October 6th, 2017, 1:07 am

Yesterday plugin got upgraded and the issue is gone. BTW, it is now a webextension, so no more "Obsolete" next to it ;-)

Return to Firefox Support

Who is online

Users browsing this forum: Google [Bot], tpaulr and 6 guests