MozillaZine

Cookies vanish??

User Help for Mozilla Firefox
Bennyd
 
Posts: 166
Joined: April 23rd, 2005, 6:53 am

Post Posted October 2nd, 2017, 11:56 am

A get TV listings from http://tvlistings.zap2it.com/tvlistings/ZCGrid.do?aid=zap2it. At that site, I specify preferences which include which channels I want to see in the listings. Occasionally, and unpredictably, the preferences vanish and I have to set up my favorite channels again; I assume a cookie is deleted or out of date? How can I keep my favorites from vanishing?

Happy112

User avatar
 
Posts: 415
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted October 2nd, 2017, 12:36 pm

Hi Bennyd !

When cookies vanish, it's usually because somebody ate them .....
But all kidding aside :
When you're on that page, have you tried this :
Click on the 'i' in a circle (left side of the address bar), then click on the little black arrow and then on 'More Information'.
Under the Permissions tab, scroll down to 'Set Cookies' and click 'Allow'

Any good ?
You can keep your diamonds - they're just shiny stones; love is the only precious thing and doesn't cost a dime.

Bennyd
 
Posts: 166
Joined: April 23rd, 2005, 6:53 am

Post Posted October 2nd, 2017, 1:21 pm

Sorry, no i in a circle on the left side of the address bar; instead, I have a short area, highlighted pink, with the Zap2it icon and a black lock with a red slash across it. If I click that, I'm told that site connection is not secure.

When looking at the cookies in this profile, I have 16 coming from the Zap2it site. Some of those cookies expire at the end of the session, and some expire about a year from today's date.

Happy112

User avatar
 
Posts: 415
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted October 2nd, 2017, 1:36 pm

Bennyd wrote:Sorry, no i in a circle on the left side of the address bar; instead, I have a short area, highlighted pink, with the Zap2it icon and a black lock with a red slash across it. If I click that, I'm told that site connection is not secure.

To the left of that padlock with the red slash through it : you don't see the letter 'i' in a circle ?
Looks just like the 'i' in a circle here on this MozillaZine page, on the left side of the URL.
When I click on your link and get on that site, I sure do see it !
The 'connection is not secure': nothing for you to worry about, as long as you don't submit any sensitive information on that site.
You can keep your diamonds - they're just shiny stones; love is the only precious thing and doesn't cost a dime.

LoveMyFoxy

User avatar
 
Posts: 1914
Joined: December 11th, 2009, 11:23 am
Location: USA

Post Posted October 2nd, 2017, 2:54 pm

I use Zap2It too. I have the i but not the pink or black lock. How often do your preferences disappear? I think it might be a bug in their site, not reading the cookie correctly. It used to be often for me, but now hardly ever.
Desktop--Win 7 Ult. 64-bit, 6GB RAM /FF 52ESR 64/ Thunderbird 52 / MS Sec. Essent./ Windows firewall / Verizon FIOS

Bennyd
 
Posts: 166
Joined: April 23rd, 2005, 6:53 am

Post Posted October 2nd, 2017, 4:59 pm

Happy112 wrote:
Bennyd wrote:Sorry, no i in a circle on the left side of the address bar; instead, I have a short area, highlighted pink, with the Zap2it icon and a black lock with a red slash across it. If I click that, I'm told that site connection is not secure.

To the left of that padlock with the red slash through it : you don't see the letter 'i' in a circle ?
Looks just like the 'i' in a circle here on this MozillaZine page, on the left side of the URL.
When I click on your link and get on that site, I sure do see it !
The 'connection is not secure': nothing for you to worry about, as long as you don't submit any sensitive information on that site.


On my Windows 7 machine, there is no i in a circle but a Zap2it icon. On my windows 10 machine, there is an i in a circle. If I click on the i on the Windows 10 machine or the Zap2it icon on the windows 7 machine, I see the permissions tab. It says "You have not granted this site any special permissions". There is nothing to scroll down to. Also, each machine has currently dated cookies to the Zap2it site, so it must have the right permissions to do so - right?

Bennyd
 
Posts: 166
Joined: April 23rd, 2005, 6:53 am

Post Posted October 2nd, 2017, 5:02 pm

LoveMyFoxy wrote:I use Zap2It too. I have the i but not the pink or black lock. How often do your preferences disappear? I think it might be a bug in their site, not reading the cookie correctly. It used to be often for me, but now hardly ever.


My preferences disappear randomly it seems like, but several weeks or months must pass. I'd be really happy if my preferences disappeared hardly ever!

LoveMyFoxy

User avatar
 
Posts: 1914
Joined: December 11th, 2009, 11:23 am
Location: USA

Post Posted October 2nd, 2017, 5:47 pm

The i and, red lock pink box are irrelevant here.

Do you have anything in Tools>Options> Privacy? Zap2It should be an exception in the Privacy>Cookies list.

Do you have FF set to remove cookies and History upon closing? Options> Privacy>Clear History When FF closes>Settings
Desktop--Win 7 Ult. 64-bit, 6GB RAM /FF 52ESR 64/ Thunderbird 52 / MS Sec. Essent./ Windows firewall / Verizon FIOS

Happy112

User avatar
 
Posts: 415
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted October 2nd, 2017, 10:14 pm

Bennyd wrote:
On my Windows 7 machine, there is no i in a circle but a Zap2it icon. On my windows 10 machine, there is an i in a circle. If I click on the i on the Windows 10 machine or the Zap2it icon on the windows 7 machine, I see the permissions tab. It says "You have not granted this site any special permissions". There is nothing to scroll down to. Also, each machine has currently dated cookies to the Zap2it site, so it must have the right permissions to do so - right?


When you see that "You have not granted this site any special permissions", like I said in my first post :
click on th little black arrow, then on 'More Information' and then you'll see the Permissions tab, where you can scroll down to 'Set Cookies' ......
You can keep your diamonds - they're just shiny stones; love is the only precious thing and doesn't cost a dime.

LoveMyFoxy

User avatar
 
Posts: 1914
Joined: December 11th, 2009, 11:23 am
Location: USA

Post Posted October 2nd, 2017, 10:24 pm

Happy112, the Cookie Monster. You ate the cookies ;-)
Desktop--Win 7 Ult. 64-bit, 6GB RAM /FF 52ESR 64/ Thunderbird 52 / MS Sec. Essent./ Windows firewall / Verizon FIOS

LoveMyFoxy

User avatar
 
Posts: 1914
Joined: December 11th, 2009, 11:23 am
Location: USA

Post Posted October 2nd, 2017, 10:28 pm

My i says no special permissions, but I do allow cookies, so cookies aren't counted as "special."

That's the first time I've ever clicked on the i.
Desktop--Win 7 Ult. 64-bit, 6GB RAM /FF 52ESR 64/ Thunderbird 52 / MS Sec. Essent./ Windows firewall / Verizon FIOS

Happy112

User avatar
 
Posts: 415
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted October 2nd, 2017, 10:30 pm

LoveMyFoxy wrote:Happy112, the Cookie Monster. You ate the cookies ;-)


Oh Shush !
And to think that I left you some ....... Now I'm going to eat them all myself !
You can keep your diamonds - they're just shiny stones; love is the only precious thing and doesn't cost a dime.

LoveMyFoxy

User avatar
 
Posts: 1914
Joined: December 11th, 2009, 11:23 am
Location: USA

Post Posted October 2nd, 2017, 10:32 pm

BennyD--
you see the Permissions if you rt-click on the page and select "View page info."
Desktop--Win 7 Ult. 64-bit, 6GB RAM /FF 52ESR 64/ Thunderbird 52 / MS Sec. Essent./ Windows firewall / Verizon FIOS

Bennyd
 
Posts: 166
Joined: April 23rd, 2005, 6:53 am

Post Posted October 3rd, 2017, 5:46 am

Happy112 wrote:
Bennyd wrote:
On my Windows 7 machine, there is no i in a circle but a Zap2it icon. On my windows 10 machine, there is an i in a circle. If I click on the i on the Windows 10 machine or the Zap2it icon on the windows 7 machine, I see the permissions tab. It says "You have not granted this site any special permissions". There is nothing to scroll down to. Also, each machine has currently dated cookies to the Zap2it site, so it must have the right permissions to do so - right?


When you see that "You have not granted this site any special permissions", like I said in my first post :
click on th little black arrow, then on 'More Information' and then you'll see the Permissions tab, where you can scroll down to 'Set Cookies' ......


Thanks, but there is no little black arrow on or adjacent to the Permissions box.

Bennyd
 
Posts: 166
Joined: April 23rd, 2005, 6:53 am

Post Posted October 3rd, 2017, 5:55 am

LoveMyFoxy wrote:BennyD--
you see the Permissions if you rt-click on the page and select "View page info."


When clicking on permissions after right clicking on View Page Info, I see that each and every item on that menu is checked "Use Default".

Under Options - Privacy, there is checked "Accept cookies from sites", "always accept third-party cookies", "and keep cookies until they expire". Under "Settings for clearing history" Cookies is not checked. These settings are how my FF has been set for a long, long time.

I want my Zap2it cookies, accept them and keep them. Y'all might can have some cookies, but no Zap2it cookies.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], LIMPET235, takeshi-kovacs and 12 guests