MozillaZine

Content Encoding Error

User Help for Mozilla Firefox
garry_

User avatar
 
Posts: 14
Joined: February 13th, 2006, 4:38 pm

Post Posted October 3rd, 2017, 12:12 pm

Hello.I'ts been a week since i have this problem in random sites.I've already cleared the cache,cookies,made new profile nothing works so far.Any ideas? :(

Grumpus

User avatar
 
Posts: 11660
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted October 3rd, 2017, 12:25 pm

First: remember your settings before you make the change, write them down.
Try Tools/Options/General/Fonts & Colors/Advanced and set "Fonts For:" to Other Writing Systems
Set "Text Encoding" to "Other(including Western European"
See if that makes any difference, restart Firefox before you check.

garry_

User avatar
 
Posts: 14
Joined: February 13th, 2006, 4:38 pm

Post Posted October 3rd, 2017, 1:24 pm

Thanks Grumpus,however the problem is still there BUT now its less frequent.

dickvl

User avatar
 
Posts: 52286
Joined: July 18th, 2005, 3:25 am

Post Posted October 4th, 2017, 1:36 am

You can check the network.http.accept-encoding prefs on the about:config page and make sure they are default.
http://kb.mozillazine.org/about%3Aconfig

garry_

User avatar
 
Posts: 14
Joined: February 13th, 2006, 4:38 pm

Post Posted October 4th, 2017, 5:02 am

It's already default.I also disabled my add-ons.Very weird issue :?

dickvl

User avatar
 
Posts: 52286
Joined: July 18th, 2005, 3:25 am

Post Posted October 4th, 2017, 7:00 am

What exactly is the error message?
Does it include details?

In some cases it is possible that other software places itself as a MITM to intercept the connection and changes the encoding.

garry_

User avatar
 
Posts: 14
Joined: February 13th, 2006, 4:38 pm

Post Posted October 4th, 2017, 7:45 am

No details just this page

https://s1.postimg.org/5vla87mqfz/Untitled.jpg

Also sometimes i get a totally blank page but this is very rare.

dickvl

User avatar
 
Posts: 52286
Joined: July 18th, 2005, 3:25 am

Post Posted October 4th, 2017, 8:08 am

Try to modify the network.http.accept-encoding.secure pref and remove the trailing ", br" to prevent the server from sending files with Brotli compression.
network.http.accept-encoding.secure = "gzip, deflate, br" => "gzip, deflate" (without quotes)

therube

User avatar
 
Posts: 18030
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted October 4th, 2017, 8:37 am

? https://support.mozilla.org/en-US/questions/945251

If you've done other testing, like Safe Mode & a new, clean test Profile, I'd look to external interference.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

garry_

User avatar
 
Posts: 14
Joined: February 13th, 2006, 4:38 pm

Post Posted October 4th, 2017, 9:25 am

Finally i found the solution.The problem was the add-on ColorfulTabs.It was incompatible with Multiprocess Windows.Now the browser is a little bit faster and i get no errors.Thank you all for you suggestions.Firefox rulez! 8-)

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 4 guests