MozillaZine

Unwanted redirect notice

User Help for Mozilla Firefox
jglanvil
 
Posts: 16
Joined: August 27th, 2015, 2:35 pm

Post Posted October 19th, 2017, 3:21 pm

In the current version of FF, how do I stop from getting the notice "Firefox prevented this page from automatically redirecting to another page?"

I have spent much time looking on line and reading about fixes for this problem. Nothing works.

jg

barbaz
 
Posts: 1677
Joined: October 1st, 2014, 3:25 pm

Post Posted October 19th, 2017, 5:00 pm

about:config > set accessibility.blockautorefresh to false
*Always* check the changelogs BEFORE updating that important software!

Reflective

User avatar
 
Posts: 2217
Joined: February 15th, 2007, 11:13 am

Post Posted October 20th, 2017, 2:44 am

Copy/paste about:preferences#advanced into the location bar and hit Enter. Click the General tab (usually opens there by default) and remove the checkmark from "Warn me when websites try to redirect or reload the page".

Happy112

User avatar
 
Posts: 420
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted October 20th, 2017, 2:56 am

Reflective wrote:Copy/paste about:preferences#advanced into the location bar and hit Enter. Click the General tab (usually opens there by default) and remove the checkmark from "Warn me when websites try to redirect or reload the page".


Unfortunately the Options/Preferences have changed as of FF56.
See this video that 'guigs' (Mozilla Adminstrator) made :

https://www.youtube.com/watch?v=gk39zpLWn7w
You can keep your diamonds - they're just shiny stones; love is the only precious thing and doesn't cost a dime.

Grumpus

User avatar
 
Posts: 11601
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted October 20th, 2017, 6:22 am

"Warn me when websites try to redirect or reload the page". is still there in 56 under "Block Pop-up Windows."
Shows in this system and in others on this machine and another.
Could also be Setting Sanity is still functioning and managed to maintain what's being removed in the GUI.

Happy112

User avatar
 
Posts: 420
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted October 20th, 2017, 6:44 am

Grumpus wrote:"Warn me when websites try to redirect or reload the page". is still there in 56 under "Block Pop-up Windows."


Hey Grumpy, please don't bite my head off, but it says : " Warn you when websites try to install add-ons " under 'Block pop-up windows' .....
You can keep your diamonds - they're just shiny stones; love is the only precious thing and doesn't cost a dime.

Reflective

User avatar
 
Posts: 2217
Joined: February 15th, 2007, 11:13 am

Post Posted October 20th, 2017, 8:38 am

Happy112 wrote:
Reflective wrote:Copy/paste about:preferences#advanced into the location bar and hit Enter. Click the General tab (usually opens there by default) and remove the checkmark from "Warn me when websites try to redirect or reload the page".


Unfortunately the Options/Preferences have changed as of FF56.
See this video that 'guigs' (Mozilla Adminstrator) made :

https://www.youtube.com/watch?v=gk39zpLWn7w

Nooooooooo......... I don't wanna be wasting time looking at videos: just give me the location and I'll make a note of it.

Happy112

User avatar
 
Posts: 420
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted October 20th, 2017, 9:01 am

Reflective wrote:Nooooooooo......... I don't wanna be wasting time looking at videos: just give me the location and I'll make a note of it.


How is learning something a waste of time ?

You want me to give you a link to what ? To 'Warn me when websites try to redirect or reload the page' ? It's not in Options/Preferences anymore - hence the video .....
But I'll give you this : you can now toggle that as a preference in about:config - type : 'accessibility.blockautofresh' (without the quotation marks) and set its value to either 'true' or 'false'.

Ah c'mon : watch that video - you won't regret it, promise.
You can keep your diamonds - they're just shiny stones; love is the only precious thing and doesn't cost a dime.

jglanvil
 
Posts: 16
Joined: August 27th, 2015, 2:35 pm

Post Posted October 20th, 2017, 9:58 am

How many minutes/seconds into the guigs video is the answer? Sadly, nothing suggested here so far has worked for me. jg

Happy112

User avatar
 
Posts: 420
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted October 20th, 2017, 10:17 am

jglanvil wrote:How many minutes/seconds into the guigs video is the answer? Sadly, nothing suggested here so far has worked for me. jg


Apparantly you haven't read my reply to Reflective :

It's not in Options/Preferences anymore : you'll have to toggle a preference in 'about:config'

This has also been mentioned by 'barbaz' ......
You can keep your diamonds - they're just shiny stones; love is the only precious thing and doesn't cost a dime.

jglanvil
 
Posts: 16
Joined: August 27th, 2015, 2:35 pm

Post Posted October 20th, 2017, 10:45 am

Toggling the blockautorefresh simply gives different redirect notices. Is this known to the community?

Is there a way to avoid any redirect notice at all other than using G Chrome?

Many thanks to all here who here are trying to assist.

jg

Happy112

User avatar
 
Posts: 420
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted October 20th, 2017, 11:08 am

@ jglanvil (and anybody who's interested) :

You can also (temporarily) toggle this preference in 'about:config' to restore the 'old' Options/Preferences :

'browser.preferences.useOldOrganization' (without the quotation marks) and set its value to 'true'.

This will give you time to get to know and get used to the 'new' Options/Preferences ......
You can keep your diamonds - they're just shiny stones; love is the only precious thing and doesn't cost a dime.

jglanvil
 
Posts: 16
Joined: August 27th, 2015, 2:35 pm

Post Posted October 20th, 2017, 12:10 pm

Thanks for trying. I just wanted a step-by-step solution without the lectures.

Firefox is a tool, not a graduate school course or an IQ test.

I'll just go with Google Chrome.

jg

therube

User avatar
 
Posts: 17822
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted October 20th, 2017, 1:39 pm

"Firefox prevented this page from automatically redirecting to another page?"

URL that generates that message?

I have spent much time looking on line and reading about fixes for this problem.

What suggestions have you already tried?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

8-bit

User avatar
 
Posts: 874
Joined: October 19th, 2007, 5:19 pm

Post Posted October 20th, 2017, 7:56 pm

Happy112 wrote:How is learning something a waste of time?

When a Mozilla administrator makes a video that is unprofessional, amateurish, and uninformative. Without mincing words here: the clarity of the information presented in that video sucks. PERIOD. I didn't need the info (I just went into prefs and simply set them), but checked it out because you linked to it.

BOTTOM LINE: Moz has consolidated the preferences into fewer categories with 99.9% of the original prefs there. It's quite simple.

jglanvil wrote:Toggling the blockautorefresh simply gives different redirect notices.

Can you give me a link to a site where this is true? I do not receive "different" redirect notices. I receive none. I'm giving you the benefit of the doubt, but I'd really like to have a link to see it for myself.

jglanvil wrote:Thanks for trying. I just wanted a step-by-step solution without the lectures. Firefox is a tool, not a graduate school course or an IQ test.

To the best of my knowledge (pending a link to a site that gives a "different" redirect notice), barbaz answered your question immediately.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot], LIMPET235 and 18 guests