MozillaZine

Adding sites to permissions dialog

User Help for Mozilla Firefox
Odin2
 
Posts: 337
Joined: March 10th, 2012, 8:08 pm

Post Posted October 31st, 2017, 7:10 am

This is probably a dumb question--but I can't see how to add a site to the permissions dialog. I use NoScript, and I thought NoScript might be the problem--but NoScript won't let me whitelist about:preferences.

kreemoweet
 
Posts: 714
Joined: December 30th, 2009, 11:25 pm

Post Posted October 31st, 2017, 8:48 am

There hasn't been an "about:permissions" dialog in Firefox since version 44. What other "permissions dialog" might you be talking about?
And the only way to have a site listed on about:permissions was to go to a webpage and adjust the permissions to something non-default.

Grumpus

User avatar
 
Posts: 11611
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted October 31st, 2017, 9:33 am

Type about:about in the nav bar and you can see what is available for about pages.
If you visit a site and you get a NoScript warning you have the option to allow or deny.
If you have inadvertently disallowed or labeled a site as untrusted there is an item in about:config which you can edit, adding or subtracting, watch syntax (spaces mostly, etc.)
noscript.untrusted
If you have a great number of untrusted items you can copy to a text editor,
make your edits easier to read and modify and paste back in noscript.untrusted
It's good for beacons and trackers which show up on sites as untrusted.

Odin2
 
Posts: 337
Joined: March 10th, 2012, 8:08 pm

Post Posted October 31st, 2017, 10:09 am

Thanks, both, for your responses, but I'm still at a loss.

1. The permissions dialog is at about:preferences#content, accessed by clicking the Choose button.

2. It seems I must have mistyped the URL in question, which is is actually about:preferences. (Sorry.) As I said, NoScript does not allow me to whitelist that site. If I try, the option to Allow is grayed out.

(Grumpus, much of what you say looks interesting, but I don't know how it applies to my problem.)

Grumpus

User avatar
 
Posts: 11611
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted October 31st, 2017, 12:44 pm

Are you referring to cached web content or Offline web content and user data
If the Offline Web Content there does not appear to be an "add" feature but it could need to be triggered when a site requests it.
Otherwise there's no other Content except for the cached web content which is just a bucket you empty.

Odin2
 
Posts: 337
Joined: March 10th, 2012, 8:08 pm

Post Posted October 31st, 2017, 12:54 pm

Grumpus, I'm simply trying to prevent notifications from a particular website or, possibly, my antivirus provider.

therube

User avatar
 
Posts: 17831
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted October 31st, 2017, 7:12 pm

NoScript won't let me whitelist about:preferences

No, NoScript won't allow you to block about:preferences.
about:preferences (& various other about: preferences, those that are grayed out) are [forced] whitelisted.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Gingerbread Man

User avatar
 
Posts: 7565
Joined: January 30th, 2007, 10:55 am

Post Posted November 1st, 2017, 1:18 am

Odin2 wrote:I can't see how to add a site to the permissions dialog.

Odin2 wrote:I'm simply trying to prevent notifications from a particular website

Which is it: do you want to allow or deny a website permission to display notifications?

In any case, websites that you haven't whitelisted will ask for permission via a doorhanger (a prompt that hangs off the icon on the left side of the address bar). If you accept, they then end up in the list under Options/Preferences → Privacy & Security → (Permissions) Choose. You can remove them from the whitelist there.
You can also click the icon on the left-side of the address bar; at the bottom of that doorhanger you can see if you've granted the site any special permissions and remove them by clicking the circled X.
Lastly, you can right-click a blank area of the website and choose View Page Info, then Permissions. There you can switch "Receive Notifications" to "Use default" (ask), Allow or Block.

:arrow: https://support.mozilla.org/kb/push-notifications-firefox

Odin2
 
Posts: 337
Joined: March 10th, 2012, 8:08 pm

Post Posted November 6th, 2017, 1:30 pm

Thanks, Gingerbread Man. For whatever reason I've just now seen your post.

My interest was primarily in blocking pop-ups from Epson. At the permissions dialog for Epson.com, I see that the [checked] default for pop-ups is Block, and the [checked] default for notifications is Always ask. So I don't know why I get frequent pop-ups from Epson nagging me to install software I don't want. Is there no way to stop these pop-ups?

Gingerbread Man

User avatar
 
Posts: 7565
Joined: January 30th, 2007, 10:55 am

Post Posted November 11th, 2017, 7:12 am

Can you post a link to the page where that happens, and maybe a screenshot (you can upload it to a site like imgur.com and post the link here)? I see no pop-ups on https://epson.com/usa. It's difficult to know if you're seeing a pop-up window that Firefox thinks is user-requested, an add-on installation prompt or something else.

Odin2
 
Posts: 337
Joined: March 10th, 2012, 8:08 pm

Post Posted November 11th, 2017, 11:21 am

Thanks again, Gingerbread Man.

I'm guessing it's not a Firefox issue after all, as the pop-ups aren't associated with a particular page. I probably should ask at the MS Community forum.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 10 guests