MozillaZine

[Ext] DblClicker & KillSpinners & FlashStopper & Add-on Tbb

Announce and Discuss the Latest Theme and Extension Releases.
streetwolf

User avatar
 
Posts: 2151
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted November 2nd, 2017, 4:21 am

yochaim wrote:ok thanks...
btw are you still using aps regularly (you've been fairly quiet lately...)? did you stumble on any other issues?


APS is working well for me. I've been busy getting together all the parts needed for a new PC build which I hope to begin building very soon.
Intel Core i7-8700K CPU @ 5.1GHz | Gigabyte Z370 AORUS Gaming 7 | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 64GB RAM @ 3.7GHz | EVGA GeForce GTX 1080 Ti FTW3 11GB | Dual ASUS PA249Q 24" LCDs | 2-512GB Samsung 960 PRO M.2 | 4TB WD Black | 2TB Seagate | Windows 10 Pro x64 | FIOS 1Gb

YaShum2
 
Posts: 9
Joined: September 27th, 2017, 9:55 pm

Post Posted November 8th, 2017, 11:05 pm

yochaim wrote:...
click the flashstopper toolbarbutton to open menu, then click edit script...
the script editor should open!
find the line from the post (you can use ctrl+f) and change the value as mentioned in the post.
click apply
...

Sorry that I did not write for a long time.
Yeah, it turned out to be much easier than I thought, "fs-blablabla" is an abbreviation of the plugin name, but it looked like a line in about:config xD
I understand this number of milliseconds before the activation of the plug-in after loading the page. If you specify too many, then the video will load, if too little, then the comments will not load. In general, I tried different parameters: 6000 - 30% of the cases load comments, 9000 - 80% of the cases the video loads, and there is a complete randomness between them))) Alas, it's easier to create another plugin that cuts from Youtube comments than to configure this brain-blowing Youtube.
I completely switched to CherryPlayer for a long time, but how annoying, CherryPlayer has its bugs and flaws, and the most annoying ones are: the inability to send a comment, the inability to adjust the volume with the mouse wheel, the inability to return to previous pages, and most importantly there is no way to tell the developer about bugs (just like Youtube) ](*,) . But this is the lesser of two evils, better I will watch the video quietly than to post comments (however, I will have 30% of the gifts given to you))).
Thank you for bothering with this plugin, it helps me a lot (and not only me)! =))
Last edited by YaShum2 on November 8th, 2017, 11:15 pm, edited 2 times in total.

YaShum2
 
Posts: 9
Joined: September 27th, 2017, 9:55 pm

Post Posted November 8th, 2017, 11:08 pm

Lol, well that I noticed, Google.translate began to swear (about Yutoub), otherwise I would be banned)))

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted November 9th, 2017, 3:33 am

hi YaShum[2],

you can still use the old youtube design (don't know for how long) that doesn't have the comments issue (works well with the default 1500 timeout).
in youtube from the 3 dot menu select the last option 'restore old youtube'...

if it helps you any

percysowner
 
Posts: 9
Joined: March 14th, 2015, 6:15 pm

Post Posted November 9th, 2017, 12:21 pm

I don't know what is going on, but suddenly, YouTube is autoplaying. It's not whitelisted, I have YouTube's autoplay turned off. I tried installing Flashblock Plus, and YouTube autoplays under that, so maybe they have changed something? I just thought you should know.

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted November 9th, 2017, 2:39 pm

thanks for the info,
but i didn't find any issues with youtube (please notice that only first video in tab will stop)
check that you don't have proactive blocking activated for youtube.
if that isn't the problem please try in new profile (be sure to restart ff after you install the add-on)

streetwolf

User avatar
 
Posts: 2151
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted November 9th, 2017, 3:24 pm

yochaim...

FYI...

Chrome Store Foxified add-on was updated to support webextensions. This is the add-on that let's you install Google Chrome extensions into Firefox. Also, it will optionally sign them too. I installed the Chrome version of APS and now it is also signed. Seems to work OK but I guess it's missing the stuff you added about comments.
Intel Core i7-8700K CPU @ 5.1GHz | Gigabyte Z370 AORUS Gaming 7 | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 64GB RAM @ 3.7GHz | EVGA GeForce GTX 1080 Ti FTW3 11GB | Dual ASUS PA249Q 24" LCDs | 2-512GB Samsung 960 PRO M.2 | 4TB WD Black | 2TB Seagate | Windows 10 Pro x64 | FIOS 1Gb

percysowner
 
Posts: 9
Joined: March 14th, 2015, 6:15 pm

Post Posted November 9th, 2017, 3:38 pm

The new profile took care of the problem. Thanks.

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted November 9th, 2017, 6:38 pm

hi streetwolf,

the most important diff is csp workaround (see viewtopic.php?p=14773627#p14773627) which means that aps doesn't work on sites with csp (ex. twitter...)
in youtube you get the control band and the video does buffer (slowly).

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted November 10th, 2017, 10:04 pm

hi streetwolf,

uploaded new version (v1.2.0.1) to the chrome store that includes (different) workaround for the csp issue in ff...
so this https://twitter.com/AC360 should stop.
the only difference left is the youtube handling but this could easily be fixed by loading the ff handler.js.

streetwolf

User avatar
 
Posts: 2151
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted November 11th, 2017, 6:45 am

I installed the latest v1.2.0.1 and during the signing process I got this warning on Mozilla's signing report:
-------------------------------------------
eval can be harmful.

Warning: Evaluation of strings as code can lead to security vulnerabilities and performance issues, even in the most innocuous of circumstances. Please avoid using `eval` and the `Function` constructor when at all possible.'

content/content.js line 133 column 32
----------------------------------------------

The add-on in Fx has the message above it about not being verified for Nightly. It's possible the warning message above caused this. It could also be CSF that caused this.
Intel Core i7-8700K CPU @ 5.1GHz | Gigabyte Z370 AORUS Gaming 7 | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 64GB RAM @ 3.7GHz | EVGA GeForce GTX 1080 Ti FTW3 11GB | Dual ASUS PA249Q 24" LCDs | 2-512GB Samsung 960 PRO M.2 | 4TB WD Black | 2TB Seagate | Windows 10 Pro x64 | FIOS 1Gb

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted November 11th, 2017, 7:38 am

that's the workaround for the csp issue, using window.eval to insert the handlers script into the page...
the evaluated string is internal to the add-on so no way to temper with it! i'll change it back to <script> element (like it works in chrome) when they'll fix the csp bug...

do you need the youtube fixup and does the twitter link stop for you?

i'm having problems installing with CSF. maybe it's not signed?

streetwolf

User avatar
 
Posts: 2151
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted November 11th, 2017, 9:59 am

I spoke with the developer of CSF and he told me how I can use CSF to sign the Fx version. You need to select any Chrome Extension then go into CSF's dashboard where there is a place where you can load an xpi file from your computer. I loaded the latest APS for Fx from your newversions zip file and now APS is signed. I still got the warning about the eval statement.

CSF is still a little buggy. A new release is coming out.

btw... YouTube and Twitter work fine for me.
Intel Core i7-8700K CPU @ 5.1GHz | Gigabyte Z370 AORUS Gaming 7 | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 64GB RAM @ 3.7GHz | EVGA GeForce GTX 1080 Ti FTW3 11GB | Dual ASUS PA249Q 24" LCDs | 2-512GB Samsung 960 PRO M.2 | 4TB WD Black | 2TB Seagate | Windows 10 Pro x64 | FIOS 1Gb

yochaim
 
Posts: 478
Joined: September 14th, 2009, 9:23 am

Post Posted November 11th, 2017, 1:35 pm

v1.2.0.1 is the same for chrome/ff (only the file ext is different...)

in youtube you get the control band & it does buffer slowly. if you want it to stop completely (no band / no buffering) let me know.

there is also something i'm curious about:
if you can check the devtools panel in the setting then when you open devtools in the aps tab and click the file button, do you get the select file dialog?

streetwolf

User avatar
 
Posts: 2151
Joined: August 21st, 2011, 8:07 am
Location: NJ (USA)

Post Posted November 11th, 2017, 3:40 pm

yochaim wrote:v1.2.0.1 is the same for chrome/ff (only the file ext is different...)

in youtube you get the control band & it does buffer slowly. if you want it to stop completely (no band / no buffering) let me know.

Yes I do

there is also something i'm curious about:
if you can check the devtools panel in the setting then when you open devtools in the aps tab and click the file button, do you get the select file dialog?

No select file dialog either
Intel Core i7-8700K CPU @ 5.1GHz | Gigabyte Z370 AORUS Gaming 7 | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 64GB RAM @ 3.7GHz | EVGA GeForce GTX 1080 Ti FTW3 11GB | Dual ASUS PA249Q 24" LCDs | 2-512GB Samsung 960 PRO M.2 | 4TB WD Black | 2TB Seagate | Windows 10 Pro x64 | FIOS 1Gb

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 2 guests