MozillaZine

Can't see or downlaod motherboard drivers from ASUS website

User Help for Mozilla Firefox
ghot

User avatar
 
Posts: 181
Joined: August 10th, 2007, 3:52 pm

Post Posted November 29th, 2017, 12:10 am

For some reason I don't see the motherboard drivers list, that I should be seeing. I only seem to have this problem on ASUS's website.

I try to go here: https://www.asus.com/us/Motherboards/PRIME-Z370-A/HelpDesk_Download/, choose an OS, then I used to see a list of motherboard driver downloads, now I see nothing.

I'm running Win 7 64 bit and Firefox 52.5.0 ESR.

I used to be able to see the driver download list at ASUS.

/e I asked other folks if they could see it...and they can.
We the willing, led by the unknowing, have been doing the impossible for the ungrateful. We have been doing so much, for so long, with so little, we are now qualified to do anything with nothing.

DanRaisch
Moderator

User avatar
 
Posts: 120594
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 29th, 2017, 5:03 am

Does the same thing occur if you launch the application in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode

Reflective

User avatar
 
Posts: 2283
Joined: February 15th, 2007, 11:13 am

Post Posted November 29th, 2017, 5:14 am

I tested the site on FF ESR 52.5 and as you can see from the screenshot, the site loads just fine. https://imgbox.com/tNLSFDq0

Grumpus

User avatar
 
Posts: 12040
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted November 29th, 2017, 7:24 am

Had no issues going around the entire site and searching with various blockers enabled.
The site does not drop a page however when going to a link or search page.
If you closed a preceding page it might be why a second page might not open.
No Login seemed necessary for basic stuff but you might need to create an account using your board specs.
I seem to remember having to do something like a registration process for the most recent for my board..

Brummelchen
 
Posts: 3894
Joined: March 19th, 2005, 10:51 am

Post Posted November 29th, 2017, 7:30 am

asus pages are either slow or critical to blocked scripts and popups.

ghot

User avatar
 
Posts: 181
Joined: August 10th, 2007, 3:52 pm

Post Posted November 29th, 2017, 3:40 pm

I know the site works fine. I said that in the OP.


About 3 weeks ago, I tried FF 57, didn't like it, and uninstalled it. I also removed all instances of Mozilla from my C: drive
Then I installed FF 52.5.0 ESR, and everything works fine...except one site, and only part of that site. Namely the drivers download page.

I do have an account there and even logged in and tried that. Something is blocking that one page. I can even go to the BIOS files and see all them.
But the drivers page won't show me the drivers and their download links.

I only use two extensions, namely NoScript and Classic Theme Restorer. NoScript is set to allow the whole page.




/e Same problem in safe mode. Entire rest of the site works.
We the willing, led by the unknowing, have been doing the impossible for the ungrateful. We have been doing so much, for so long, with so little, we are now qualified to do anything with nothing.

therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted November 29th, 2017, 8:33 pm

As a test, create a new, clean Profile & confirm that the site works.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

malliz
Folder@Home

User avatar
 
Posts: 43532
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted November 29th, 2017, 8:46 pm

Yep Noscript can be painful
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

ghot

User avatar
 
Posts: 181
Joined: August 10th, 2007, 3:52 pm

Post Posted November 29th, 2017, 9:15 pm

therube wrote:As a test, create a new, clean Profile & confirm that the site works.


I completely uninstalled FF 52.5.0 ESR and ALL it's associated files, then reinstalled it clean.

I'm beginning to think it may have been when I uninstalled FF 52.5.0 ESR, installed FF 57 tried it out...and then uninstalled it, completely, and reinstalled FF 52.5.0 ESR.

I never had the problem before I did that. Unfortunately, right before I did that, I also did some Win 7 security only updates.
I do have a Acronis backup from October 7th, before I did any of this. Maybe I'll try that tomorrow. :/



/e

malliz wrote:Yep Noscript can be painful


Yeah, I thought of that, but running in safe mode, I still had the problem. Just that one site. Lol
We the willing, led by the unknowing, have been doing the impossible for the ungrateful. We have been doing so much, for so long, with so little, we are now qualified to do anything with nothing.

therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted November 29th, 2017, 10:07 pm

Yesterday, I happened to have a similar issue on HP's website when I went to download drivers.

The site automatically detected my setup, & there were "OS" & "version" dialog boxes too, & while the dropdowns in those boxes worked, "selecting" them resulted in no action occurring, & I refreshed the page & tried again, & again. The same.

Then I opened a new window, & loaded the page, & it it worked. No idea why.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

ghot

User avatar
 
Posts: 181
Joined: August 10th, 2007, 3:52 pm

Post Posted December 8th, 2017, 4:09 am

I'm on FF 52.5.2 and I still can't get the driver page at ASUS's site to work. The whole rest of the site works fine.
I have the same problem in safe mode.

I tired both 32 and 64 bit versions and totally clean installs...no help. No problems on any other site.
We the willing, led by the unknowing, have been doing the impossible for the ungrateful. We have been doing so much, for so long, with so little, we are now qualified to do anything with nothing.

therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted December 12th, 2017, 11:05 am

uninstalled FF 52.5.0 ESR and ALL it's associated files

Did that include your Profile files?

Does IE work on that site for you?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

ghot

User avatar
 
Posts: 181
Joined: August 10th, 2007, 3:52 pm

Post Posted December 13th, 2017, 12:51 am

Yeah, all files associated with Firefox.

As for IE I don't use it and it is disabled. But everyone else, on FF, Chrome, IE etc, can access the site's driver list and downloads.
I can access the entire site, even the lists and downloads of all other motherboard related files and documents. It's just the motherboard drivers lists and files that I can't access. I choose the OS and the site does absolutely nothing. It doesn't freeze, it just does nothing.

The icon on the tab should turn into a revolving circle, this does not happen. With all other parts of the site, no issues at all.


Here is the link. I picked an older motherboard this time, just in case it was a modern CPU related issue...as I don't have a modern CPU.

https://www.asus.com/us/Motherboards/SABERTOOTH_990FX_R20/HelpDesk_Download/
We the willing, led by the unknowing, have been doing the impossible for the ungrateful. We have been doing so much, for so long, with so little, we are now qualified to do anything with nothing.

Lnwdz
 
Posts: 166
Joined: June 12th, 2012, 7:59 am

Post Posted December 13th, 2017, 8:58 am

It fails for me if tracking protection is enabled. Googletagmanager.com gets blocked, which somehow breaks the driver list.

therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted December 13th, 2017, 10:32 am

Good find.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 11 guests