MozillaZine

[Ext] DblClicker & KillSpinners & FlashStopper & Add-on Tbb

Announce and Discuss the Latest Theme and Extension Releases.
delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 3:11 pm

Why not keeping 2.5.1 & doing this
"open the editor and remove "use strict"; from the userscript (and apply) if this doesn't help try removing it from the script too..."

will i miss important functions ?

yochaim
 
Posts: 499
Joined: September 14th, 2009, 9:23 am

Post Posted December 8th, 2017, 3:20 pm

you can try it on v2.5.1 but (as explained before) there is no functionality difference except for being e10s & compatible with the latest changes in ff...

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 3:46 pm

?????

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 3:48 pm

2.4.7:

Fixed media autoplay blocking integration.
Fixed theme issues when used with specific add-ons.
Improved handling for html5 video.

2.4.8

Fixed issues with new youtube.

2.5.0

Improved handling for html5 video.

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 3:50 pm

if i read it well, i'm losing functionalities not using the latest..

yochaim
 
Posts: 499
Joined: September 14th, 2009, 9:23 am

Post Posted December 8th, 2017, 4:11 pm


delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 4:39 pm

Ok, i removed "use strict";

in the "script" section of the editor.

I hope i'm not losing functionality, cause you haven't put it there for nothing i guess.

i'll stay on the latest, no more error.

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 4:40 pm

I also hope that doesn't affect the main handler, otherwise, at next update, it might be overwritten

Elhem Enohpi
 
Posts: 35
Joined: March 19th, 2016, 8:49 am

Post Posted December 8th, 2017, 4:42 pm

@yochaim, I got bitten by an obscure bug! Everything's ok now...

In case you're curious, it turns out I'd had "disable everywhere" checked and didn't notice it, so I turned on "proactive blocking" for macworld.com instead, thinking that was the problem. And it turns out that's a bad idea, because it actually disables blocking for that site. And furthermore if you enable proactive blocking while "disable everywhere" is checked, then blocking will be disabled for that site no matter what else you do, until you restart Firefox.

1. Check "disable everywhere".
2. Go to https://www.macworld.com/article/204270 ... ideos.html
3. Video starts playing, pause it.
4. Check "enable proactive blocking for: macworld.com".
5. Immediately uncheck "enable proactive blocking for: macworld.com".
6. Uncheck "disable everywhere".
7. Reload page.
Results: video on macworld.com autoplays. It will continue to autoplay no matter what the settings are, until you restart Firefox.

As I said, it's all sorted now so no worries, thanks for your help!

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 4:48 pm

Nevertheless, i still can't see dailymotion videos, with or without ubo disabled on that page..

tested on:
http://www.dailymotion.com/video/x24fyhv

can you please check if it's not an issue with flashstopper & provide a script ?

ff44.0.2.

yochaim
 
Posts: 499
Joined: September 14th, 2009, 9:23 am

Post Posted December 8th, 2017, 5:42 pm

@Elhem Enohpi

the issue is that nsIStyleSheetService.loadAndRegisterSheet does not work dynamically.
since fs removes and adds the content.css when disabling/enabling (also editing the script or installing) it does not work until restarting ff.
i was still able to get it working again (in ff56 but not in 57) when closing all tabs then opening link in new tab from about:newtab.

@delicacy

check what player you get (and if it works without fs)...

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 5:54 pm

remind me how to find out the player ?

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 6:28 pm

with flashplayer disabled, i get this from the video frame in dailymotion:

"Blop!
Please update your browser or try a different one"

They have nothing better to do than injecting that form of checking through
the video frame & minding about which browser i should use or build.

& with flashstopper, ctrl shift right click doesn't show any html5 player

again, i only got the audio of it to play, no image:
http://www.dailymotion.com/video/x5b0krg

& for many other videos, no sound, no video on dailymotion

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 6:49 pm

uninstalling flashplayer doesnt work either

delicacy1
 
Posts: 304
Joined: September 28th, 2016, 11:25 am

Post Posted December 8th, 2017, 7:11 pm

I never ask you to make a test for nothing.. but when you push me to do the tests myself,
this is what happens & i can only blame myself for having done it..

Since flashstopper was still active even disabled in past versions, i had to move my flashstopper folder to the desktop
before uninstalling flashstopper for that test, & putting back that folder, or probably because i updated it at one time,
i've lost all your script-fixes you gave me in the past.

clap clap delicacy.. keep testing delicacy, there's always a super tech technique
to get your user data deleted at a moment or another..

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest