MozillaZine

Bing keeps setting itself as default search

User Help for Mozilla Firefox
jaybiam
 
Posts: 11
Joined: September 22nd, 2014, 1:02 pm

Post Posted December 10th, 2017, 6:27 pm

Google has been my default search since before I can remember, all the sudden every time I start up Firefox, Bing is set as default. I remove Bing from search settings, but next time I restart up Firefox, Bing has returned as default search. I use Windows 10 Home Version 1709, I was thinking it was an update to Windows but according to an agent it is not. I have restarted Firefox in Safe Mode with all addons inactive, this did not work. I have not installed any new software on my desktop, and I use just a standard AntiVirus, not a security suite, so browser protection is not an option on it. I do not know what to do, I cannot locate any thing on Google other then a Yahoo Search issue years back. ](*,)

Image
This is how it appears every time I start up Firefox, I remove Bing but upon next start up this is what it looks like again

TheVisitor
 
Posts: 4489
Joined: May 13th, 2012, 10:43 am

Post Posted December 10th, 2017, 6:35 pm

What addons do you have - do you have any Bing related addons ?

DanRaisch
Moderator

User avatar
 
Posts: 118394
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 10th, 2017, 8:37 pm


8-bit

User avatar
 
Posts: 908
Joined: October 19th, 2007, 5:19 pm

Post Posted December 11th, 2017, 8:17 am

FWIW: Are you running the InvisibleHand extension? - known to do this - check the settings very carefully and you can remedy this. Although, you may not be running this at all.

Also, I suggest staying away from ibb.co for image hosting as it is known for serving up some delicious malware.
The desire that something be true, rather than the desire for truth itself, is why pseudoscience is pop-culture.

jaybiam
 
Posts: 11
Joined: September 22nd, 2014, 1:02 pm

Post Posted December 11th, 2017, 2:30 pm

I have fully scanned my system, it is clean, and I've tried with Addon's disabled (Safemode) and still set Bing as my default. I have zero Bing related addons.

DanRaisch
Moderator

User avatar
 
Posts: 118394
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 11th, 2017, 2:38 pm

If no improvement using Safe Mode, do you have the same problem if you create a new profile and test it with no extensions or non-default themes installed?
http://kb.mozillazine.org/Profile_Manager
and
http://kb.mozillazine.org/Creating_a_ne ... on_Windows

jaybiam
 
Posts: 11
Joined: September 22nd, 2014, 1:02 pm

Post Posted December 11th, 2017, 3:07 pm

DanRaisch wrote:If no improvement using Safe Mode, do you have the same problem if you create a new profile and test it with no extensions or non-default themes installed?
http://kb.mozillazine.org/Profile_Manager
and
http://kb.mozillazine.org/Creating_a_ne ... on_Windows


I will check this option out..

jaybiam
 
Posts: 11
Joined: September 22nd, 2014, 1:02 pm

Post Posted December 12th, 2017, 12:38 am

ok, created a new profile, it is still doing it.

TheVisitor
 
Posts: 4489
Joined: May 13th, 2012, 10:43 am

Post Posted December 12th, 2017, 3:55 am

Open Win10 Settings - open Apps - are there any Bing apps listed there ?

Reflective

User avatar
 
Posts: 2280
Joined: February 15th, 2007, 11:13 am

Post Posted December 12th, 2017, 4:47 am

Copy/paste into the location bar and hit Enter: about:config?filter=browser.search.defaultenginename (If you see a warning agree that you'll be careful so you can proceed further).

Right click the setting and click Modify. Delete Bing and type Google.

Repeat for about:config?filter=browser.search.defaultenginename.US which should be visible immediately underneath the first one. This is the current setting on my system for that one:

Code: Select all
data:text/plain,browser.search.defaultenginename.US=DuckDuckGo

On your machine you should be able to see Bing instead of DuckDuckGo which I have as my default search engine, so just delete that and add Google to the end of the string.

Close about: config and then determine if it resolves the problem.

Reflective

User avatar
 
Posts: 2280
Joined: February 15th, 2007, 11:13 am

Post Posted December 12th, 2017, 10:22 am


jaybiam
 
Posts: 11
Joined: September 22nd, 2014, 1:02 pm

Post Posted December 13th, 2017, 3:34 am

TheVisitor wrote:Open Win10 Settings - open Apps - are there any Bing apps listed there ?


Nothing Bing related no

jaybiam
 
Posts: 11
Joined: September 22nd, 2014, 1:02 pm

Post Posted December 13th, 2017, 3:41 am

Reflective wrote:Copy/paste into the location bar and hit Enter: about:config?filter=browser.search.defaultenginename (If you see a warning agree that you'll be careful so you can proceed further).

Right click the setting and click Modify. Delete Bing and type Google.

Repeat for about:config?filter=browser.search.defaultenginename.US which should be visible immediately underneath the first one. This is the current setting on my system for that one:

Code: Select all
data:text/plain,browser.search.defaultenginename.US=DuckDuckGo

On your machine you should be able to see Bing instead of DuckDuckGo which I have as my default search engine, so just delete that and add Google to the end of the string.

Close about: config and then determine if it resolves the problem.


Code: Select all
browser.search.defaultenginename.US;data:text/plain,browser.search.defaultenginename.US=Google
.. and that did not resolve my issue. upon restart Bing was still set as my default search once again.

LIMPET235
Moderator

User avatar
 
Posts: 37874
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted December 13th, 2017, 3:47 am

If all else fails, maybe try the 'Horse's Mouth" method?
See if anything here helps out...
> https://www.tenforums.com/gtsearch.php? ... x=0&sa.y=0
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-56.0.1-57.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. (Always choose the "Custom" Install.)

therube

User avatar
 
Posts: 18186
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted December 13th, 2017, 11:19 am

Do you have a user.js file in your Profile folder?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Support


Who is online

Users browsing this forum: allande, Bing [Bot], Flashlight, Google [Bot], ZekeBlue and 8 guests