MozillaZine

Firefox 57.0.2 (64) on Windows 7

User Help for Mozilla Firefox
Briar2345
 
Posts: 7
Joined: December 20th, 2017, 9:43 am

Post Posted December 20th, 2017, 9:55 am

Good Evening,

This new Firefox hasn't gone well with me.

At first launch it starts several instances but does not show a GUI. I have to strangle these in Task Manager and start Firefox again.

There appears to be no way to close the last tab without closing Firefox (or opening a spare tab, or leaving the previous page up, which is wasteful to say the least) It also means that if I close Firefox I then have to sign in to Last Pass when running it again !!

Any way round these anomalies ?

Regards

Briar

therube

User avatar
 
Posts: 18567
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted December 20th, 2017, 10:57 am

Were you using any version of FF prior?

See if you can start FF in Safe Mode.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

dfoulkes

User avatar
 
Posts: 22243
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted December 20th, 2017, 11:51 am

Briar2345 wrote:Good Evening,

There appears to be no way to close the last tab without closing Firefox (or opening a spare tab, or leaving the previous page up, which is wasteful to say the least) It also means that if I close Firefox I then have to sign in to Last Pass when running it again !!

Any way round these anomalies ?

Regards

Briar


I'm not on installed version 57 yet but changing this setting in about:config works for my portable version of 57... also, same setting in all my installed version...
So, type about:config in your location bar and enter...
browser.tabs.closeWindowWithLastTab

...double click on that record to change its value to False. That should do it....and I don't think that you need to restart Firefox for the change...try it.
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

LIMPET235
Moderator

User avatar
 
Posts: 38227
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted December 21st, 2017, 2:30 am

The above "pref" that DF posted ^, works fine in v57.

Merry Christmas.
Image
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. (Always choose the "Custom" Install.)

Jeemag

User avatar
 
Posts: 72
Joined: November 28th, 2013, 9:46 am
Location: Englandshire

Post Posted December 22nd, 2017, 3:59 am

therube wrote:Were you using any version of FF prior?


Hello & Thanks.

Yes, I held on to my dear extensions as long as I could ...

I have Pale Moon installed also but not running - may be part of the problem ?

See if you can start FF in Safe Mode.


I can do, but yesterday and today it started normally. I'll do that if the issue persists.

Regards,

Briar

Jeemag

User avatar
 
Posts: 72
Joined: November 28th, 2013, 9:46 am
Location: Englandshire

Post Posted December 22nd, 2017, 4:15 am

dfoulkes wrote:
Briar2345 wrote:Good Evening,

There appears to be no way to close the last tab without closing Firefox (or opening a spare tab, or leaving the previous page up, which is wasteful to say the least) It also means that if I close Firefox I then have to sign in to Last Pass when running it again !!

Any way round these anomalies ?

Regards

Briar


I'm not on installed version 57 yet but changing this setting in about:config works for my portable version of 57... also, same setting in all my installed version...
So, type about:config in your location bar and enter...
browser.tabs.closeWindowWithLastTab

...double click on that record to change its value to False. That should do it....and I don't think that you need to restart Firefox for the change...try it.


Yes! That works. Many thanks.

Regards,

Briar

dfoulkes

User avatar
 
Posts: 22243
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted December 22nd, 2017, 8:45 am

Jeemag wrote: Yes! That works. Many thanks.

Regards,

Briar

You're Welcome! :D
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

pepegot1
 
Posts: 318
Joined: December 23rd, 2008, 11:43 am

Post Posted December 22nd, 2017, 8:57 am

You have to dig to get it to work but, it is worth it. I used css and configured it close to my pre 57 version of Firefox. The speed increase is without question - fast!! This knowledgeable forum is a great source of help. Thanks to all those that help!!

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 10 guests