MozillaZine

Cannot play Video's from facebook and Twitter

User Help for Mozilla Firefox
marcenada
 
Posts: 3
Joined: December 31st, 2017, 12:27 am

Post Posted January 1st, 2018, 12:25 am

Hoi there, at first a very happy newjear.
At second i like to say sorry voor my poor English but i try to do my best to ask my question.
Why cant i play little video's from the internet , these are put on via facebook and twitter on the internet
Do i need another plug-in and so yes where can i find the plug-in.

James
Moderator

User avatar
 
Posts: 27260
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted January 1st, 2018, 1:40 am

It appears you are in the Netherlands so you may likely have the N edition of Windows 7.
https://support.microsoft.com/en-us/help/11529/what-is-a-windows-7-n-edition

The videos on Facebook and Twitter is using the HTML5 player in Firefox and not the Flash Plugin from Adobe.
https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows

You may not have the Media Feature Pack installed for the needed codecs so the HTML5 player may not work on some videos.

You can test at https://www.youtube.com/html5/ as all checks marks should ideally be blue and no reds.

marcenada
 
Posts: 3
Joined: December 31st, 2017, 12:27 am

Post Posted January 1st, 2018, 10:46 am

Hoi James
thanx for the answer but it is for me not the solution
I did the test and everything is blue and nothing is red.
I tried to download the codecs but they are already installed on my computer.
I hope someone has another solution for this problem

dfoulkes

User avatar
 
Posts: 22215
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted January 2nd, 2018, 8:32 am

Since you ended up with 'everything' in blue...then the normal thing to try next is to restart Firefox in safe-mode. Maybe an extension (or other stuff) is causing the issue. Please post back here with your results. Visit those links while in safe-mode....

Try running Firefox in safe-mode... NOTE: This is a testing procedure only ... NOT for normal browsing.
-- On the menu bar, click the Help menu and select Restart with Add-ons Disabled....
Firefox will start up with the Firefox Safe Mode dialog. Click continue in Safe Mode and don't check any items.

Note: You can also start Firefox in Safe Mode by holding down the shift key while Single/Double clicking on the icon.
* (option key while starting Firefox on Mac).

-----------------------------------------------------------------------------------------
>What safe-mode does ..... Safe Mode temporarily affects the following:
* All extensions are disabled. --- * The userChrome.css and userContent.css files are ignored.
* The default theme is used, without a persona. --- * The default toolbar layout is used.
* The Just-in-time (JIT) JavaScript compiler is disabled. --- * Hardware acceleration is disabled.

-- Safe Mode has no effect on the following --
* The status of plugins is not affected.
* Custom preferences are not affected.

This is the link to the main KB article for Safe-Mode ... but, use the above info 1st...
Safe Mode - MozillaZine Knowledge Base
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

therube

User avatar
 
Posts: 18479
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 2nd, 2018, 10:17 am

these are put on via facebook and twitter on the internet

URLs?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

dickvl

User avatar
 
Posts: 52362
Joined: July 18th, 2005, 3:25 am

Post Posted January 2nd, 2018, 11:31 am

Twitter videos embedded on other websites may not work due to CSP violation errors.
The Web Console will show a security error message in such a case.
You check if there is a link to open the video on the Twitter website.

Right-click the media player to check the video link in "View Page Info to see if this is about content hosted on Twitter.
I don't know if this is the same for Facebook.

If this is about CSP (Content-Security-Policy) then a possible workaround is to disable CSP temporarily when you need to bypass this policy restriction by toggling a pref on the about:config page.
security.csp.enable = false
CSP is a security feature and you should re-enable CSP once you are done with the website.

https://developer.mozilla.org/Security/CSP

marcenada
 
Posts: 3
Joined: December 31st, 2017, 12:27 am

Post Posted January 3rd, 2018, 10:43 pm

Thanxxxxxxxxx
The solution was to go to the config page and set security.csp.enable from true to false
Thanx everybody for the help

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 10 guests