MozillaZine

persistent web site domain requests (via Little Snitch)

User Help for Mozilla Firefox
machi1x
 
Posts: 12
Joined: March 9th, 2013, 2:39 pm

Post Posted January 2nd, 2018, 3:31 pm

I have Little Snitch active for all internet traffic on my laptop. Since installing Firefox v57 a great number of web sites I've visited in the past (a seemingly unending list) request advance permission to make contact with Firefox or vice versa every time I re-start the browser! That's hundreds of LS action requests each time I load Firefox. The only way I could stop this was to create a permanent rule to deny actions for every one of those sites, one after the other, which took close to an hour. Really.

Now if I want to re-visit one of those sites I have to go into LS, search for the domain name and delete the current rule for the site. Then re-add the site before closing Firefox. Insane!

Please, someone - tell me how to stop Firefox from 'pre-checking' these sites (which I assume are being checked because they are in my 'History'). It's a ridiculous 'feature'.

- thanks

Reflective

User avatar
 
Posts: 2283
Joined: February 15th, 2007, 11:13 am

Post Posted January 3rd, 2018, 12:04 pm

It's not Firefox which is causing that behaviour, but rather your Little Snitch app. They even tell you they're doing it. On their site it reads as follows:

Code: Select all
As soon as you’re connected to the Internet, applications can potentially send whatever they want to wherever they want. Most often they do this to your benefit. But sometimes, like in case of tracking software, trojans or other malware, they don’t.

But you don’t notice anything, because all of this happens invisibly under the hood.

So that last sentence is saying that you don't normally see these connection attempts. But then, there's this titbit:

Code: Select all
Little Snitch makes these Internet connections visible and puts you back in control!

It sounds to me like an app for the paranoid.

RobertJ
Moderator

User avatar
 
Posts: 10714
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted January 3rd, 2018, 1:10 pm

Reflective wrote:It sounds to me like an app for the paranoid.

It is a simple outbound firewall that is for Mac.

machi1x wrote:I have Little Snitch active for all internet traffic on my laptop. Since installing Firefox v57 a great number of web sites I've visited in the past (a seemingly unending list) request advance permission to make contact with Firefox

That makes no sense. Sites do not "contact" FF unless there is a HTML request from FF like going to a bookmark or clicking on a link.

The Little Snitch configuration for FF is trivial.

Allow outgoing TCP connections to port 80 (http)
Allow outgoing TCP connections to port 443 (https)

When you launch FF there should be no requests unless you have turned on FF data collection and, at most that will generate one or two requests.

.
FF 64.0- FF 64b13 - FF 65a - TB 60.3.1 - Mac OSX 10.13.6
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2018

machi1x
 
Posts: 12
Joined: March 9th, 2013, 2:39 pm

Post Posted January 3rd, 2018, 1:20 pm

Thanks to Mod RobertJ for your response. Sounds like I need to speak with LS for an explanation.

- best

dickvl

User avatar
 
Posts: 52442
Joined: July 18th, 2005, 3:25 am

Post Posted January 3rd, 2018, 4:08 pm


Gingerbread Man

User avatar
 
Posts: 7742
Joined: January 30th, 2007, 10:55 am

Post Posted January 3rd, 2018, 5:56 pm

machi1x wrote:Since installing Firefox v57 a great number of web sites I've visited in the past (a seemingly unending list) request advance permission to make contact with Firefox or vice versa every time I re-start the browser!

Check if the problem occurs when you start Firefox in Safe Mode. If it doesn't, one of your add-ons is to blame.

If it does, it might be the New Tab page. Test the following.
  1. Into the location bar, enter
    Code: Select all
    about:config?filter=newtab*enabled
  2. Press the big button to bypass the warning.
  3. In the search results, double-click browser.newtabpage.activity-stream.enabled and browser.newtabpage.enabled to set them to false.
  4. Restart Firefox and check if the problem still occurs.
RobertJ wrote:The Little Snitch configuration for FF is trivial.

Allow outgoing TCP connections to port 80 (http)
Allow outgoing TCP connections to port 443 (https)

  • TCP out 21 if you use FTP
  • TCP out 8080 and 8081 if you use a proxy
  • A very small number of sites use non-standard ports like 81-83, 182, etc.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 14 guests