MozillaZine

Accept invites into Google Calendar

For discussing the Mozilla Calendar, Sunbird and Lightning projects.
wms1yter5
 
Posts: 8
Joined: January 16th, 2018, 5:13 pm

Post Posted January 16th, 2018, 5:18 pm

Hi, when I accept an invite, it always goes into my home calendar, on the local machine. I'd like them to go into my Google calendar, which is synced nicely with Lightning and shows up fine.

Or even be able to move an invite that went into my home calendar to the google calendar.

Any suggestions on how to do this?

WaltS48

User avatar
 
Posts: 3915
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted January 17th, 2018, 7:42 am

Is the Home calendar or the Google calendar selected in the Calendar List?
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

wms1yter5
 
Posts: 8
Joined: January 16th, 2018, 5:13 pm

Post Posted January 17th, 2018, 5:03 pm

Both are selected. If I only have the Google calendar selected, will that be the default calendar that invites get added to?

WaltS48

User avatar
 
Posts: 3915
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted January 18th, 2018, 8:39 am

wms1yter5 wrote:Both are selected. If I only have the Google calendar selected, will that be the default calendar that invites get added to?


How did you select both? I can only have one at a time highlighted, even with all of them enabled (Check boxes checked).

Highlight the Google calendar and see what happens.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

wms1yter5
 
Posts: 8
Joined: January 16th, 2018, 5:13 pm

Post Posted January 18th, 2018, 11:47 am

I guess I probably misunderstand "select". I have both checked in the list on the left. The appointments for Google are blue in the calendar, Home in a light green.

When an appointment comes in, there is an accept button, but it does not give me a choice of which calendar to accept it into. So I click the button, and it goes into the Home calendar by default.

Does this make sense? Any advice appreciated.

WaltS48

User avatar
 
Posts: 3915
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted January 19th, 2018, 8:44 am

So you have both calendars enabled.

Which one has the highlight bar across it?

Which calendar is selected when you create a new event?
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

wms1yter5
 
Posts: 8
Joined: January 16th, 2018, 5:13 pm

Post Posted January 19th, 2018, 11:10 am

I'm not sure what the "highlight bar" is? Where can I find that?

The listing in the panel on the left is Google first, then Contacts (not sure what that has to do with the calendar, but anyway), and then Home. There does not seem to be any highlight bars as far as I can tell.

When I create an event, the Google calendar is selected. I can click on the Calendar and change it to Home, but of course never do that.

wms1yter5
 
Posts: 8
Joined: January 16th, 2018, 5:13 pm

Post Posted January 23rd, 2018, 1:08 pm

Just to clarify, when I create a meeting directly in Lightning, Google is the default calendar. However, when an invite comes in by email, there don't appear to be any choices, and Accept put it in the Home calendar, so only accessible on my local computer.

WaltS48

User avatar
 
Posts: 3915
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted January 24th, 2018, 7:58 am

wms1yter5 wrote:Just to clarify, when I create a meeting directly in Lightning, Google is the default calendar. However, when an invite comes in by email, there don't appear to be any choices, and Accept put it in the Home calendar, so only accessible on my local computer.


Thanks! That's what I wanted to know.

I don't get any invitations by email, so I was wondering if the calendar selection was the problem. That doesn't seem to be the case.

I would just try to move it to the Google calendar.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

wms1yter5
 
Posts: 8
Joined: January 16th, 2018, 5:13 pm

Post Posted January 24th, 2018, 12:19 pm

Thanks for the reply. I'm not sure how to move invitations or appointments between calendars. If I could do that, all would be solved! Any hints?

mgagnonlv
 
Posts: 737
Joined: February 12th, 2005, 8:33 pm

Post Posted January 24th, 2018, 8:14 pm

@ wms1yter5

I think there is an inherent limitation of either Google Calendar or the Provider for Google Agenda extension that might play with it.

For each local calendar as well as the main Google Calendar attached with each Google account and many WebCal calendars, there is a default email attached to them. That email was set when you created each calendar in Lightning and can be seen by right-clicking on each Calendar and checking for Properties.

Note that the main calendar of Google account, say "me@gmail.com" can be linked in Lightning to email address "thatsme@mydomain.com" if you want to.

So if you have :
– local calendar associated with email1@user.com
– main Google Calendar of account "me@gmail.com" associated with email2@domain.com
– main Google Calendar of account "thatothermail@gmail.com" associated with thatothermail@gmail.com
– WebDav calendar of your office account associated with mymail@work.com
etc.

Then when you receive an invitation at "email@user.com", it will automatically be added to the local calendar, and if you receive an invitation at "email@domain.com" it will automatically be added to the main Google Calendar of account "me@gmail.com".

So if you have only one calendar affected to any of your emails, then the process is simple: it's clear which calendar will receive an invitation. But if you have more than one writable calendar affected to a given email account, then I *think* the appointment is added to the first calendar you have created in Lightning.

The latter part, however, I'm not totally sure because I only have one series of calendars attached to my work email address and the server has its own set of priorities too.

Solution
So in a nutshell, if you go to your local calendar and define its associated email address to "none", then the only (or first) calendar associated with your email address will be your Google calendar, and from now on your invites will be added to your Google calendar.
Michel Gagnon
Montréal (Québec, Canada)

wms1yter5
 
Posts: 8
Joined: January 16th, 2018, 5:13 pm

Post Posted February 2nd, 2018, 3:21 pm

Great stuff Michel. I have set my local calendar email address to "None" by right-clicking the calendar and selecting Properties.

I set my Google calendar address to my usual address that invitations come in on, by right-clicking the calendar and selecting properties.

I sent myself a calendar invite, accepted it, and it went into my Google calendar!

This will save me a lot of problems. Thanks very much.

mgagnonlv
 
Posts: 737
Joined: February 12th, 2005, 8:33 pm

Post Posted February 3rd, 2018, 12:09 pm

Glad it worked as expected.
Michel Gagnon
Montréal (Québec, Canada)

jenda__
New Member
 
Posts: 1
Joined: May 28th, 2019, 5:04 am

Post Posted May 28th, 2019, 5:28 am

I have quite similar problem. But I can't associate Google Calendar with any e-mail.

My work mail is work@example.org and I download messages from it using POP3. I have google account with calendar registered as work@example.org (not @gmail.com) and added it to lightning using Google calendar provider.
I can create new local calendar and associate it to mail@example.org and in accepts invites just fine.
I can go to properties of this calendar and change "E-mail" dropdown to None. Or even delete it. I can't save invites then.
If I add new calendar On the network - Google calendar - work@example.org - check "My calendar" or "work@example.org", or whatever is there. I can see calendar from Google in Lightning but I can't save any invites. And if I click on properties of this calendar, E-mail dropdown is not there! There's Location (with googleapi://work@example.org/...) and after that there is Refresh calendar. But no E-mail...

I have also added my personal@gmail.com to Lightning and E-mail dropdown is missing there too (I don't need this functionality for personal, it's just to say it doesn't work with different account too).

Thunderbird 60.7.0 32-bit, Lightning 6.2.7, Google calendar provider 4.4.2

wms1yter5
 
Posts: 8
Joined: January 16th, 2018, 5:13 pm

Post Posted May 28th, 2019, 7:23 am

Hi Jenda, I'm not sure what your end goal here is, or if I can help. But fwiw, here is what I know.

My primary email address is at a domain I have used for a long time, not a Google gmail address. However, I wanted to save all calendar invites to a Google calendar, so that they would be available everywhere. And if my local computer or phone was lost or broken, I would not lose that data.

1. So I created a gmail email address, just for this purpose. Then I connected that calendar to Thunderbird, so it is available there, and added it on my phone so it is available there. I only use this gmail address to establish a Google calendar for this cloud availability purpose. (And to establish a Google address book, for the same reason, so my contacts can be connected to Thunderbird and my phone and be available everywhere).

2. I don't actually use that gmail email address for email, however have it setup to forward any email to my usual non-gmail address, so that when I create a calendar invite, in Thunderbird or anywhere else, and someone accepts it or replies to it, their reply to the gmail address will be forwarded to my non-gmail address. This forwarding must be setup from the settings for your gmail address from a Gmail.com web page.

3. Then I added that Google calendar to Thunderbird. There are explanations on the web on how to do this. In short, when you right click the calendar and select properties, you set the location to "googleapi://address@gmail.com/?calendar=address%40gmail.com" where "address" is your gmail address.

4. In the "Email" dropdown under properties for that calendar, I then selected my usual email address, not the gmail address, but the one Thunderbird is using. (Fwiw, this email address is at 1and1.com and I connect to it using imap, not pop3 as you do, but don't believe this would make any difference.)

5. Then for the "Home" calendar, the builtin one for Thunderbird, in properties I set the email address to "None".

Now all invites to my usual non-gmail address when they are received in Thunderbird automatically go into my Google calendar. And so are visible everywhere I have connected to that Calendar.

(On my phone, I have connected to this special Google account to sync my calendar and contacts there. However, I use K9mail on my phone to access my usual non-gmail email.)

Interestingly, on Thunderbird both the Google calendar and Home calendar have the "Switch this calendar on" checkbox checked under properties, however in the Thunderbird main calendar pane where the calendars are listed on the left, only the Google calendar checkbox is checked, and the Home calendar is unchecked. It works.

Hope this helps.

Cheers,
Bill

Return to Calendar


Who is online

Users browsing this forum: No registered users and 0 guests