MozillaZine

What Version Should I Use of Thunderbird; Lightning; Extens

User Help for Mozilla Thunderbird
FuturePerfect
 
Posts: 2
Joined: September 21st, 2004, 10:08 am

Post Posted February 11th, 2019, 1:36 am

What Version Should I Use of Thunderbird; Lightning; Extensions?

I haven’t updated the above programs in 4 years, so I need your help:

Below are existing program versions installed on my OLD PC:

-Thunderbird [TB] 24.8.0...........-Lightning 2.6.6
-AddressBookTab 1.5 Extension....-Rise of the Tools 1.0.1.0 Extension
-BirdieSync Extension (sync Address Book & Calendar to Android phone)

**What program version do you recommend I install on my NEW PC,
using 3 Notes and 4 Criteria for them, listed in priority order below:

NOTE 1 Don’t consider Mail or Tasks, since I don’t use these sub-apps

NOTE 2 Don’t consider security updates, since TB on my PC is isolated

NOTE 3 Choose among TB versions 24.x, 31.x, 38.x, 45.x, 52.x, 60.x
(relatively recent releases; versions supported by BirdieSync Extension)

CRITERIA:

1. Your experience with these versions operation & other capabilities

2. Ease in migrating current Thunderbird/Lightning databases [DB]?
[ideally, migration = copy current profile to new PC,
and new TB version auto migrates existing TB version 24 DB;
--in past, install TB vers x for part DB migrate; then vers y to finish--ugh]

3. Tabs in main interface for TB Address Book and Lightning Calendar?
[included in later TB versions, but which ones in NOTE 3 ????;
need to know this because AddressBookTab not avail above TB 28]

4. Enhancement I’ve wanted in Address Book, if it’s available--longer
"Notes" scrolling window in "Other" Address Book tab--like older TB

If you think I should stay on TB 24, that's fine, just let me know.

Thanks for any assistance you can provide.

tanstaafl
Moderator

User avatar
 
Posts: 45402
Joined: July 30th, 2003, 5:06 pm

Post Posted February 11th, 2019, 12:40 pm

I suggest you consider Thunderbird 52.9.1. Its the last release before version 60, which starts to break many add-ons. You'd use version 5.4 of Lightning with it. You'll get more features, bug fixes and a better selection of add-ons. Its also recent enough (July 10, 2018) getting support is not a problem. If you don't care about security updates its not clear to me whether its worth the hassle of updating.

I suggest you create a new profile using the profile manager, copy the contents of your old profile over it, install TB 52.9.1 in a separate directory (custom setup), and try using TB 52.9.1 with the new profile. If you don't like it delete the new profile using the profile manager and uninstall TB 52.9.1.

https://addons.thunderbird.net/en-US/th ... ab/?src=ss (supports 45.0 - 61.*)
https://addons.thunderbird.net/en-US/th ... src=search (supports 45.0 - 60.*)
https://freeshell.de/~kaosmos/morecols-en.html (MoreFunctionsForAddressBook)

http://kb.mozillazine.org/Go_back_to_an ... hunderbird
https://addons.thunderbird.net/en-US/th ... /versions/

FuturePerfect
 
Posts: 2
Joined: September 21st, 2004, 10:08 am

Post Posted February 16th, 2019, 1:11 am

To tanstaafl: Thank you for completely answering my questions in a logical and succinct post.

It’s great to hear from someone who has as much experience with Thunderbird as you have.

Thus I’m in the process of installing Thunderbird 52.9.1 and Lightning 5.4.

Thanks also for alerting me to the profile manager, which I didn’t know about. I also didn’t know about installing TB 52.9.1 via custom setup. Easy copying of my TB profile along with easy uninstalling of 52.9.1 lets me easily evaluate it on my test system first.

Finally, thanks for links to the versions of Thunderbird, Lightning, and Add-ons I’ll be using.

tanstaafl
Moderator

User avatar
 
Posts: 45402
Joined: July 30th, 2003, 5:06 pm

Post Posted February 16th, 2019, 7:17 am

You're welcome.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 5 guests