MozillaZine

WG9 Seamonkey 2.49.5 unofficial

User Help for Seamonkey and Mozilla Suite
ndebord

User avatar
 
Posts: 781
Joined: December 7th, 2002, 9:53 am

Post Posted April 8th, 2019, 5:51 pm

OK, I moved on from 2.94.4 some time ago and went with WG9's unofficial version. it has worked well for some time now, but recently, it is failing with multiple financial sites. I can log in to some of them, but can't do anything there, most options are greyed out. I tried his 2.53 version which can login, however, some (not all) of the extensions that worked with 2.49.5 no longer work with 2.53. I can work around that, but think it is time to figure out what to do, going down the road.

I do not like Firefox, nor the newer iterations of Thunderbird, so am invested in having a SeaMonkey that can handle the web, and in particular, financial sites.

Thanks for listening.
-N- Quis custodiet ipsos custodes
SeaMonkey 2.49.5, Dell D420, Windows 7 Ultimate, Avast, Scotty is on Patrol and MalwarebytesPremium

frg
 
Posts: 782
Joined: December 15th, 2015, 1:20 pm

Post Posted April 8th, 2019, 11:50 pm

The sites are probably doing incorrect user agent sniffing and / or deliberatly shut browsers they don't want to support out. Nothing SeaMonkey can do here. You can set a user agent override and see if it works. 2.49.5 is planned to be the last 2.49 version.

FRG
Last edited by frg on April 10th, 2019, 11:51 pm, edited 1 time in total.

ndebord

User avatar
 
Posts: 781
Joined: December 7th, 2002, 9:53 am

Post Posted April 9th, 2019, 7:02 pm

frg wrote:The sites are probably doing incorrect user agent sniffing and / or deliberatly shut browsers they don't want to support out. Noting SeaMonkey can do here. You can set a user agent override and see if it works. 2.49.5 is planned to be the last 2.49 version.

FRG


Hi FRG,

Yup.... tried that. I have moved on to 2.53 and have managed to kludge my way through all the extensions that I desire to use. Will see. So far so good with my financial sites.
-N- Quis custodiet ipsos custodes
SeaMonkey 2.49.5, Dell D420, Windows 7 Ultimate, Avast, Scotty is on Patrol and MalwarebytesPremium

4td8s
 
Posts: 650
Joined: June 24th, 2009, 1:07 pm

Post Posted April 17th, 2019, 8:19 pm

note that WG9s SM 2.49.5 unofficial has not been updated for a while (the Windows ports have not been updated since mid-Jan 2019 and the Linux/Mac ports were last updated early Feb. 2019)

in July 2019 I will permanently stop using any SM 2.49.x version (that's around the time Firefox will release a v68.0 ESR) and will run SM 2.53 and perhaps beta test the 2.57 version from WG9S

therube

User avatar
 
Posts: 19959
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 18th, 2019, 12:31 pm

I can log in to some of them, but can't do anything there, most options are greyed out.

What sites?

some (not all) of the extensions that worked with 2.49.5 no longer work with 2.53

Which?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

4td8s
 
Posts: 650
Joined: June 24th, 2009, 1:07 pm

Post Posted May 19th, 2019, 1:50 am

4td8s wrote:note that WG9s SM 2.49.5 unofficial has not been updated for a while (the Windows ports have not been updated since mid-Jan 2019 and the Linux/Mac ports were last updated early Feb. 2019)


I can take this back since wg9s is recently providing new unofficial SM 2.49.5 builds this May 2019

latest wg9s build for 2.49.5 on his web site was dated 5/16/2019

4td8s
 
Posts: 650
Joined: June 24th, 2009, 1:07 pm

Post Posted July 2nd, 2019, 6:43 pm

unofficial 2.49.5 from WG9s updated June 29, 2019 :)

IdOp
 
Posts: 17
Joined: May 16th, 2013, 12:42 pm

Post Posted July 11th, 2019, 8:00 am

Technically OT, but probably of interest: looks like Seamonkey 2.49.5 official candidate binaries are starting to appear. So far just linux-i686-it. Using it now. :)

Bac_a_sable
 
Posts: 23
Joined: January 1st, 2017, 12:35 pm
Location: Near Lyon / France in Europe

Post Posted July 11th, 2019, 9:03 am

Sounds good :)

IdOp
 
Posts: 17
Joined: May 16th, 2013, 12:42 pm

Post Posted August 7th, 2019, 8:01 am

Following up, an official candidate second build has appeared. :)

therube

User avatar
 
Posts: 19959
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted August 7th, 2019, 6:09 pm

(Expect a third build.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Dan Kies
 
Posts: 128
Joined: November 9th, 2002, 12:14 am
Location: Subjunctive {Sydney, NYC, Chicago, Paris} Indicative {Hell}

Post Posted August 11th, 2019, 9:58 am

Hello everyone,

I tried the official candidate that IdOp linked above. However, one problem keeps me from using any build after 2.49.4: I need an operational java plugin within the browser.

Can anyone point me in some directions where I can keep current on SeaMonkey development AND continue to use a java plugin?

Regards,

Dan

frg
 
Posts: 782
Joined: December 15th, 2015, 1:20 pm

Post Posted August 11th, 2019, 12:51 pm

The Windows and Linux x86 2.49.5 versions might still support it. For all other platforms, all x64 builds and all later releases it is dead and no longer supported.

https://www.java.com/en/download/faq/firefox_java.xml

James
Moderator

User avatar
 
Posts: 27616
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted August 11th, 2019, 1:05 pm

Win64 Firefox 52 ESR only allowed Flash Player and Silverlight to run as you needed 32-bit (on Windows) Firefox 52 ESR at the time to run other NPAPI Plugins like Java. Mac OSX and Linux could support all NPAPI Plugins at the time whether 32-bit or 64-bit. Ever since the Firefox 52.0 Release to current only the Flash Player Plugin (NPAPI) has been allowed to run. What happened with NPAPI Plugins and Firefox basically affected SeaMonkey in this case.

Dan Kies, you probably went from using 32-bit SeaMonkey (as WOW64 in useragent shows) to the SeaMonkey 2.49.5 Win64 build you have now as to why the ever vulnerable NPAPI Java Plugin does not run now.

Dan Kies
 
Posts: 128
Joined: November 9th, 2002, 12:14 am
Location: Subjunctive {Sydney, NYC, Chicago, Paris} Indicative {Hell}

Post Posted August 11th, 2019, 9:29 pm

Thank you frg and James,

You are both correct about the win32 build. Everything is working fine in the win32 build of 2.49.5.

Thanks for pointing me in the right direction, and I am kicking myself because I should have remembered that difference between the 32 and 64 windows build myself.

Thanks again.

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 0 guests